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About This Manual

Use this manual to familiarize yourself with LabVIEW SignalExpress 
interactive measurements and the basic LabVIEW SignalExpress features 
that you use to acquire and analyze signals.

This manual contains exercises that help you begin working with 
LabVIEW SignalExpress. These exercises teach you how to run projects, 
configure steps, work with signals, configure sweep measurements, log 
data, and extend LabVIEW SignalExpress with LabVIEW graphical 
programming.

Conventions
The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes input and 
output names, parameter names, dialog boxes, sections of dialog boxes, and 
menu names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction 
to a key concept. Italic text also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard. This font is also used for the proper names of disk drives, paths, 
directories, programs, subprograms, subroutines, device names, functions, 
operations, variables, filenames, and extensions.

Related Documentation
Refer to the LabVIEW SignalExpress Help, available by selecting Help»
LabVIEW SignalExpress Help, for more information as you read this 
manual.



© National Instruments Corporation 1-1 Getting Started with LabVIEW SignalExpress

1
Introduction to LabVIEW 
SignalExpress

National Instruments provides innovative solutions for scientists 
and engineers to build automated measurement systems based on 
industry-standard computers and platforms. National Instruments develops 
robust, industry-leading programming environments for automating 
measurement systems, such as LabVIEW for graphical development, 
LabWindows™/CVI™ for ANSI C programming, and Measurement Studio 
for Microsoft Visual Studio programming. You can use these programming 
tools with National Instruments measurement hardware and interfaces to 
traditional instruments to build custom, advanced virtual instrumentation 
systems.

LabVIEW SignalExpress optimizes virtual instrumentation for design 
engineers by offering instant interactive measurements that require no 
programming. You can use LabVIEW SignalExpress interactively to 
acquire, generate, analyze, compare, import, and log signals. You can 
compare design data with measurement data in one step. LabVIEW 
SignalExpress extends the ease of use and performance of virtual 
instrumentation to those who must acquire or analyze signals without 
programming applications. You also can extend the functionality of 
LabVIEW SignalExpress by importing a custom virtual instrument (VI) 
created in the LabVIEW Development System or by converting a 
LabVIEW SignalExpress project to a LabVIEW block diagram so you can 
continue development in LabVIEW. Refer to Chapter 7, Extending 
LabVIEW SignalExpress Projects with LabVIEW, for more information.
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2
Installing LabVIEW 
SignalExpress

You can use the LabVIEW SignalExpress CD to install LabVIEW 
SignalExpress and complete the exercises in this manual.

LabVIEW SignalExpress LE
LabVIEW SignalExpress LE gives you a 30-day trial of the Full version of 
LabVIEW SignalExpress. After that period, you must activate your version 
of LabVIEW SignalExpress LE or purchase the Full version. If you activate 
your version of LabVIEW SignalExpress LE before your 30-day trial of the 
full version is complete, the full features are still available for the remainder 
of your 30-day trial. You can use LabVIEW SignalExpress LE to complete 
simple data acquisition and logging functions.

If you do not register your version of LabVIEW SignalExpress LE after 
30 days, LabVIEW SignalExpress LE runs with the following limitations:

• You can no longer save projects, so you cannot convert projects into 
LabVIEW block diagrams.

• You can run projects for only 10 minutes per session.

Refer to the National Instruments Web site at ni.com/signalexpress to 
purchase the full version of LabVIEW SignalExpress.

Minimum System Requirements
LabVIEW SignalExpress requires a minimum of 256 MB of RAM and a 
Pentium III or later or Celeron 866 MHz or equivalent processor, but 
National Instruments recommends 512 MB of RAM and a Pentium 4/M or 
equivalent processor.

http://www.ni.com/signalexpress
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Installing LabVIEW SignalExpress
Complete the following steps to install LabVIEW SignalExpress on 
Windows Vista/XP/2000/NT.

Note If you want to convert LabVIEW SignalExpress projects to LabVIEW block 
diagrams, you must install LabVIEW 7.1 or later before you install LabVIEW 
SignalExpress.

1. Disable any automatic virus detection programs before you install. 
Some virus detection programs interfere with the installation program.

2. Log on as an administrator or as a user with administrator privileges.

3. Insert the LabVIEW SignalExpress Development or Evaluation CD 
and follow the instructions that appear on the screen.

By default, LabVIEW SignalExpress installs in the Program Files\
National Instruments\SignalExpress directory.

4. After installation, check the hard disk for viruses and enable any virus 
detection programs you disabled.

The example projects you use with this manual are located in 
SignalExpress\Examples\Tutorial. The solutions for each exercise 
are located in SignalExpress\Examples\Tutorial\Solutions.

If you use LabVIEW SignalExpress with National Instruments data 
acquisition or modular instrumentation hardware, you must install 
NI-DAQmx 8.5 or later, NI-SCOPE 2.7 or later, NI-FGEN 2.2 or later, or 
NI-DMM 2.4.2. LabVIEW SignalExpress includes a National Instruments 
Driver CD that includes these drivers.
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3
Working with Projects

You can use LabVIEW SignalExpress to define measurement procedures 
by adding and configuring steps in an interactive measurement 
environment. A step is a configurable function that acquires, generates, 
analyzes, loads, or stores signals. Most steps process input signals and 
produce output signals. You can configure the operation of a step by 
specifying values in a configuration view. A saved sequence of configured 
steps is a LabVIEW SignalExpress project.

This chapter teaches you how to load and run existing projects and how to 
configure steps in these projects.

Opening a Project
Complete the following steps to load a sample project in LabVIEW 
SignalExpress.

1. Launch LabVIEW SignalExpress.

Notice that LabVIEW SignalExpress is split into three main views: the 
Project View on the left, the Data View in the middle, and the help on 
the right. Within the Data View, you should see the Data View tab, the 
Logging Options tab, and the Project Documentation tab.

2. If LabVIEW SignalExpress does not open in the factory-default 
configuration, select View»Data View to display the Data View.

3. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click the First 
Project.seproj LabVIEW SignalExpress project. 

4. Examine the window that appears, as shown in Figure 3-1 with the 
help hidden, to learn about different components of LabVIEW 
SignalExpress.
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Figure 3-1.  First Project.seproj

The left pane is the Project View, which presents the order of 
operations, or steps, for the project. The right pane is the Data View, 
which displays the signal that the project generates and analyzes.

Running a Project and Displaying Signals
LabVIEW SignalExpress has two execution modes—Run and Run Once. 
When you click the Run button, LabVIEW SignalExpress executes all 
steps in the project continuously until you click the Stop button. The Stop 
button appears in place of the Run button as a project runs. While the steps 
in the project execute, the Data View updates continuously. While the 
project runs, you can change the measurement configurations and view the 

1 Execution control buttons
2 Work Area pull-down menu
3 Step

4 Input
5 Output
6 Project View

7 Logged Data window
8 Data View
9 Record button

5

8

5

1

3

4

2

9

6

7
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results immediately. If you modify the configuration of steps while a 
project runs, LabVIEW SignalExpress gives you direct, immediate 
feedback on the changes you make. When you click the Run Once button, 
LabVIEW SignalExpress executes all steps in the project one time.

Complete the following steps to run the sample project and display signals.

1. Click the Run button, shown at left, to execute all steps in the project 
continuously.

The project loads a signal from a text file and performs two operations 
on the signal—an amplitude and levels measurement and a distortion 
measurement. The Amplitude and Levels step and the Distortion step 
perform these measurements, respectively. When you run a project, 
steps analyze input signals and generate new output signals as a result 
of the analysis. In this project, the Load from ASCII step loads a 
distorted sine wave, the Amplitude and Levels step and the Distortion 
step analyze the sine wave, and both steps return new outputs. In the 
Project View, LabVIEW SignalExpress indicates inputs with red 
arrows and outputs with blue arrows.

The graph in the Data View still contains the loaded signal, which is a 
time-domain signal. Graphs display time-domain, frequency-domain, 
or x-y signals. 

2. Click the exported spectrum output signal of the Distortion step in the 
Project View and drag it to the Data View to display the signal. 

LabVIEW SignalExpress creates a new graph in the Data View. 
LabVIEW SignalExpress does not display the exported spectrum 
signal on the same graph as the time-domain signal because the 
exported spectrum signal is a frequency-domain signal. LabVIEW 
SignalExpress automatically recognizes different types of signals and 
renders them in the appropriate displays.

3. Select Help»LabVIEW SignalExpress Help, click the Search tab, 
and enter "signal types" to refer to the LabVIEW SignalExpress 
Help for more information about signal types. The help provides 
information about using LabVIEW SignalExpress functionality such 
as projects, steps, and signals.

4. Click the dc output of the Amplitude and Levels step and drag it to the 
Data View to display the measurement. 

LabVIEW SignalExpress creates a table to display the scalar 
measurement from the dc output.
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5. Drag the rms output to the table to display the scalar RMS 
measurement.

LabVIEW SignalExpress creates a new row in the table to display the 
second measurement. The project should appear as shown in 
Figure 3-2.

Figure 3-2.  Outputs of First Project.seproj

Configuring a Step
A step is a configurable function that acquires, generates, analyzes, loads, 
or stores signals. Steps process input signals and produce output signals. 
You can configure the operation of a step in SignalExpress by specifying 
values in the Step Setup dialog box, or configuration view, for that step. 
While a project runs, you can modify the configuration of steps to view 
immediate feedback on the changes and adjust the measurements until you 
achieve the results you need.
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Complete the following steps to configure the Distortion step and the 
Amplitude and Levels step.

1. Double-click the Distortion step in the Project View. The Step Setup 
dialog box for the Distortion step appears, as shown in Figure 3-3.

Figure 3-3.  Distortion Step Setup Dialog Box

On the Configuration tab, the settings indicate that the Distortion step 
receives a time-domain waveform signal as an input, performs a power 
spectrum on the signal to convert it to the frequency domain, and 
computes the total harmonic distortion (THD) and fundamental 
frequency of the signal. The step generates three measurements as 
outputs—the spectrum, the THD, and the fundamental frequency of 
the original time-domain waveform input.

2. If the context help does not appear on the right side of the screen, click 
the Show Help button, shown at left, to display complete reference 
information about the step. The upper half of the context help displays 
information about the step, and the lower half of the context help 
displays information about an object when you move the cursor over 
the object.
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3. On the Configuration tab, select Fundamental Tone from the 
Export signals (THD) pull-down menu.

The operation of the step changes from displaying the 
frequency-domain spectrum of the entire input signal to displaying 
only the frequency spectrum of the fundamental tone of the input 
signal. The graphed signals in the top half of the Step Setup dialog box 
update to reflect the change you made.

4. Select Harmonics Only from the Export signals (THD) pull-down 
menu.

The step changes to export only the spectrum of the harmonic signals 
from the input signal. Both the output signal of the Distortion step and 
the graph on the Data View update to reflect the change you made.

5. Click the Amplitude and Levels step in the Project View. 

The Step Setup dialog box changes from displaying the configuration 
of the Distortion step to displaying the configuration of the Amplitude 
and Levels step.
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6. Click the Input/Output tab to display the list of possible inputs and 
outputs for this step, as shown in Figure 3-4.

Figure 3-4.  Amplitude and Levels Step Setup Dialog Box

7. Place checkmarks in the Export +peak value, Export -peak value, 
and Export peak-peak value checkboxes to configure the Amplitude 
and Levels step to return three additional measurements.

Three additional outputs appear in the Project View.

8. Click the Data View tab to display the Data View.

9. Drag the three new outputs from the Project View to the table to 
display the scalar measurements.

10. Click the Stop button, shown at left, to stop the project.

When you click the Stop button, the project stops running after 
completing the current cycle of operations, or the current iteration. 
Click the down arrow on the Stop button and click the Abort button to 
completely stop the project without finishing the current iteration.
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11. Select File»Save Project As and save the project as My First 
Project.seproj in the SignalExpress\Examples\Tutorial 
directory.

12. Select File»Close Project to close the project.

Moving and Deleting Steps
The steps in SignalExpress projects depend on input data, which means 
steps can operate only on signals exported from previous steps in the 
Project View. When you click the Input signal pull-down menu on the 
Input tab of the Step Setup dialog box of a step, the menu displays only 
compatible signals exported from a previous step. When the output of a 
step becomes the input of another step, the steps become dependent on each 
other, and the two steps execute sequentially at the same rate. The first step 
generates an output signal that the second step must receive as an input 
before the step can execute.

You can move a step within a project by dragging it up or down in the 
Project View. You can delete a step by right-clicking it in the Project View 
and selecting Delete from the shortcut menu. However, when you move or 
delete a step, the status of signals in the project changes. For example, if 
you delete a step that generates output signals, the operation of the project 
breaks if any of the deleted output signals are inputs for other steps, and an 
error indicator appears in the Project View. You also can cut, copy, and 
paste steps within a project by pressing the <Ctrl-X>, <Ctrl-C>, and 
<Ctrl-V> keys, respectively, or by right-clicking a step in the Project View 
and selecting Cut, Copy, Paste Before Selected Step, or Paste After 
Selected Step from the shortcut menu.

Handling Errors and Warnings
If an error occurs while a project runs, an error indicator, shown at left, 
appears in the Project View on the step that encountered the error. 
Double-click the step with the error to display an error description across 
the bottom of the Step Setup dialog box. Click the Details button to the 
right of the error description to display the full error description.

SignalExpress logs all errors and warnings in the Event Log while a project 
runs. To display the Event Log, select View»Event Log and click the Event 
Log tab in the Data View area. Refer to the LabVIEW SignalExpress Help for 
more information about errors and warnings by selecting Help»LabVIEW 
SignalExpress Help, clicking the Search tab, and entering errors.
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4
Working with Signals

You can use LabVIEW SignalExpress to generate and analyze signals to 
evaluate designs without programming. This chapter teaches you how to 
work with signals in LabVIEW SignalExpress, including how to plot 
signals on graphs, import signals from a file, interactively align and 
compare two signals, and save signals to a file.

Graphing Signals
Complete the following steps to plot signals in a sample project and 
examine the signals visually using cursors.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click 
Signals.seproj. This project configures the Create Signal step 
to create a square wave signal and the Filter step to perform a lowpass 
Butterworth filter.

2. Drag the step signal output of the Create Signal step to the Data View.

3. Drag the filtered step output of the Filter step to the Data View.

You can plot signals of the same signal type on the same graph. Both 
the step signal and the filtered step signals are time-domain signals, 
so they appear on the same graph. If you want to plot signals of 
different types, drag the signals to the same graph and LabVIEW 
SignalExpress creates a new graph.

4. Click the Add Display button, shown at left, on the toolbar to create a 
new graph.

5. Drag the filtered step output of the Filter step to the new graph.
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6. Right-click the new graph and select Visible Items»Cursors from the 
shortcut menu to display two interactive cursors, as shown in 
Figure 4-1.

Figure 4-1.  Signals.seproj

As you drag the cursors, LabVIEW SignalExpress displays the x and 
y values of the cursors in the cursor table at the bottom of the Data 
View.

7. Select File»Save Project As and save the project as 
My Signals.seproj in the SignalExpress\Examples\
Tutorial directory.
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Importing a Signal from a File
You can import signals from standard file formats such as ASCII comma- 
or tab-delimited files and LabVIEW measurement data files (.lvm). You 
also can import signals from simulated results of EDA tools such as SPICE 
simulators.

Complete the following steps to import a signal from a file.

1. Right-click the Project View and select Load/Save Signals»Analog 
Signals»Load from ASCII from the shortcut menu.

2. Click the browse button, shown at left, in the Step Setup dialog box, 
navigate to the SignalExpress\Examples\Tutorial directory, 
and double-click Step Response.txt. This step parses an ASCII file 
and displays the signals in the file.

In the File preview section, column 1 shows the time stamp data, and 
column 2 shows the actual voltage values of the signal.

3. Click the Import Signals tab to display the available signals in the file.

4. Place a checkmark in the Column 2 checkbox to import that signal, 
and remove the checkmark from the Column 1 checkbox.

The Step Setup dialog box displays a preview of the signal in the 
Imported Signal section.

5. Select Column 1 from the Input X values pull-down menu to set the 
x-axis data of the waveform to the appropriate values.

6. Open the Data View.

7. Right-click the Column 2 output in the Project View and select 
Rename from the shortcut menu.

8. Enter step response and press the <Enter> key to rename the output.

9. Drag the step response output of the Load from ASCII step to the 
lower graph in the Data View.

The filtered step signal resembles the rising edge of the step response 
output, as shown in Figure 4-2.
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Figure 4-2.  Signals of Signals.seproj

10. Select File»Save Project to save the project.

Aligning and Comparing Signals
Although the filtered step signal and the step response output both show 
an overshoot in the rising edge, assessing the similarity between the two 
is difficult because the signals come from different sources and vary in 
amplitude and timing. However, you can use the Interactive Alignment step 
to align and compare two signals, so you can choose which type of 
information you want to export from the operation to use in the project.

Complete the following steps to align two signals in the 
My Signals.seproj project.

1. Right-click the step response output and select Send To»
Processing»Analog Signals»Interactive Alignment from the 
shortcut menu to pass the step response signal from the Load from 
ASCII step to the Interactive Alignment step.
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The step selects the two most recent signals from the project to use as 
inputs and displays the signals on the graph of the Step Setup dialog 
box, as shown in Figure 4-3.

Figure 4-3.  Interactive Alignment Step Setup Dialog Box

When you add a step to a project, LabVIEW SignalExpress selects 
input signals based on the signal types the step can accept. For 
example, the Interactive Alignment step can operate only on 
time-domain waveform signals. Therefore, the step selects as inputs 
the last two time-domain signals created in the project. To change the 
input signals for a step, select different signals from the pull-down 
menu of compatible signals in the Input/Output tab of the Step Setup 
dialog box.

2. Click the red signal in the Input Signals graph and drag it to another 
point within the graph.

You can drag, expand, and contract signals on the graph.

3. Try to align the rising edges of the two signals by dragging a signal 
within the graph. Click a signal to set an anchor point and press and 
hold the <Alt> key to stretch the signal around that anchor point in the 
x and y directions.
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On the Alignment tab of the Step Setup dialog box, the step computes 
and displays the x and y gain and offset values you need to achieve 
alignment specifications as you drag the signals.

4. Select Auto - Step from the Mode pull-down menu to align the 
signals. LabVIEW SignalExpress bases this alignment mode on 
built-in algorithms.

The lower graph in the Step Setup dialog box displays the difference 
between the two signals.

5. On the Input/Output tab, place a checkmark in the Export aligned 
signals checkbox to add the signals to the outputs of the step.

6. Select the Data View tab to open the Data View.

7. Click the Add Display button, shown at left, to add a third graph.

8. Drag the aligned reference and aligned test outputs of the Interactive 
Alignment step to the new graph to view the aligned signals.

9. Select File»Save Project to save the project.

Signal Types in LabVIEW SignalExpress
Some steps, such as the Arithmetic step, can operate on multiple signal 
types. For example, you can use the Arithmetic step to operate on 
time-domain or frequency-domain waveforms. The Arithmetic step 
changes behavior based on the type of input signals you select for the 
step. For example, if you add two time-domain signals, LabVIEW 
SignalExpress adds only their amplitudes. However, if you add two 
frequency-domain phase signals, LabVIEW SignalExpress adds the 
appropriate phase shift.

Refer to the LabVIEW SignalExpress Help for more information by 
selecting Help»LabVIEW SignalExpress Help, clicking the Search tab, 
and entering "signal types".

Exporting and Printing Signals
You can use LabVIEW SignalExpress to document signals or continue 
analysis in another software application. This section teaches you how to 
export signals, including sending signals to an ASCII file, sending data to 
Microsoft Excel, printing signals, and using the built-in documentation 
feature to document the LabVIEW SignalExpress project.
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Saving Signals to File
Complete the following steps to save a signal to a file.

1. Click the Add Step button and select Load/Save Signals»Analog 
Signals»Save to ASCII/LVM.

2. Click the Signals tab in the Step Setup dialog box and select filtered 
step from the Input Data pull-down menu.

3. On the File Settings tab, save the file to SignalExpress\
Examples\Tutorial\filtered signal.txt in the Export file 
path control.

4. Select Overwrite from the If file already exists pull-down menu.

5. Select Generic ASCII from the Export file type pull-down menu.

You can use a Load/Save Signals step to save data to a file every time 
the project runs.

6. Click the Close button to close the Step Setup dialog box.

7. Click the Run button to run the project and save the resulting signal to 
the specified ASCII file.

8. Select File»Save Project to save the project.

9. Select File»Close Project to close the project.

Exporting Signals to Microsoft Excel
To export signal data to Microsoft Excel, launch Excel and drag the output 
signal of a step in LabVIEW SignalExpress to an Excel spreadsheet.

Printing Signals
To print an image of a graph, open the Data View and select File»Print»
Print Data View.

Creating Reports in LabVIEW SignalExpress
Select View»Project Documentation to display the Project Documentation 
View. You can describe your project using text and drag and drop step 
outputs into your documentation. When you drag and drop a step output into 
the Project Documentation View, the value in the Project Documentation 
View automatically updates to match the current value of the step output. 

To print your documentation, open the Project Documentation View and 
select File»Print»Print Documentation. To export your documentation to 
HTML, open the Project Documentation View and select File»Export»
Export Documentation to HTML.
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5
Logging Data

You can use LabVIEW SignalExpress to record and analyze 
measurements. You can record any time-domain, double, U32, or Boolean 
step output. You also can analyze and process logged data by playing it 
through analysis steps. 

This chapter teaches you how to record data using the integrated data 
logging features in LabVIEW SignalExpress. You learn how to record a 
specified signal, play back that signal, and analyze the signal using analysis 
steps. You also learn how to use the Recording Options View to log signals 
based on specified start or stop conditions. 

Recording a Signal
You can use the Record button to configure a data logging process. 

Complete the following steps to specify a signal to record and to record the 
signal.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click 
Logging.seproj.

This project uses the Create Signal step to generate a signal based on a 
formula.

2. Click the Record button, shown at left, to open the Logging Signals 
Selection dialog box.

The Logging Signals Selection dialog box displays the signals in the 
project available for recording. You can select one signal or multiple 
signals to record. You also can specify a name and description for 
the log.

3. Place a checkmark in the signal checkbox to record the formula signal 
generated in the Create Signal step.

4. Click the OK button to close the Logging Signals Selection dialog 
box and begin recording the signal. The logging operation continues 
until you click the Stop button.
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5. Click the Stop button, shown at left, to stop logging the signal. 

The logged data appears in the Logged Data window, as shown in 
Figure 5-1.

Figure 5-1.  Logged Data Window

By default, LabVIEW SignalExpress names the logged data according 
to the date and time you recorded the data. LabVIEW SignalExpress 
saves logged data in the .tdms file format in the directory you specify 
in the Options dialog box. 

6. Select Tools»Options and select the Logging option to specify the 
directory for LabVIEW SignalExpress to save the logged data and to 
customize various preferences for logged data.

7. Click the OK button to close the Options dialog box.

8. Select File»Save Project to save the project.

Viewing a Logged Signal
Complete the following steps to view the logged data.

1. If the Data View is not visible, select View»Data View to display the 
Data View. 

2. The Logged Data window displays a list of all logged data in the 
current project. Select the data log you just recorded from the Logged 
Data window and drag it into the Data View. The Data View displays 
the logged data and a preview graph, as shown in Figure 5-2. The 
signal displayed in the Data View may differ from the signal displayed 
in Figure 5-2, depending on how long you record the signal.
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Figure 5-2.  Logging.seproj

The preview graph provides a method for zooming and panning 
through data in the Data View. The preview graph appears by default 
when viewing logged data. When viewing live or non-logged data, 
right-click the Data View and select Visible Items»Preview to display 
the preview graph.

3. Click the Zoom In button next to the preview graph to zoom in on the 
logged signal. The cursors on the preview graph show the subset of 
data currently displayed on the preview graph. Use the scroll bar 
beneath the preview graph to scroll through the data. Click and drag the 
cursors on the preview graph to increase or decrease the subset of data 
you are viewing.

Logging Signals with Predefined Start and Stop 
Conditions

You can configure start and stop conditions that the signals must meet 
before LabVIEW SignalExpress records or stops recording the signals. 
Complete the following steps to log data based on start and stop conditions.

1. If the Recording Options tab is not visible, select View»Recording 
Options to open the Recording Options View.
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2. Select Signal Selection in the Category list in the Recording Options 
View.

3. Place a checkmark next to the signal in the Record column, as shown 
in Figure 5-3.

Figure 5-3.  Signal Selection

The Record button changes to the Record While Running button, 
shown at left. Ensure the Record While Running button is pressed. 
When the Record While Running button is pressed, LabVIEW 
SignalExpress records the selected signal when you click the Run or 
Run Once button.

4. Select Start Conditions in the Category list in the Recording Options 
View. 

5. Click the Add button in the Logging start conditions page to 
customize a start condition for your logging task.

a. Select the Signal option in the Condition source control to 
specify for LabVIEW SignalExpress to begin recording when the 
input signal meets the specified condition.

b. Select signal in the Signal control.
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c. Select Rising slope in the Condition control to begin recording 
the signal based on the value of the edge of the signal on a positive 
slope.

d. Enter 1 in the Value control to begin recording when the signal 
crosses 1 on a rising slope.

6. Select Stop Conditions in the Category list in the Recording Options 
View.

7. Click the Add button in the Logging stop conditions page to 
customize a stop condition for your logging task.

a. Select the Duration option in the Condition source control.

b. Enter 5 in the Duration control to record the signal for 5 seconds 
after the signal meets the start condition.

c. Click the Run button, shown at left. LabVIEW SignalExpress 
begins recording the signal when the signal crosses level 1 on a 
rising slope and continues recording the signal for 5 seconds. 

The Recording indicator on the bottom of the Recording Options 
View will turn on when the signal meets the start condition and 
logging is in progress. The Disk information indicator displays 
the available hard disk space on the computer for the log.

Analyzing Logged Signals
After you log a signal, you can play back the logged data or run the logged 
signal through analysis steps, just as you can with live data. Complete the 
following steps to analyze a logged signal.

1. Navigate to the Work Area pull-down menu on the top left of the 
LabVIEW SignalExpress window, as shown in Figure 5-4. Click the 
down arrow and select Playback to switch to the Playback work area.

Figure 5-4.  Work Area pull-down menu

Use work areas to perform multiple LabVIEW SignalExpress 
operations from within the same project. You can acquire data, process 
signals, record data, and perform measurements on logged data 
without opening a new project. When you save your project, 
LabVIEW SignalExpress saves every work area within the project in 
the same project file.
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The default work area, Monitor/Record, allows you to take 
measurements, analyze live data, and log data. You must be in the 
Playback work area to use logged data as an input for an analysis step. 
For example, you can take a measurement and log the signal in the 
Monitor/Record work area, and then run the logged data through an 
analysis step in the Playback work area.

2. Click the Add Step button, shown at left, and select the Filter step from 
Processing»Analog Signals»Filter. LabVIEW SignalExpress 
automatically selects the first signal you logged as the input to the 
Filter step.

3. Navigate to the Data View. Drag the filtered data output of the Filter 
step into the Data View to view the resulting signal.

4. Click the Run button, shown at left. The Data View displays the 
resulting filtered signal and LabVIEW SignalExpress plays back the 
entire log.

Advanced Playback
You can configure advanced data playback options by using the Playback 
Options View. The Playback Options View displays a preview of the 
logged data and allows you to select a subset of that data to play back or run 
through analysis steps.

1. Select View»Playback Options to open the Playback Options View, 
as shown in Figure 5-5. The Playback Options View allows you to 
preview the logged data, as well as specify a subset of the logged data 
to play back or send to analysis steps. 
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Figure 5-5.  Playback Options View

2. Select signal from the second log you created in the Logged signal 
listbox.

3. Enter 1 in the Start time control to play back or analyze a subset of the 
logged signal beginning 1 second after the start of the log. 

4. Enter 4 in the Stop time control to play back or analyze a subset of the 
logged signal ending four seconds after the start of the log.

5. Switch to the Data View and drag the filtered data output of the Filter 
step into the Data View.

6. Click the Run button, shown at left. LabVIEW SignalExpress filters 
the subset of the signal you specified in the Playback Options View and 
displays the resulting filtered signal in the Data View.

7. Click the Stop button to stop running the project.

Refer to the LabVIEW SignalExpress Help for more information about 
logging data, such as specifying alarm conditions and playback options.
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6
Performing Sweep 
Measurements

You can use LabVIEW SignalExpress to automate measurements to 
characterize and validate designs by creating sweep operations. You can 
use the sweep measurements to gather data from designs over a range of 
conditions to document the performance of the designs. For example, you 
can use sweep operations to vary the frequency of a stimulus signal or vary 
the level of a supply voltage while taking measurements to characterize 
designs.

This chapter teaches you how to set up sweep operations using the Sweep 
step in LabVIEW SignalExpress. You learn how to characterize the 
performance of a filter by sweeping through a range of frequency values 
and measuring the output of the filter. You also learn how to display sweep 
results and perform multidimensional sweeps for more complex 
measurements.

Defining Sweep Ranges and Outputs
You can use the Sweep step in LabVIEW SignalExpress to define 
automated measurements for complex, repeatable sweep operations.

Complete the following steps to define a frequency range in a sample 
project to sweep through a filter.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click Sweep.seproj.

2. Click the Run button, shown at left, to run the project.

The project generates a sine wave stimulus signal using the Create 
Signal step, passes it through a bandpass elliptic filter using the Filter 
step, measures the RMS level of the filter output using the Amplitude 
and Levels step, and converts the level to decibels (dB) using the 
Formula step. The Filter step acts as a simulated unit under test, so the 
project uses no hardware. However, you also can sweep physical 
signals generated from a National Instruments arbitrary waveform 
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generator, function generator, dynamic signal analyses, or 
multifunction I/O (MIO) device.

3. Click the Add Step button, shown at left, and select Execution 
Control»Sweep.

4. Click the Add button in the Step Setup dialog box to display the list 
of sweep parameters from each step in the project, as shown in 
Figure 6-1.

Figure 6-1.  Sweep Parameter Selection Dialog Box

5. Select the Frequency parameter under Create Signal and click the 
OK button.

The Sweep step encloses the Create Signal step, which provides the 
signal to sweep.

6. On the Sweep Configuration tab, select Exponential from the Type 
pull-down menu.

7. Enter 1k in the Start Frequency (Hz) field, and enter 40k in the Stop 
Frequency (Hz) field.

8. Enter 150 in the Number of points field.

The Sweep Configuration tab should appear as shown in Figure 6-2.
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Figure 6-2.  Sweep Step Setup Dialog Box

You used the Sweep step to specify a range of values to iterate through 
the Frequency parameter of the Create Signal step. The Create Signal 
step uses the defined frequency range to generate a sine wave at each 
of these frequencies. However, you can use the Sweep step to sweep 
any sweepable parameter value of any sweepable step in a project.

9. Click the Sweep Output tab.

10. Click the Add button to display the list of sweep outputs from each 
step in the project.

11. Select the response amplitude in dB output under Formula and click 
the OK button to plot this measurement against the swept Frequency 
parameter.

The Sweep step creates a loop around all the steps in the Project View 
to include all the steps in the sweep operation.



Chapter 6 Performing Sweep Measurements

Getting Started with LabVIEW SignalExpress 6-4 ni.com

Plotting Sweep Results
Complete the following steps to run the sweep measurement.

1. Click the Run Once button, shown at left, to execute the sweep 
measurement.

The stimulus signal output on the graph iterates through the specified 
range of frequencies.

2. Drag the response amplitude in dB vs. Frequency signal from the 
bottom of the Sweep loop to the Data View to display the output of the 
sweep.

LabVIEW SignalExpress creates a new graph. The data from a sweep 
operation is an x-y array that requires a separate graph, as shown in 
Figure 6-3.

Figure 6-3.  Sweep.seproj
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3. Click the Run Once button again to execute the sweep.

The frequency response of the Filter step plots on the new graph while 
the project runs. The graph displays the transfer function of the filter, 
or the amplitude output expressed in decibels versus the frequency.

4. Double-click the Filter step to display the filter specifications in the 
Step Setup dialog box.

The frequency response of the filter in the Filter Magnitude 
Response graph matches the graph in the Data View.

5. Select File»Save Project As and save the project as 
My Sweep.seproj in the SignalExpress\Examples\Tutorial 
directory.

You can use the Sweep step to sweep multiple parameters simultaneously 
by adding additional parameters on the Sweep Configuration tab of the 
Sweep Step Setup dialog box. Sweeping two or more parameters 
simultaneously is called a parallel sweep. For example, if you want to vary 
the amplitude of a stimulus signal, you can run a parallel sweep. You can 
use a parallel sweep to maximize the precision of the acquisition by varying 
the input range of a digitizer or MIO device as you vary the signal level. As 
the signal level increases, you can increase the input range of the 
measurement device to ensure you use the entire resolution for the 
measurement.

Running Multidimensional Sweeps
Use multidimensional, or nested, sweeps to iterate through one range while 
you vary another range. For example, if you want to sweep through 
frequencies of a stimulus signal at different amplitudes, run a nested sweep. 
You can set the amplitude to level 1 and sweep through frequencies, and 
then set the amplitude to level 2 and sweep through frequencies, and so on. 
You can build a nested sweep by right-clicking a Sweep step in a project 
and selecting Add Dimension from the shortcut menu to add another 
sweep loop. 

Complete the following steps to run a sample nested sweep project.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click Nested 
Sweep.seproj.

2. Click the Run button, shown at left, to run the project.

Each iteration of the inner sweep loop sweeps the frequency of the 
stimulus signal. The outer sweep loop varies the low and high cutoff 
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frequencies of the Filter step. Each iteration appears in real time on the 
upper graph, and then appears on the lower graph to display all the 
sweeps at each cutoff frequency setting, as shown in Figure 6-4.

Figure 6-4.  Nested Sweep.seproj

3. Click the Stop button, shown at left, to stop the project.
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7
Extending LabVIEW 
SignalExpress Projects with 
LabVIEW

You can use LabVIEW SignalExpress to define automated measurements 
by using built-in steps for acquiring, generating, analyzing, or logging 
signals. You can extend the functionality of LabVIEW SignalExpress 
projects by using LabVIEW in the following ways:

• Build a VI in LabVIEW and import this VI into LabVIEW 
SignalExpress to provide custom step functionality and expand the 
number of steps available in LabVIEW SignalExpress.

• Convert a LabVIEW SignalExpress project to a LabVIEW block 
diagram to continue development in LabVIEW.

You must have LabVIEW 7.1 or later to complete the exercises in this 
chapter.

Importing LabVIEW VIs into LabVIEW SignalExpress as 
Steps

Use the Run LabVIEW VI step in LabVIEW SignalExpress to call custom 
LabVIEW VIs. You can call a LabVIEW VI from LabVIEW 
SignalExpress to do the following:

• Control GPIB instruments

• Control National Instruments hardware that LabVIEW SignalExpress 
does not support

• Read or write data to more file formats

• Display operator instructions in a pop-up dialog box

• Define a measurement algorithm
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Complete the following steps to import a VI from LabVIEW with the Run 
LabVIEW VI Step.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial directory, and double-click User 
Step.seproj.

This project uses the Create Signal step to generate a signal.

2. Click the Add Step button and select Run LabVIEW VI»Run 
LabVIEW 8.2 VI. 

The VI you run in this exercise was saved in LabVIEW 8.2. You must 
use the version of the Run LabVIEW VI step that matches the version 
of LabVIEW you saved your VI in.

3. Click the browse button on the Step Setup dialog box and select 
Limiter-LV82.vi in the LabVIEW SignalExpress\Examples\
Tutorial directory. The Limiter-LV82 VI accepts a time-domain 
waveform as an input, clips the signal above and below values that you 
specify in the Step Setup dialog box, and returns the clipped 
waveform as an output signal.

When you import a LabVIEW VI, LabVIEW SignalExpress maps the 
inputs of the VI as parameters and the outputs of the VI as output 
signals in LabVIEW SignalExpress.

You can define whether the inputs for VIs become input signals or 
parameters. An input signal appears in the Project View as an input to 
a step, which means you can pass signals as inputs to a VI. A parameter 
is a value you can configure on the Step Setup dialog box of a step. 
You also can sweep parameters dynamically using the Sweep step. In 
this project, the VI has an input signal, Time waveform in, and scalar 
parameters, Upper limit and Lower limit.

Verify that the Step Setup dialog box appears as shown in Figure 7-1.
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Figure 7-1.  Limiter VI Step Setup Dialog Box

4. Click the Run button, shown at left, to run the project. 

5. Drag the Clipped waveform out output signal from the Limiter.vi step 
to the Data View.

6. Double-click the Limiter.vi step to display the Step Setup dialog box.

7. Select the Configure VI tab to display the VI. 

8. Enter new values in the Upper limit and Lower limit fields. For 
example, enter 100 in the Upper limit field.

9. Click the Apply button to apply the changes.

10. Click the Close button to close the VI and click the Close button to 
close the Step Setup dialog box.

The Clipped waveform out signal changes on the Data View to reflect 
the changes you made.

Refer to the LabVIEW SignalExpress Help for more information about 
using LabVIEW VIs in LabVIEW SignalExpress and building VIs that 
work well in LabVIEW SignalExpress.
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Converting LabVIEW SignalExpress Projects to 
LabVIEW Block Diagrams

LabVIEW SignalExpress can convert LabVIEW SignalExpress projects 
into LabVIEW block diagrams.

Note To convert an LabVIEW SignalExpress project to a LabVIEW VI, you must have 
the LabVIEW 7.1 Full Development System or greater installed.

Complete the following steps to convert a LabVIEW SignalExpress project 
to a LabVIEW block diagram.

1. Select File»Open Project, navigate to the SignalExpress\
Examples\Tutorial\Solutions and double-click My First 
Project.seproj.

2. Select Tools»Generate Code»LabVIEW Diagram.

3. Specify a filename and location for the new LabVIEW VI and click the 
OK button.

The resulting LabVIEW block diagram reflects the execution of the 
project in LabVIEW SignalExpress. The LabVIEW block diagram 
consists of LabVIEW Express VIs wired together. Each Express VI 
correlates to a step in the LabVIEW SignalExpress project. You can 
double-click an Express VI to display the same Step Setup dialog box 
as in LabVIEW SignalExpress. You also can right-click an Express VI 
and select Open Front Panel from the shortcut menu to convert the 
Express VI into a LabVIEW subVI. You can view the block diagram 
to see how the LabVIEW block diagram executes and modify the 
functionality of the VI. When you convert an Express VI into a subVI, 
you cannot convert the subVI back into an Express VI.

Note When you convert a LabVIEW SignalExpress project with logging, LabVIEW 
SignalExpress generates a LabVIEW block diagram with one Express VI. You cannot 
convert the generated Express VI into a subVI.
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8
Where to Go from Here

Refer to the following resources for more information about LabVIEW 
SignalExpress.

LabVIEW SignalExpress Sample Projects
LabVIEW SignalExpress provides a variety of sample projects that 
demonstrate more capabilities of LabVIEW SignalExpress. These projects 
are located in the SignalExpress\Examples directory. Review these 
examples to learn more about the features of LabVIEW SignalExpress or 
to start with a project that closely resembles your needs.

Using Hardware with LabVIEW SignalExpress
This manual does not describe how to control hardware from LabVIEW 
SignalExpress because LabVIEW SignalExpress supports a variety of 
National Instruments hardware for acquiring and generating signals. You 
can generate or acquire and log analog signals in SignalExpress using 
National Instruments MIO devices, dynamic signal acquisition devices, 
high-speed digitizers, or arbitrary waveform generator and function 
generator devices. You also can synchronize multiple devices in a system 
by sharing clocks and trigger signals between devices. Refer to the 
LabVIEW SignalExpress Help by selecting Help»LabVIEW 
SignalExpress Help for more information about using hardware with 
LabVIEW SignalExpress.

Web Resources
Refer to the National Instruments Web site at ni.com/signalexpress 
for resources such as example projects, technical documents, and 
LabVIEW VIs written for use in LabVIEW SignalExpress.

http://www.ni.com/signalexpress
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A
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources at ni.com/support 
include the following:

– Self-Help Resources—For immediate answers and solutions, 
visit the award-winning National Instruments Web site for 
software drivers and updates, a searchable KnowledgeBase, 
product manuals, step-by-step troubleshooting wizards, thousands 
of example programs, tutorials, application notes, instrument 
drivers, and so on.

– Free Technical Support—All registered users receive free Basic 
Service, which includes access to hundreds of Application 
Engineers worldwide in the NI Developer Exchange at 
ni.com/exchange. National Instruments Application Engineers 
make sure every question receives an answer.

• Training and Certification—Visit ni.com/training for 
self-paced training, eLearning virtual classrooms, interactive CDs, 
and Certification program information. You also can register for 
instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, National Instruments 
Alliance Partner members can help. To learn more, call your local 
NI office or visit ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.

http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp04
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp07
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp08
http://digital.ni.com/productpages/nialliance.nsf/main?readform
http://www.ni.com/cgi-bin/redirect.cgi?dest=infcoprod&src=lvhelp&openagent&code=rdbp10
http://ni.com
http://ni.com
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À propos de ce manuel

Utilisez ce manuel pour vous familiariser avec les mesures interactives dans 
LabVIEW SignalExpress et les fonctionnalités de base de LabVIEW 
SignalExpress que vous utilisez pour acquérir et analyser des signaux.

Ce manuel contient des exercices qui vous aident à prendre en main 
LabVIEW SignalExpress. Ces exercices vous apprennent comment 
exécuter des projets, configurer des étapes, manipuler des signaux, 
configurer des mesures de balayage, enregistrer des données et étendre les 
possibilités de LabVIEW SignalExpress avec l’environnement de 
programmation graphique LabVIEW.

Conventions
Les conventions suivantes apparaissent dans ce manuel :

» Le symbole » vous guide à travers les éléments de menu imbriqués et les 
options de boîte de dialogue pour une action finale. Ainsi, la séquence 
Fichier»Mise en page»Options indique qu’il vous faut dérouler le menu 
Fichier, sélectionner l’élément Mise en page et sélectionner Options dans 
la dernière boîte de dialogue.

Cette icône représente une remarque qui vous donne des informations 
importantes.

gras Du texte en caractères gras représente un élément que vous devez 
sélectionner ou sur lequel vous devez cliquer dans le logiciel, comme les 
éléments de menu ou les options de boîte de dialogue. Du texte en 
caractères gras indique également des noms d’entrées et de sorties, des 
noms de paramètres, des boîtes de dialogue, des sections de boîte de 
dialogue et des noms de menus.

italique Du texte en italique signale les variables, la mise en valeur, une référence 
croisée ou une introduction à un concept-clé. Il indique également un texte 
que vous devez remplacer par un mot ou une valeur.

monospace Du texte dans cette police indique du texte ou des caractères qui doivent 
être entrés avec le clavier. Cette police est également utilisée pour les noms 
des disques durs, des chemins, des répertoires, des programmes, des 
sous-programmes, des noms des périphériques, des fonctions, des 
opérations, des variables et des noms de fichiers et d’extensions.
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Documentation associée
Reportez-vous à l’Aide LabVIEW Signal Express, disponible en 
sélectionnant Aide»Aide LabVIEW Signal Express, pour obtenir des 
informations complémentaires.
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1
Introduction à LabVIEW 
SignalExpress

National Instruments offre des solutions innovatrices aux scientifiques et 
aux ingénieurs pour construire des systèmes de mesure automatisés basés 
sur les plates-formes et les ordinateurs conformes aux normes de 
l’industrie. National Instruments développe des environnements de 
programmation robustes, à la pointe de la technologie, comme LabVIEW 
pour le développement graphique, LabWindows™/CVI™ pour la 
programmation en C ANSI et Measurement Studio pour la programmation 
avec Microsoft Visual Studio. Vous pouvez utiliser ces outils de 
programmation avec le matériel de mesure de National Instruments et les 
interfaces vers les instruments traditionnels pour construire des systèmes 
d’instrumentation virtuelle avancés.

LabVIEW SignalExpress optimise l’instrumentation virtuelle pour les 
ingénieurs concepteurs en offrant des mesures interactives instantanées qui 
ne requièrent aucune programmation. Vous pouvez utiliser LabVIEW 
SignalExpress de manière interactive pour acquérir, générer, analyser, 
comparer, importer et enregistrer des signaux. Vous pouvez comparer des 
données de conception avec des données de mesure en une étape. 
LabVIEW SignalExpress apporte la simplicité d’utilisation et les 
performances de l’instrumentation virtuelle aux personnes qui doivent 
acquérir ou analyser des signaux sans programmer des applications. Vous 
pouvez aussi étendre les fonctionnalités de LabVIEW SignalExpress en 
important un VI (instrument virtuel) personnalisé créé dans 
l’environnement de développement graphique LabVIEW ou en 
convertissant un projet LabVIEW SignalExpress en un diagramme 
LabVIEW ce qui vous permet de poursuivre le développement dans 
l’environnement LabVIEW. Reportez-vous au chapitre 7, Extension des 
projets LabVIEW SignalExpress avec LabVIEW, pour obtenir de plus 
amples informations.
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2
Installation de LabVIEW 
SignalExpress

Vous pouvez utiliser le CD LabVIEW SignalExpress pour installer 
LabVIEW SignalExpress et effectuer les exercices de ce manuel.

LabVIEW SignalExpress LE
LabVIEW SignalExpress LE vous offre une période d’évaluation de 
30 jours de la version complète de LabVIEW SignalExpress. Une fois cette 
période écoulée, vous devez activer votre version de LabVIEW 
SignalExpress LE ou acheter la version complète. Si vous activez votre 
version de SignalExpress LE avant la fin des 30 jours d’évaluation, toutes 
les fonctionnalités resteront disponibles pendant le restant de la période 
d’évaluation. Vous pouvez utiliser LabVIEW SignalExpress LE pour 
effectuer une acquisition de données simple et enregistrer des fonctions.

Si vous n’enregistrez pas la version LE de LabVIEW SignalExpress dans 
un délai de 30 jours, elle s’exécute avec les limites suivantes :

• Vous ne pouvez plus enregistrer les projets et vous ne pouvez donc pas 
convertir les projets en diagrammes LabVIEW.

• Vous pouvez exécuter des projets à raison de 10 minutes seulement par 
session.

Reportez-vous au site Web de National Instruments sur ni.com/
signalexpress pour acheter la version complète de LabVIEW 
SignalExpress.

Configuration système minimale requise
LabVIEW SignalExpress exige un minimum de 256 Mo de RAM et un 
processeur Pentium III ou plus récent, ou un processeur Celeron 866 MHz 
ou équivalent, mais National Instruments recommande 512 Mo de RAM et 
un processeur Pentium 4/M ou équivalent.

http://www.ni.com/signalexpress
http://www.ni.com/signalexpress


Chapitre 2 Installation de LabVIEW SignalExpress

Initiation à LabVIEW SignalExpress 2-2 ni.com

Installation de LabVIEW SignalExpress
Effectuez les étapes suivantes pour installer LabVIEW SignalExpress sous 
Windows Vista/XP/2000/NT.

Remarque Si vous voulez convertir des projets LabVIEW SignalExpress en diagrammes 
LabVIEW, vous devez installer LabVIEW 7.1 ou une version ultérieure avant d’installer 
LabVIEW SignalExpress.

1. Désactivez tous les programmes de détection automatique de virus 
avant de procéder à l’installation. Certains programmes de détection de 
virus interfèrent avec le programme d’installation.

2. Ouvrez une session en tant qu’administrateur ou en tant qu’utilisateur 
jouissant de privilèges d’administrateur.

3. Insérez le CD LabVIEW SignalExpress Development ou le CD 
d’évaluation et suivez les instructions qui s’affichent à l’écran.

Par défaut, LabVIEW SignalExpress s’installe dans le répertoire 
Program Files\National Instruments\SignalExpress.

4. Après l’installation, vérifiez que le disque dur ne contient pas de virus 
et activez les programmes de détection de virus que vous aviez 
éventuellement désactivés.

Les projets d’exemple que vous utilisez avec ce manuel se trouvent dans le 
répertoire SignalExpress\Examples\Tutorial. Les solutions des 
exercices se trouvent dans SignalExpress\Examples\Tutorial\
Solutions.

Si vous utilisez LabVIEW SignalExpress avec du matériel National 
Instruments d’acquisition de données ou d’instrumentation modulaire, 
vous devez installer NI-DAQmx 8.5 ou une version ultérieure, 
NI-SCOPE 2.7 ou une version ultérieure, ou NI-FGEN 2.2 ou une version 
ultérieure ou NI-DMM 2.4.2. LabVIEW SignalExpress comprend un CD 
de drivers National Instruments qui intègre ces drivers.
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3
Travailler avec des projets

Vous pouvez utiliser LabVIEW SignalExpress pour définir des procédures 
de mesure en ajoutant et en configurant des étapes dans un environnement 
de mesure interactif. Une étape est une fonction configurable qui acquiert, 
génère, analyse, charge ou enregistre des signaux. La plupart des étapes 
traitent des signaux en entrée et produisent des signaux en sortie. Vous 
pouvez configurer le fonctionnement d’une étape en spécifiant des valeurs 
sur la page de configuration. Une séquence enregistrée d’étapes 
configurées constitue un projet LabVIEW SignalExpress.

Ce chapitre vous apprend à charger et à exécuter des projets existants et à 
configurer des étapes dans ces projets.

Ouverture d’un projet
Effectuez les étapes suivantes pour charger un projet d’exemple dans 
LabVIEW SignalExpress.

1. Lancez LabVIEW SignalExpress.

Notez que LabVIEW SignalExpress se divise en trois parties 
principales : la Vue du projet à gauche, l’Affichage des données au 
centre et l’aide à droite. Dans l’Affichage des données, vous voyez les 
onglets Affichage des données, Options d’enregistrement et 
Documentation du projet.

2. Si LabVIEW SignalExpress ne s’ouvre pas dans la configuration par 
défaut, sélectionnez Affichage»Affichage des données pour afficher 
l’Affichage des données.

3. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur le 
projet LabVIEW SignalExpress First Project.seproj. 

4. Observez la fenêtre qui apparaît, montrée avec l’aide masquée dans la 
figure 3-1, pour vous familiariser avec les différents composants de 
LabVIEW SignalExpress.
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Figure 3-1.  First Project.seproj

Le panneau de gauche est la Vue du projet qui présente l’ordre des 
opérations, ou étapes, du projet. Le panneau de droite est l’Affichage 
des données qui présente le signal que le projet génère et analyse.

Exécution d’un projet et affichage de signaux
LabVIEW SignalExpress possède deux modes d’exécution : Exécuter et 
Exécuter une fois. Lorsque vous cliquez sur le bouton Exécuter, LabVIEW 
SignalExpress exécute toutes les étapes du projet en continu jusqu’à ce que 
vous cliquiez sur le bouton Arrêter. Le bouton Arrêter apparaît à la place 
du bouton Exécuter lorsqu’un projet s’exécute. L’Affichage des données 
se met à jour continuellement pendant que les étapes du projet s’exécutent. 
Pendant que le projet s’exécute, vous pouvez changer les configurations de 
mesure et afficher les résultats immédiatement. Si vous modifiez la 
configuration des étapes pendant qu’un projet s’exécute, LabVIEW 

1 Boutons de contrôle d’exécution
2 Menu déroulant Zone de travail
3 Étape

4  Entrée
5  Sortie
6 Vue du projet

7 Fenêtre Données enregistrées
8 Affichage des données
9 Bouton Enregistrer

5

8

5

1

3

4

2

9

6

7
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SignalExpress vous donne un retour d’informations immédiat et direct sur 
les modifications que vous avez effectuées. Lorsque vous cliquez sur le 
bouton Exécuter une fois, LabVIEW SignalExpress exécute toutes les 
étapes du projet une seule fois.

Effectuez les étapes suivantes pour exécuter le projet d’exemple et afficher 
des signaux.

1. Cliquez sur le bouton Exécuter, montré à gauche, pour exécuter toutes 
les étapes du projet de manière continue.

Le projet charge un signal à partir d’un fichier texte et effectue deux 
opérations sur le signal : une mesure de l’amplitude et des niveaux et 
une mesure de distorsion. L’étape Amplitude et niveaux et l’étape 
Distorsion effectuent ces mesures, respectivement. Lorsque vous 
exécutez un projet, les étapes analysent des signaux en entrée et 
génèrent de nouveaux signaux en sortie comme résultat de l’analyse. 
Dans ce projet, l’étape Charger un fichier ASCII charge un signal 
sinusoïdal déformé, l’étape Amplitude et niveaux et l’étape Distorsion 
analysent le signal sinusoïdal et les deux renvoient de nouvelles 
sorties. Dans la Vue du projet, LabVIEW SignalExpress indique les 
entrées avec des flèches rouges et les sorties avec des flèches bleues.

Le graphe dans l’Affichage des données contient toujours le signal 
chargé, qui est un signal du domaine temporel. Les graphes affichent 
des signaux x-y, du domaine fréquentiel ou du domaine temporel. 

2. Cliquez sur le signal en sortie spectre exporté dans l’étape Distorsion 
de la Vue du projet et faites-le glisser sur l’Affichage des données pour 
afficher le signal. 

LabVIEW SignalExpress crée un nouveau graphe dans l’Affichage des 
données. LabVIEW SignalExpress n’affiche pas le signal spectre 
exporté sur le même graphe que le signal du domaine temporel car le 
signal spectre exporté est un signal du domaine fréquentiel. 
LabVIEW SignalExpress reconnaît automatiquement les différents 
types de signaux et les affiche en fonction de leur type.

3. Sélectionnez Aide»Aide LabVIEW SignalExpress, cliquez sur 
l’onglet Rechercher et entrez "types de signaux" pour vous 
référer à l’Aide LabVIEW SignalExpress pour obtenir des informations 
complémentaires sur les types de signaux. L’aide offre des 
informations sur l’utilisation des fonctionnalités de LabVIEW 
SignalExpress telles que les projets, les étapes et les signaux.
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4. Cliquez sur la sortie cc de l’étape Amplitude et niveaux et faites-la 
glisser sur l’Affichage des données pour afficher la mesure. 

LabVIEW SignalExpress crée une table pour afficher la mesure 
scalaire dans la sortie cc.

5. Faites-glisser la sortie Veff vers la table pour afficher la mesure rms 
scalaire.

LabVIEW SignalExpress crée une nouvelle ligne dans la table pour 
afficher la deuxième mesure. Le projet doit ressembler à la figure 3-2.

Figure 3-2.  Sorties de First Project.seproj
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Configuration d’une étape
Une étape est une fonction configurable qui acquiert, génère, analyse, 
charge ou enregistre des signaux. Les étapes traitent des signaux en 
entrée et produisent des signaux en sortie. Vous pouvez configurer le 
fonctionnement d’une étape dans SignalExpress en spécifiant des valeurs 
dans la boîte de dialogue Configuration de l’étape, ou la page de 
configuration, de cette étape. Pendant qu’un projet s’exécute, vous pouvez 
modifier la configuration des étapes pour afficher immédiatement le retour 
d’informations sur les modifications et ajuster les mesures jusqu’à ce que 
vous obteniez les résultats escomptés.

Effectuez les étapes suivantes pour configurer l’étape Distorsion et l’étape 
Amplitude et niveaux.

1. Double-cliquez sur l’étape Distorsion dans la Vue du projet. La boîte 
de dialogue Configuration de l’étape pour l’étape Distorsion apparaît, 
comme le montre la figure 3-3.

Figure 3-3.  Boîte de dialogue de configuration de l’étape Distorsion
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Sur l’onglet Configuration, les paramètres indiquent que l’étape 
Distorsion reçoit un signal temporel sous forme d’une entrée, effectue 
un spectre de puissance sur le signal pour le convertir en domaine 
fréquentiel et calcule la distorsion harmonique totale (DHT) et la 
fréquence fondamentale du signal. L’étape génère trois mesures sous 
forme de sorties : le spectre, la DHT et la fréquence fondamentale de 
l’entrée du signal du domaine temporel d’origine.

2. Si l’aide contextuelle n’apparaît pas à droite de l’écran, cliquez 
sur le bouton Afficher l’aide, montré à gauche, pour afficher des 
informations de référence complètes sur l’étape. La partie supérieure 
de l’aide contextuelle affiche des informations sur l’étape, et la partie 
inférieure de l’aide contextuelle affiche des informations sur un objet 
lorsque vous déplacez le curseur sur celui-ci.

3. Sur l’onglet Configuration, sélectionnez Ton fondamental dans le 
menu déroulant Signaux à exporter (DHT).

Le fonctionnement de l’étape passe de l’affichage du spectre du 
domaine fréquentiel du signal en entrée complet à l’affichage du 
spectre de fréquence du ton fondamental du signal en entrée 
uniquement. Les signaux représentés dans la partie supérieure de la 
boîte de dialogue Configuration de l’étape se mettent à jour pour 
refléter la modification que vous avez effectuée.

4. Sélectionnez Harmoniques uniquement dans le menu déroulant 
Signaux à exporter (DHT).

L’étape exporte alors uniquement le spectre des signaux harmoniques 
du signal en entrée. Le signal en sortie de l’étape Distorsion et le 
graphe de l’Affichage des données se mettent à jour pour refléter la 
modification que vous avez apportée.

5. Cliquez sur l’étape Amplitude et niveaux dans la Vue du projet. 

La boîte de dialogue Configuration de l’étape qui affichait la 
configuration de l’étape Distorsion, affiche désormais la configuration 
de l’étape Amplitude et niveaux.
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6. Cliquez sur l’onglet Entrée/Sortie pour afficher la liste des entrées et 
des sorties possibles pour cette étape, comme le montre la figure 3-4.

Figure 3-4.  Boîte de dialogue de configuration de l’étape Amplitude et niveaux

7. Cochez les cases Exporter la valeur max., Exporter la valeur min. 
et Exporter la valeur de pic à pic pour configurer l’étape Amplitude 
et niveaux pour renvoyer trois mesures supplémentaires.

Trois sorties supplémentaires apparaissent dans la Vue du projet.

8. Cliquez sur l’onglet Affichage des données pour afficher l’Affichage 
des données.

9. Faites glisser les trois nouvelles entrées dans la Vue du projet vers la 
table pour afficher les mesures scalaires.

10. Cliquez sur le bouton Arrêter, montré à gauche, pour arrêter le projet.

Lorsque vous cliquez sur le bouton Arrêter, le projet arrête de 
s’exécuter après avoir terminé le cycle de fonctionnement actuel ou 
l’itération actuelle. Cliquez sur la flèche vers le bas à droite du bouton 
Arrêter et cliquez sur le bouton Abandonner pour arrêter 
complètement le projet sans terminer l’itération en cours.

11. Sélectionnez Fichier»Enregistrer le projet sous et enregistrez le 
projet sous Mon premier projet.seproj dans le répertoire 
SignalExpress\Examples\Tutorial.

12. Sélectionnez Fichier»Fermer le projet pour fermer le projet.
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Déplacement et suppression d’étapes
Les étapes des projets SignalExpress dépendent des données en entrée, ce 
qui signifie qu’elles ne peuvent fonctionner qu’avec des signaux provenant 
des étapes précédentes de la Vue du projet. Lorsque vous cliquez sur le 
menu déroulant Signal en entrée de l’onglet Entrée de la boîte de dialogue 
Configuration de l’étape, le menu affiche uniquement des signaux 
compatibles exportés par une étape précédente. Lorsque la sortie d’une 
étape devient l’entrée d’une autre étape, les deux étapes deviennent 
dépendantes l’une de l’autre et s’exécutent de manière séquentielle, à la 
même fréquence. La première étape génère un signal en sortie que la 
deuxième étape reçoit comme entrée avant de pouvoir s’exécuter.

Vous pouvez déplacer une étape dans un projet en la faisant glisser vers le 
haut ou vers le bas dans la Vue du projet. Vous pouvez supprimer une étape 
en faisant un clic droit dessus dans la Vue du projet et en sélectionnant 
Supprimer dans le menu local. Toutefois, lorsque vous déplacez ou 
supprimez une étape, l’état des signaux du projet change. Par exemple, 
si vous supprimez une étape qui génère des signaux en sortie, le 
fonctionnement du projet est brisé si l’un des signaux en sortie supprimés 
est l’entrée d’une autre étape et un indicateur d’erreur apparaît dans la Vue 
du projet. Vous pouvez aussi couper, copier et coller des étapes dans un 
projet en appuyant respectivement sur les touches <Ctrl-X>, <Ctrl-C> et 
<Ctrl-V>, ou en cliquant avec le bouton droit sur la Vue du projet et en 
sélectionnant Couper, Copier, Coller avant l’étape sélectionnée ou 
Coller après l’étape sélectionnée dans le menu local.

Gestion des erreurs et des mises en garde
Si une erreur se produit pendant qu’un projet s’exécute, un indicateur 
d’erreur, montré à gauche, apparaît dans la Vue du projet sur l’étape dans 
laquelle l’erreur s’est produite. Double-cliquez sur l’étape où l’erreur s’est 
produite pour afficher sa description au bas de la boîte de dialogue 
Configuration de l’étape. Cliquez sur le bouton Détails à droite de la 
description de l’erreur pour afficher la description complète.

SignalExpress enregistre toutes les erreurs et les mises en garde dans le 
journal d’événements pendant l’exécution d’un projet. Pour afficher le 
journal des événements, sélectionnez Affichage»Journal d’événements 
puis cliquez sur l’onglet Journal d’événements dans la zone Affichage des 
données. Reportez-vous à l’LabVIEW SignalExpress Help pour obtenir des 
informations complémentaires sur les erreurs et les mises en garde en 
sélectionnant Aide»Aide LabVIEW SignalExpress, en cliquant sur 
l’onglet Rechercher et en entrant erreurs.
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4
Manipulation de signaux

Vous pouvez utiliser LabVIEW SignalExpress pour générer et analyser des 
signaux afin d’évaluer des projets de conception sans programmation. 
Ce chapitre vous apprend à travailler avec des signaux dans LabVIEW  
SignalExpress, en vous indiquant notamment comment tracer des signaux 
sur des graphes, importer des signaux d’un fichier, aligner et comparer 
deux signaux de manière interactive et enregistrer des signaux dans un 
fichier.

Représentation de signaux dans des graphes
Effectuez les étapes suivantes pour tracer des signaux dans un projet 
d’exemple et examiner visuellement les signaux à l’aide de curseurs.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur 
Signals.seproj. Ce projet configure l’étape Créer un signal 
analogique pour qu’elle permette de créer un signal carré et l’étape 
Filtre pour réaliser un filtre Butterworth passe-bas.

2. Faites glisser la sortie step signal de l’étape Créer un signal analogique 
vers l’Affichage des données.

3. Faites glisser la sortie filtered step de l’étape Filtre vers l’onglet 
Affichage des données.

Vous pouvez tracer des signaux du même type sur le même graphe. 
Comme les signaux step signal et filtered step sont tous deux des 
signaux temporels, ils apparaissent sur le même graphe. Si vous voulez 
tracer des signaux de différents types, faites-les glisser sur le même 
graphe et LabVIEW SignalExpress se chargera de créer un nouveau 
graphe.

4. Cliquez sur le bouton Ajouter un volet de la barre d’outils, représenté 
à gauche, pour créer un nouveau graphe.

5. Faites glisser la sortie filtered step de l’étape Filtre vers le nouveau 
graphe.
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6. Faites un clic droit sur le nouveau graphe et sélectionnez Éléments 
visibles»Curseurs dans le menu local pour afficher deux curseurs 
interactifs, comme le montre la figure 4-1.

Figure 4-1.  Signals.seproj

Quand vous déplacez les curseurs, LabVIEW SignalExpress affiche 
les valeurs x et y des curseurs dans le tableau de curseurs au bas de 
l’Affichage des données.

7. Sélectionnez Fichier»Enregistrer le projet sous et enregistrez le 
projet sous Mes signaux.seproj dans le répertoire 
SignalExpress\Examples\Tutorial.
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Importation d’un signal à partir d’un fichier
Vous pouvez importer des signaux de formats de fichier standard comme 
des fichiers ASCII délimités par des virgules ou des tabulations et des 
fichiers de données de mesures LabVIEW (.lvm). Vous pouvez aussi 
importer des signaux à partir de résultats simulés d’outils EDA comme des 
simulateurs SPICE.

Suivez les étapes ci-après pour importer un signal d’un fichier.

1. Cliquez avec le bouton droit sur la Vue du projet et sélectionnez 
Charger/Enregistrer des signaux»Signaux analogiques»Charger 
un fichier ASCII dans le menu local.

2. Cliquez sur le bouton Parcourir, représenté à gauche, dans la boîte de 
dialogue Configuration de l’étape, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur Step 
Response.txt. Cette étape analyse un fichier ASCII et affiche les 
signaux dans le fichier.

Dans la section Aperçu du fichier, la colonne 1 affiche les 
informations d’horodatage et la colonne 2 indique les valeurs de 
tension réelles du signal.

3. Cliquez sur l’onglet Signaux à importer pour afficher les signaux 
disponibles dans le fichier.

4. Cochez l’option Colonne 2 pour importer ce signal et désélectionnez 
l’option Colonne 1.

La boîte de dialogue Configuration de l’étape affiche un aperçu du 
signal dans la section Signal importé.

5. Sélectionnez Colonne 1 dans le menu déroulant Valeurs X en entrée 
pour définir les données de l’axe x de la waveform aux valeurs 
appropriées.

6. Ouvrez l’Affichage des données.

7. Faites un clic droit sur la sortie Colonne 2 dans la Vue du projet et 
sélectionnez Renommer dans le menu local.

8. Entrez réponse indicielle et appuyez sur la touche <Entrée> pour 
renommer la sortie.

9. Faites glisser la sortie réponse indicielle de l’étape Charger un fichier 
ASCII vers le graphe du bas dans l’Affichage des données.
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Le signal filtered step ressemble au front montant de la sortie réponse 
indicielle, comme l’indique la figure 4-2.

Figure 4-2.  Signals of Signals.seproj

10. Sélectionnez Fichier»Enregistrer le projet pour enregistrer le projet.

Alignement et comparaison de signaux
Bien que le signal filtered step et la sortie réponse indicielle montrent tous 
les deux un overshoot dans le front montant, il est difficile d’évaluer leur 
similarité car ces signaux proviennent de sources différentes et ont une 
amplitude et un cadencement différents. Toutefois, vous pouvez utiliser 
l’étape Alignement interactif pour aligner et comparer deux signaux, de 
sorte que vous puissiez choisir quel type d’informations vous voulez 
exporter de l’opération pour pouvoir les utiliser dans le projet.



Chapitre 4 Manipulation de signaux

© National Instruments Corporation 4-5 Initiation à LabVIEW SignalExpress

Suivez les étapes ci-après pour aligner deux signaux dans le projet Mes 
signaux.seproj.

1. Cliquez avec le bouton droit sur la sortie réponse indicielle et 
sélectionnez Envoyer vers»Traitement»Signaux analogiques»
Alignement interactif dans le menu local pour transmettre le signal 
réponse indicielle de l’étape Charger un fichier ASCII à l’étape 
Alignement interactif.

L’étape sélectionne les deux signaux les plus récents dans le projet à 
utiliser comme entrées et affiche les signaux sur le graphe de la boîte 
de dialogue Configuration de l’étape, comme le montre la figure 4-3.

Figure 4-3.  Boîte de dialogue de configuration de l’étape Alignement interactif

Lorsque vous ajoutez une étape dans un projet, LabVIEW 
SignalExpress sélectionne les signaux en entrée en fonction des types 
de signaux que l’étape accepte. Par exemple, l’étape Alignement 
interactif ne peut être utilisée que sur des signaux waveform du 
domaine temporel. Par conséquent, l’étape sélectionne comme entrées 
les deux signaux du domaine temporel créés dans le projet. Pour 
changer les signaux en entrée d’une étape, sélectionnez différents 
signaux dans le menu déroulant de signaux compatibles dans l’onglet 
Entrée/Sortie de la boîte de dialogue Configuration de l’étape.
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2. Cliquez sur le signal rouge dans le graphe Signaux en entrée et 
faites-le glisser vers un autre point du graphe.

Vous pouvez faire glisser, étendre et réduire des signaux sur le graphe.

3. Essayez d’aligner les fronts montants de deux signaux en faisant 
glisser un signal dans le graphe. Cliquez sur un signal pour définir le 
point d’ancrage et maintenez la touche <Alt> enfoncée pour étendre le 
signal autour de ce point d’ancrage dans le sens des x et des y.

Sur l’onglet Alignement de la boîte de dialogue Configuration de 
l’étape, l’étape calcule et affiche le gain des x et des y et les valeurs 
d’offset dont vous avez besoin pour atteindre les spécifications 
d’alignement lorsque vous faites glisser les signaux.

4. Sélectionnez Auto - Créneau dans le menu déroulant Mode pour 
aligner les signaux. LabVIEW SignalExpress base ce mode 
d’alignement sur des algorithmes intégrés.

Le graphe du bas de la boîte de dialogue Configuration de l’étape 
affiche la différence entre les deux signaux.

5. Sur l’onglet Entrée/Sortie, cochez l’option Exporter les signaux 
alignés pour ajouter les signaux aux sorties de l’étape.

6. Sélectionnez l’onglet Affichage des données pour ouvrir l’Affichage 
des données.

7. Cliquez sur le bouton Ajouter un volet, montré à gauche, pour ajouter 
un troisième graphe.

8. Faites glisser les sorties référence alignée et test aligné de l’étape 
Alignement interactif dans le nouveau graphe pour afficher les signaux 
alignés.

9. Sélectionnez Fichier»Enregistrer le projet pour enregistrer le projet.

Types de signaux dans LabVIEW SignalExpress
Certaines étapes, comme l’étape Arithmétique, peuvent fonctionner avec 
plusieurs types de signaux. Par exemple, vous pouvez utiliser l’étape 
Arithmétique pour manipuler des signaux des domaines fréquentiel et 
temporel. L’étape Arithmétique adapte son comportement en fonction du 
type de signaux en entrée que vous sélectionnez pour cette étape. Par 
exemple, si vous ajoutez deux signaux du domaine temporel, LabVIEW 
SignalExpress ajoute uniquement leur amplitude. Toutefois, si vous 
ajoutez deux signaux de phase du domaine fréquentiel, LabVIEW 
SignalExpress ajoute le seuil de décalage approprié.
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Reportez-vous à l’Aide LabVIEW SignalExpress pour obtenir des 
informations complémentaires en sélectionnant Aide»Aide LabVIEW 
SignalExpress, en cliquant sur l’onglet Rechercher, et en entrant "types 
de signaux".

Exportation et impression de signaux
Vous pouvez utiliser LabVIEW SignalExpress pour documenter des 
signaux ou continuer des analyses dans d’autres applications logicielles. 
Cette section vous apprend comment exporter des signaux, notamment 
en les envoyant dans un fichier ASCII, en envoyant les données dans 
Microsoft Excel, en imprimant des signaux et en utilisant la fonctionnalité 
de documentation intégrée pour documenter le projet LabVIEW 
SignalExpress.

Enregistrement de signaux dans un fichier
Suivez les étapes ci-après pour enregistrer un signal dans un fichier.

1. Cliquez sur le bouton Ajouter une étape et sélectionnez 
Charger/Enregistrer des signaux»Signaux analogiques»
Enregistrer au format ASCII/LVM.

2. Cliquez sur l’onglet Signaux dans la boîte de dialogue Configuration 
de l’étape et sélectionnez filtered step dans le menu déroulant 
Données en entrée.

3. Sur l’onglet Paramètres du fichier, enregistrez le fichier sous 
SignalExpress\Examples\Tutorial\signal filtré.txt  
dans la commande Chemin du fichier à exporter.

4. Sélectionnez Remplacer dans le menu déroulant Si le fichier existe.

5. Sélectionnez ASCII générique dans le menu déroulant Type du 
fichier à exporter.

Vous pouvez utiliser l’étape Charger/Enregistrer les signaux pour 
enregistrer des données dans un fichier chaque fois que le projet 
s’exécute.

6. Cliquez sur le bouton Exécuter pour exécuter le projet et enregistrer le 
signal résultant dans le fichier ASCII spécifié.

7. Sélectionnez Fichier»Enregistrer le projet pour enregistrer le projet.

8. Sélectionnez Fichier»Fermer le projet pour fermer le projet.
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Exportation de signaux dans Microsoft Excel
Pour exporter des données de signaux dans Microsoft Excel, lancez Excel 
et faites glisser le signal en sortie d’une étape de LabVIEW SignalExpress 
dans un fichier tableur Excel.

Impression de signaux
Pour imprimer une image d’un graphe, ouvrez l’Affichage des données et 
sélectionnez Fichier»Imprimer»Imprimer : Affichage des données.

Création de rapports dans LabVIEW SignalExpress
Sélectionnez Affichage»Documentation du projet pour afficher 
l’affichage de la documentation du projet. Vous pouvez décrire votre projet 
en utilisant du texte en effectuant une opération de glisser-déposer sur les 
sorties des étapes dans votre documentation. Lorsque vous effectuez une 
opération de glisser-déposer sur une sortie d’étape dans l’affichage de la 
documentation du projet, la valeur de l’affichage de la documentation du 
projet se met automatiquement à jour pour refléter la valeur actuelle de la 
sortie de l’étape. 

Pour imprimer la documentation, ouvrez l’affichage de la documentation 
du projet et sélectionnez Fichier»Imprimer»Imprimer la 
documentation. Pour exporter la documentation au format HTML, 
ouvrez l’affichage de la documentation du projet et sélectionnez 
Fichier»Exporter»Exporter la documentation en HTML.
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5
Enregistrement des données

Vous pouvez utiliser LabVIEW SignalExpress pour enregistrer dans un 
fichier journal, enregistrer et analyser vos mesures. Vous pouvez 
enregistrer n’importe quelle sortie d’étape booléenne, U32, double ou du 
domaine temporel. Vous pouvez aussi analyser et traiter les données ainsi 
enregistrées en les relisant avec les étapes d’analyse. 

Ce chapitre vous apprend à enregistrer des données en utilisant les 
fonctionnalités d’enregistrement de données intégrées à LabVIEW 
SignalExpress. Vous apprendrez à enregistrer un signal spécifié, à relire ce 
signal et à l’analyser en utilisant des étapes d’analyse. Vous allez également 
apprendre à utiliser les Options d’enregistrement pour enregistrer des 
signaux en fonction de conditions de démarrage et d’arrêt spécifiées. 

Enregistrement d’un signal
Vous pouvez utiliser le bouton Enregistrer pour configurer un processus 
d’enregistrement de données. 

Effectuez les étapes suivantes pour spécifier le signal à enregistrer et 
l’enregistrer.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur 
Logging.seproj.

Ce projet utilise l’étape Créer un signal analogique pour générer un 
signal sur la base d’une formule.

2. Cliquez sur le bouton Enregistrer, illustré à gauche, pour ouvrir la 
boîte de dialogue Sélection des signaux à enregistrer.

La boîte de dialogue Sélection des signaux à enregistrer affiche les 
signaux dans le projet disponible pour l’enregistrement. Vous pouvez 
sélectionner un ou plusieurs signaux à enregistrer. Vous pouvez aussi 
spécifier un nom et une description pour l’enregistrement.

3. Cochez la case signal pour enregistrer le signal de la formule généré à 
l’étape Créer un signal analogique.
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4. Cliquez sur le bouton OK pour fermer la boîte de dialogue Sélection 
des signaux à enregistrer et commencer l’enregistrement du signal. 
L’enregistrement se poursuit jusqu’à ce que vous cliquiez sur le bouton 
Arrêter.

5. Cliquez sur le bouton Arrêter, montré à gauche, pour arrêter le projet. 

Les données enregistrées apparaissent dans la fenêtre Données 
enregistrées, comme le montre la figure 5-1.

Figure 5-1.  Fenêtre Données enregistrées

Par défaut, LabVIEW SignalExpress nomme les données enregistrées 
d’après la date et l’heure de leur enregistrement. LabVIEW 
SignalExpress enregistre les données au format de fichier .tdms dans 
le répertoire spécifié dans la boîte de dialogue Options. 

6. Sélectionnez Outils»Options puis l’option Enregistrement pour 
spécifier le dossier dans lequel LabVIEW SignalExpress enregistre les 
données et pour personnaliser différentes préférences pour les données 
enregistrées.

7. Cliquez sur le bouton OK pour fermer la boîte de dialogue Options.

8. Sélectionnez Fichier»Enregistrer le projet pour enregistrer le projet.

Affichage d’un signal enregistré dans un journal
Effectuez les étapes suivantes pour afficher les données enregistrées dans 
un fichier journal.

1. Si l’Affichage des données n’est pas visible, sélectionnez 
Affichage»Affichage des données. 

2. La fenêtre Données enregistrées présente la liste de toutes les données 
enregistrées dans le projet actuel. Sélectionnez le journal de données 
que vous venez d’enregistrer dans la fenêtre Données enregistrées et 
faites-le glisser dans l’Affichage des données. L’Affichage des 
données affiche les données enregistrées et un graphe d’aperçu, 
comme le montre la figure 5-2. Le signal affiché dans l’Affichage des 
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données peut différer de celui montré dans la figure 5-2 en fonction de 
la durée d’enregistrement du signal.

Figure 5-2.  Logging.seproj

Le graphe d’aperçu représente une façon d’effectuer un zoom avant ou 
arrière sur les données de l’Affichage des données. Le graphe d’aperçu 
apparaît par défaut lorsque vous affichez les données enregistrées. 
Lorsque vous affichez des données en direct ou non enregistrées, 
cliquez avec le bouton droit sur l’Affichage des données et 
sélectionnez Éléments visibles»Aperçu pour afficher le graphe 
d’aperçu.

3. Cliquez sur le bouton Zoom avant à côté du graphe d’aperçu pour 
effectuer un zoom avant sur le signal enregistré. Les curseurs sur le 
graphe d’aperçu montre le sous-ensemble de données actuellement 
affiché sur le graphe d’aperçu. Utilisez la barre de défilement en 
dessous du graphe d’aperçu pour faire défiler les données. Cliquez sur 
le curseur et faites-le glisser sur le graphe d’aperçu pour agrandir ou 
réduire le sous-ensemble des données affichées.
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Enregistrement de signaux avec des conditions de 
démarrage et d’arrêt prédéfinies

Vous pouvez configurer des conditions de démarrage et d’arrêt que les 
signaux doivent respecter avant que LabVIEW SignalExpress les 
enregistre ou arrête de les enregistrer. Effectuez les étapes suivantes pour 
enregistrer les données en fonction de conditions de démarrage et d’arrêt.

1. Si l’onglet Options d’enregistrement n’est pas visible, sélectionnez 
Affichage»Options d’enregistrement pour ouvrir la fenêtre Options 
d’enregistrement.

2. Sélectionnez Sélection des signaux dans la liste de Catégorie de la 
fenêtre Options d’enregistrement.

3. Cochez la case du signal dans la colonne Enregistrer, comme le 
montre la figure 5-3.

Figure 5-3.  Sélection des signaux

Le bouton Enregistrer devient le bouton Enregistrer pendant 
l’exécution, montré à gauche. Assurez-vous que le bouton 
Enregistrer pendant l’exécution est enclenché. Quand le bouton 
Enregistrer pendant l’exécution est enclenché, LabVIEW 
SignalExpress enregistre le signal sélectionné quand vous cliquez sur 
le bouton Exécuter ou Exécuter une fois.
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4. Sélectionnez Conditions de démarrage dans la liste Catégorie de la 
fenêtre Options d’enregistrement. 

5. Cliquez sur le bouton Ajouter sur la page Conditions de démarrage 
des enregistrements pour personnaliser une condition de démarrage 
pour votre tâche d’enregistrement.

a. Sélectionnez l’option Signal dans la commande Source de 
condition pour spécifier que LabVIEW SignalExpress doit 
commencer l’enregistrement quand le signal en entrée remplit la 
condition spécifiée.

b. Sélectionnez signal dans l’option Signal. 

c. Sélectionnez Pente montante dans l’option Condition pour 
commencer l’enregistrement du signal en fonction de la valeur du 
front du signal sur une pente positive.

d. Entrez 1 dans l’option Valeur pour commencer l’enregistrement 
quand le signal atteint 1 sur une pente montante.

6. Sélectionnez Conditions d’arrêt dans la liste Catégorie de la fenêtre 
Options d’enregistrement.

7. Cliquez sur le bouton Ajouter sur la page Conditions d’arrêt des 
enregistrements pour personnaliser une condition d’arrêt pour votre 
tâche d’enregistrement.

a. Sélectionnez Durée dans l’option Source de condition.

b. Entrez 5 dans le champ de Durée pour enregistrer le signal 
pendant 5 secondes à partir du moment où le signal remplit la 
condition de démarrage.

c. Cliquez sur le bouton Exécuter, montré à gauche. LabVIEW 
SignalExpress commence à enregistrer le signal quand celui-ci 
atteint le niveau 1 sur une pente montante et continue à 
l’enregistrer pendant 5 secondes. 

L’indicateur Enregistrement en bas de la fenêtre Options 
d’enregistrement s’allume lorsque le signal remplit la condition 
de démarrage et reste allumé pendant l’enregistrement. 
L’indicateur Infos sur le disque affiche l’espace disque 
disponible sur l’ordinateur pour le journal.



Chapitre 5 Enregistrement des données

Initiation à LabVIEW SignalExpress 5-6 ni.com

Analyse des signaux enregistrés
Une fois que vous avez enregistré un signal, vous pouvez repasser les 
données enregistrées ou exécuter le signal enregistré via les étapes 
d’analyse, comme vous pouvez le faire avec les données en direct. 
Effectuez les étapes suivantes pour analyser un signal enregistré.

1. Naviguez vers le menu déroulant Zone de travail en haut à gauche de 
la fenêtre LabVIEW SignalExpress, comme le montre la figure 5-4. 
Cliquez sur la flèche vers le bas et sélectionnez Relecture pour passer 
à la zone de travail Relecture.

Figure 5-4.  Menu déroulant Zone de travail

Utilisez des zones de travail pour effectuer plusieurs étapes LabVIEW 
SignalExpress à partir du même projet. Vous pouvez acquérir des 
données, traiter des signaux, enregistrer les données dans un fichier 
journal et effectuer des mesures sur les données enregistrées sans 
devoir ouvrir un nouveau projet. Lorsque vous enregistrez votre projet, 
LabVIEW SignalExpress enregistre toutes les zones de travail qui s’y 
trouvent dans le même fichier de projet.

La zone de travail par défaut, Surveillance/Enregistrement, vous 
permet de prendre des mesures, d’analyser des données en direct et 
d’enregistrer des données. Vous devez vous trouver dans la zone de 
travail Relecture pour utiliser les données enregistrées comme entrée 
d’une étape d’analyse. Par exemple, vous pouvez effectuer une mesure 
et enregistrer le signal dans la zone de travail Surveillance/
Enregistrement, puis exécuter les données enregistrées via une étape 
d’analyse dans la zone de travail Relecture.

2. Cliquez sur le bouton Ajouter une étape, montré à gauche, et 
sélectionnez l’étape Filtre en sélectionnant Traitement»Signaux 
analogiques»Filtre. LabVIEW SignalExpress sélectionne 
automatiquement le premier signal que vous avez enregistré comme 
entrée de l’étape Filtre.

3. Naviguez vers l’Affichage des données. Faites glisser la sortie 
données filtrées de l’étape Filtre dans l’Affichage des données pour 
afficher le signal résultant.

4. Cliquez sur le bouton Exécuter, montré à gauche. L’Affichage des 
données affiche le signal filtré résultant et LabVIEW SignalExpress 
relit tout le journal.
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Relecture avancée
Vous pouvez configurer des options de relecture de données avancées en 
utilisant la fenêtre Options de relecture. La fenêtre Options de relecture 
affiche un aperçu des données enregistrées et vous permet de sélectionner 
un sous-ensemble de ces données à relire ou à exécuter via des étapes 
d’analyse.

1. Sélectionnez Affichage»Options de relecture pour ouvrir la fenêtre 
Options de relecture, comme le montre la figure 5-5. La fenêtre 
Options de relecture vous permet d’obtenir un aperçu des données 
enregistrées et de spécifier un sous-ensemble des données enregistrées 
à relire ou à envoyer aux étapes d’analyse. 

Figure 5-5.  Fenêtre Options de relecture

2. Sélectionnez signal dans le deuxième enregistrement que vous avez 
créé dans la liste signal enregistré.

3. Entrez 1 dans le champ Temps de départ pour relire ou analyser un 
sous-ensemble du signal enregistré qui commence une seconde après 
le début du journal. 

4. Entrez 4 dans le champ Temps final pour relire ou analyser un 
sous-ensemble du signal enregistré qui commence quatre secondes 
après le début du journal.

5. Passer à la fenêtre Affichage des données et faites glisser la sortie des 
données filtrées sur l’étape Filtre dans l’Affichage des données.



Chapitre 5 Enregistrement des données

Initiation à LabVIEW SignalExpress 5-8 ni.com

6. Cliquez sur le bouton Exécuter, montré à gauche. LabVIEW 
SignalExpress filtre le sous-ensemble du signal que vous avez spécifié 
dans la fenêtre Options de relecture et affiche le signal filtré résultant 
dans l’Affichage des données.

7. Cliquez sur le bouton Arrêter pour arrêter l’exécution du projet.

Reportez-vous à l’Aide LabVIEW SignalExpress pour obtenir des 
informations complémentaires sur l’enregistrement des données, comme 
la spécification de conditions d’alarme et les options de relecture.
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6
Réalisation de mesures de 
balayage

Vous pouvez utiliser LabVIEW SignalExpress pour automatiser les 
mesures afin de caractériser et valider des projets en créant des opérations 
de balayage. Vous pouvez utiliser les mesures de balayage pour rassembler 
des données de projets en fonction d’une gamme de conditions pour 
documenter leurs performances. Par exemple, vous pouvez utiliser des 
opérations de balayage pour faire varier la fréquence d’un signal 
d’impulsion ou le niveau d’une tension d’alimentation tout en prenant des 
mesures pour définir les caractéristiques des projets.

Ce chapitre vous apprend comment configurer des opérations de balayage 
en utilisant l’étape Balayage dans LabVIEW SignalExpress. Vous allez 
apprendre comment définir les caractéristiques des performances d’un 
filtre en balayant une gamme des valeurs de fréquence et en mesurant la 
sortie du filtre. Vous allez aussi apprendre à afficher les résultats du 
balayage et effectuer des balayages multidimensionnels pour effectuer des 
mesures plus complexes.

Définition de sorties et de gammes de balayage 
Vous pouvez utiliser l'étape Balayage dans LabVIEW SignalExpress pour 
définir des mesures automatisées dans le cadre d’opérations de balayage 
complexes et susceptibles d’être répétées.

Effectuez les étapes suivantes pour définir une gamme de fréquence à 
balayer dans un projet d’exemple utilisant un filtre.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur 
Sweep.seproj.

2. Cliquez sur le bouton Exécuter, montré à gauche, pour exécuter le 
projet.

Le projet génère un signal d’impulsion sinusoïdal à l’étape Créer un 
signal analogique, ce signal passe ensuite dans un filtre passe-bande 
elliptique à l’étape Filtre, mesure le niveau Veff de la sortie du filtre à 
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l’étape Amplitude et niveaux et convertit le niveau en décibels (dB) à 
l’étape Formule. L’étape Filtre agit comme une unité simulée en cours 
de test, le projet n’utilise donc pas de matériel. Toutefois, vous pouvez 
aussi balayer des signaux physiques générés à partir d’analyses de 
signaux dynamiques, d’un générateur de fonctions, d’un périphérique 
d’E/S multifonction (MIO) ou d’un générateur de signaux arbitraires 
National Instruments.

3. Cliquez sur le bouton Ajouter une étape, montré à gauche, 
et sélectionnez Contrôle d’exécution»Balayage.

4. Cliquez sur le bouton Ajouter dans la boîte de dialogue 
Configuration de l’étape pour afficher la liste des paramètres de 
balayage de chaque étape du projet, comme le montre la figure 6-1.

Figure 6-1.  Boîte de dialogue Sélection du paramètre de balayage

5. Sélectionnez le paramètre Fréquence sous Créer un signal 
analogique et cliquez sur le bouton OK.

L’étape Balayage comprend l’étape Créer un signal analogique qui 
fournit le signal à balayer.

6. Sur l’onglet Configuration du balayage, sélectionnez Exponentiel 
dans le menu déroulant Type.

7. Entrez 1k dans le champ Fréquence de début (Hz), et 40k dans le 
champ Fréquence de fin (Hz).

8. Entrez 150 dans le champ Nombre de points.

L’onglet Configuration du balayage doit apparaître, comme le 
montre la figure 6-2.
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Figure 6-2.  Boîte de dialogue de configuration de l’étape Balayage

Vous avez utilisé l’étape Balayage pour spécifier une gamme de 
valeurs sur laquelle effectuer des itérations dans le paramètre 
Fréquence de l’étape Créer un signal analogique. L’étape Créer un 
signal analogique utilise la gamme de fréquence définie pour générer 
un signal sinusoïdal à chacune de ces fréquences. Toutefois, vous 
pouvez utiliser l’étape Balayage pour balayer toute valeur d’un 
paramètre susceptible d’être balayé de n’importe quelle étape d’un 
projet elle-même susceptible d’être balayée.

9. Cliquez sur l’onglet Sortie du balayage.

10. Cliquez sur le bouton Ajouter pour afficher la liste de balayages en 
sortie de chaque étape du projet.

11. Sélectionnez la sortie response amplitude in dB sous Formule et 
cliquez sur le bouton OK pour tracer cette mesure par rapport au 
paramètre Fréquence balayé.

L’étape Balayage crée une boucle autour de toutes les étapes de la Vue 
du projet pour inclure toutes les étapes dans l’opération de balayage.
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Traçage des résultats du balayage
Effectuez les étapes suivantes pour exécuter la mesure de balayage.

1. Cliquez sur le bouton Exécuter une fois, montré à gauche, pour 
exécuter la mesure de balayage.

La sortie stimulus signal du graphe itère dans la gamme de fréquences 
spécifiée.

2. Faites glisser le signal response amplitude in dB vs. Fréquence du 
bas de la boucle de balayage vers l’Affichage des données pour 
afficher la sortie du balayage.

LabVIEW SignalExpress crée un nouveau graphe. Les données d’une 
opération de balayage sont représentées dans un tableau x-y qui 
requiert un graphe séparé, comme le montre la figure 6-3.

Figure 6-3.  Sweep.seproj
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3. Cliquez sur le bouton Exécuter une fois pour exécuter à nouveau le 
balayage.

La réponse en fréquence de l’étape Filtre est tracée sur le nouveau 
graphe pendant que le projet s’exécute. Le graphe affiche la fonction 
de transfert du filtre, ou la sortie d’amplitude exprimée en décibels par 
rapport à la fréquence.

4. Double-cliquez sur l’étape Filtre pour afficher les spécifications du 
filtre dans la boîte de dialogue Configuration de l’étape.

La réponse en fréquence du filtre dans le graphe response in 
amplitude in dB correspond au graphe de l’Affichage des données.

5. Sélectionnez Fichier»Enregistrer le projet sous et enregistrez le 
projet sous Mon balayage.seproj dans le répertoire 
SignalExpress\Examples\Tutorial.

Vous pouvez utiliser l’étape Balayage pour balayer plusieurs paramètres 
simultanément en ajoutant des paramètres supplémentaires sur l’onglet 
Configuration du balayage de la boîte de dialogue de configuration de 
l’étape Balayage. Le balayage simultané de plusieurs paramètres est appelé 
balayage parallèle. Par exemple, si vous voulez faire varier l’amplitude 
d’un signal d’impulsion, vous pouvez exécuter un balayage parallèle. Vous 
pouvez utiliser un balayage parallèle pour optimiser la précision de 
l’acquisition en faisant varier la gamme d’entrée d’un numériseur ou d’un 
périphérique MIO à mesure que vous faites varier le niveau du signal. 
À mesure que le niveau du signal augmente, vous pouvez augmenter la 
gamme d’entrée du périphérique de mesure pour vous assurer que vous 
utilisez toute la résolution pour la mesure.

Exécution de balayages multidimensionnels
Utilisez des balayages multidimensionnels ou imbriqués pour effectuer des 
itérations sur une gamme tout en faisant varier une autre gamme. Par 
exemple, si vous voulez effectuer des itérations sur des fréquences d’un 
signal d’impulsion à différentes amplitudes, exécutez un balayage 
imbriqué. Vous pouvez définir l’amplitude au niveau 1 et effectuer des 
itérations sur des fréquences, puis définir l’amplitude au niveau 2 et 
effectuer des itérations sur des fréquences, et ainsi de suite. Vous pouvez 
construire un balayage imbriqué en cliquant avec le bouton droit sur l’étape 
Balayage dans un projet en sélectionnant Ajouter un balayage imbriqué 
dans le menu local pour ajouter une autre boucle de balayage. 
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Effectuez les étapes suivantes pour exécuter un projet d’exemple de 
balayage imbriqué.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur 
Nested Sweep.seproj.

2. Cliquez sur le bouton Exécuter, montré à gauche, pour exécuter le 
projet.

Chaque itération de la boucle de balayage interne balaie la fréquence 
du signal d’impulsion. La boucle de balayage externe fait varier les 
fréquences de coupure basse et haute de l’étape Filtre. Chaque itération 
apparaît en temps réel sur le graphe supérieur, puis apparaît sur le 
graphe inférieur pour afficher tous les balayages à chaque 
configuration de la fréquence de coupure, comme le montre la 
figure 6-4.

Figure 6-4.  Nested Sweep.seproj

3. Cliquez sur le bouton Arrêter, montré à gauche, pour arrêter le projet.
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7
Extension des projets LabVIEW 
SignalExpress avec LabVIEW

Vous pouvez utiliser LabVIEW SignalExpress pour définir des mesures 
automatisées en utilisant les étapes intégrées pour acquérir, générer ou 
analyser des signaux. Vous pouvez étendre la fonctionnalité des projets 
LabVIEW SignalExpress en utilisant LabVIEW des façons suivantes :

• Construisez un VI dans LabVIEW et importez-le dans LabVIEW 
SignalExpress pour fournir une fonctionnalité d’étape personnalisée et 
étendre le nombre d’étapes disponibles dans LabVIEW SignalExpress.

• Convertissez un projet LabVIEW SignalExpress en un diagramme 
LabVIEW pour poursuivre le développement dans LabVIEW.

Vous devez avoir LabVIEW 7.1 ou une version ultérieure pour effectuer les 
exercices de ce chapitre.

Importation de VIs LabVIEW dans SignalExpress sous 
forme d’étapes

Utilisez l'étape Exécuter un VI LabVIEW dans SignalExpress pour appeler 
des VIs LabVIEW personnalisés. Vous pouvez appeler un VI LabVIEW à 
partir de SignalExpress pour qu’il :

• Contrôle des instruments GPIB

• Contrôle du matériel National Instruments non supporté par LabVIEW 
SignalExpress

• Lise ou écrive des données dans davantage de formats de fichier

• Affiche des instructions destinées à l’opérateur dans une boîte de 
dialogue locale

• Définisse un algorithme de mesure
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Effectuez les étapes suivantes pour importer un VI LabVIEW avec l’étape 
Exécuter un VI LabVIEW. 

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial et double-cliquez sur User 
Step.seproj.

Ce projet utilise l’étape Créer un signal analogique pour générer un 
signal.

2. Cliquez sur le bouton Ajouter une étape et sélectionnez Exécuter un 
VI LabVIEW»Exécuter un VI LabVIEW 8.2. 

Le VI que vous exécutez dans cet exercice a été enregistré avec 
LabVIEW 8.2. Vous devez utiliser la version de l’étape Exécuter un VI 
LabVIEW qui correspond à la version de LabVIEW dans laquelle vous 
avez enregistré votre VI.

3. Cliquez sur le bouton Parcourir dans la boîte de dialogue 
Configuration de l’étape et sélectionnez Limiter-LV82.vi dans le 
répertoire LabVIEW SignalExpress\Examples\Tutorial. Le VI 
Limiter-LV82 accepte une waveform du domaine temporel comme 
entrée, écrête le signal au-dessus et en dessous des valeurs que vous 
spécifiez dans la boîte de dialogue Configuration de l’étape, et 
renvoie la waveform écrêtée sous forme d’un signal en sortie.

Lorsque vous importez un VI LabVIEW, LabVIEW SignalExpress 
mappe les entrées du VI comme paramètres et les sorties du VI comme 
signaux en sortie dans LabVIEW SignalExpress.

Vous pouvez définir si les entrées des VIs deviennent des signaux en 
entrée ou des paramètres. Un signal en entrée apparaît dans la Vue du 
projet comme une entrée d’une étape, ce qui signifie que vous pouvez 
transmettre des signaux à un VI sous la forme d’entrées. Un paramètre 
est une valeur que vous pouvez configurer dans la boîte de dialogue 
Configuration de l’étape d’une étape. Vous pouvez aussi balayer des 
paramètres de manière dynamique en utilisant l’étape Balayage. Dans 
ce projet, le VI possède un signal en entrée Time Waveform in et les 
paramètres scalaires Upper limit et Lower limit.

Assurez-vous que la boîte de dialogue Configuration de l’étape 
apparaît comme dans la figure 7-1.
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Figure 7-1.  Boîte de dialogue de configuration de l’étape VI Limiter

4. Cliquez sur le bouton Exécuter, montré à gauche, pour exécuter le 
projet. 

5. Faites glisser le signal en sortie Clipped waveform out de l’étape VI 
Limiter vers l’Affichage des données.

6. Double-cliquez sur l’étape VI Limiter pour afficher la boîte de 
dialogue Configuration de l’étape.

7. Sélectionnez l’onglet Configurer le VI pour afficher le VI. 

8. Entrez de nouvelles valeurs dans les champs Upper limit et Lower 
limit. Par exemple, entrez 100 dans le champ Limite supérieure.

9. Le signal Clipped waveform out change sur l’Affichage des données 
pour refléter les modifications effectuées.

Reportez-vous à l’Aide LabVIEW SignalExpress pour obtenir davantage 
d’informations sur l’utilisation des VIs LabVIEW dans LabVIEW 
SignalExpress et sur la construction de VIs qui fonctionnent sous 
LabVIEW SignalExpress.
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Conversion de projets LabVIEW SignalExpress en 
diagrammes LabVIEW

LabVIEW SignalExpress peut convertir des projets LabVIEW 
SignalExpress en diagrammes LabVIEW.

Remarque Pour convertir un projet LabVIEW SignalExpress en VI LabVIEW, le système 
de développement complet de LabVIEW 7.1 ou une version supérieure doit être installée.

Effectuez les étapes suivantes pour convertir un projet LabVIEW 
SignalExpress en diagramme LabVIEW.

1. Sélectionnez Fichier»Ouvrir un projet, naviguez vers le répertoire 
SignalExpress\Examples\Tutorial\Solutions et 
double-cliquez sur Mon premier projet.seproj.

2. Sélectionnez Outils»Générer le code»Diagramme LabVIEW.

3. Spécifiez un nom de fichier et un emplacement pour le VI LabVIEW 
et cliquez sur le bouton OK.

Le diagramme LabVIEW résultant reflète l’exécution du projet dans 
LabVIEW SignalExpress. Le diagramme LabVIEW comprend des 
VIs Express LabVIEW câblés entre eux. Chaque VI Express 
correspond à une étape dans le projet LabVIEW SignalExpress. Vous 
pouvez double-cliquer sur un VI Express pour afficher la même 
boîte de dialogue Configuration de l'étape que dans LabVIEW 
SignalExpress. Vous pouvez également effectuer un clic droit sur un 
VI Express et sélectionner Ouvrir la face-avant dans le menu local 
pour convertir le VI Express en un sous-VI LabVIEW. Vous pouvez 
afficher le diagramme LabVIEW pour voir comment il s’exécute et 
modifier la fonctionnalité du VI. Lorsque vous convertissez un VI 
Express en sous-VI, vous ne pouvez plus convertir le sous-VI en VI 
Express.

Remarque Lorsque vous convertissez un projet LabVIEW SignalExpress comportant un 
enregistrement dans un fichier journal, LabVIEW SignalExpress génère un diagramme 
LabVIEW avec un VI Express. Vous ne pouvez pas convertir le VI Express généré en un 
sous-VI.
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8
Et maintenant ?

Reportez-vous aux ressources suivantes pour obtenir de plus amples 
informations sur LabVIEW SignalExpress.

Projets d’exemple LabVIEW SignalExpress
LabVIEW SignalExpress offre une variété de projets d’exemple qui 
démontrent davantage de possibilités de LabVIEW SignalExpress. Ces 
projets sont situés dans le répertoire SignalExpress\Examples. Passez 
ces exemples en revue pour en savoir plus sur les fonctionnalités de 
LabVIEW SignalExpress ou pour démarrer avec un projet qui s’approche 
de vos exigences.

Utilisation du matériel avec LabVIEW SignalExpress
Ce manuel ne décrit pas comment contrôler du matériel à partir de 
LabVIEW SignalExpress car LabVIEW SignalExpress supporte de 
nombreux périphériques National Instruments pour l’acquisition et la 
génération de signaux. Vous pouvez générer ou acquérir des signaux 
analogiques dans LabVIEW SignalExpress en utilisant des numériseurs 
haute vitesse, des périphériques d’acquisition de signaux dynamiques, des 
générateurs de waveform arbitraires et des générateurs de fonctions ou des 
périphériques MIO National Instruments. Vous pouvez aussi synchroniser 
plusieurs périphériques dans un système en partageant des signaux 
d’horloge et de déclenchement entre des périphériques. Reportez-vous à 
l’Aide LabVIEW SignalExpress en sélectionnant Aide»Aide LabVIEW 
SignalExpress pour obtenir des informations complémentaires sur 
l’utilisation de périphériques avec LabVIEW SignalExpress.

Ressources Web
Reportez-vous au site Web de National Instruments sur ni.com/france/
signalexpress pour obtenir des ressources telles que des projets 
d’exemple, de la documentation technique et des VIs LabVIEW écrits pour 
être utilisés dans LabVIEW SignalExpress.

http://www.ni.com/signalexpress
http://www.ni.com/signalexpress
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A
Support technique et services

Visitez les sections suivantes du site Web de National Instruments sur 
ni.com pour obtenir une assistance technique et des services 
professionnels :

• Support — Les ressources de support technique en ligne sur 
ni.com/france/support comprennent notamment :

– Ressources d’auto-assistance — Pour obtenir des réponses et 
des solutions, visitez le site Web primé de National Instruments 
pour vous procurer des drivers et des mises à jour de logiciels, 
pour faire des recherches dans la KnowledgeBase, pour accéder 
aux manuels sur les produits et aux assistants de dépannage pas à 
pas, ou pour obtenir des milliers d’exemples de programmes, des 
tutoriels, des notes d’application, des drivers d’instruments et bien 
plus encore.

– Support technique gratuit — Tous les utilisateurs enregistrés 
peuvent bénéficier du Service de base gratuit, qui vous offre la 
possibilité de contacter des centaines d’ingénieurs d’application 
dans le monde entier, dans le cadre de NI Discussion Forums sur 
ni.com/forums. Les ingénieurs d’application de National 
Instruments s’efforcent de répondre à toutes les questions qui leur 
sont adressées.

Pour obtenir des informations sur d’autres options de support 
technique dans votre région, visitez ni.com/services ou 
contactez votre filiale locale, grâce aux coordonnées qui se 
trouvent sur ni.com/contact. 

• Formations et certifications — Visitez ni.com/france et cliquez 
sur le volet Formations & Certifications à gauche de l’écran pour 
obtenir des informations détaillées sur les programmes proposés. Vous 
pouvez également vous inscrire à des cours de formation dispensés par 
des instructeurs partout dans le monde.

• Intégrateurs — Si vous devez concilier délais serrés, ressources 
techniques limitées et toute autre contrainte, nous vous invitons à faire 
appel aux intégrateurs du Programme National Instruments Alliance 
Partner. Pour en savoir plus, appelez votre filiale locale ou visitez le 
site ni.com/alliance.
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Si vous n’avez pas trouvé la réponse à vos questions sur ni.com, contactez 
votre filiale locale ou le siège social de NI. Les numéros de téléphone des 
filiales figurent au début de ce manuel. Vous pouvez également visiter la 
page des filiales internationales sur ni.com/niglobal afin d’accéder au 
site Web local de votre filiale, qui contient les informations les plus à jour 
pour contacter le support technique par téléphone, fax ou email, ainsi que 
les dates des événements locaux.
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innerhalb eines Jahres nach Schadenseintritt gerichtlich geltend gemacht werden. Die Firma National Instruments haftet nicht für 
Verspätungsschäden, die nicht in ihrem Verantwortungsbereich liegen. Diese Garantie erstreckt sich nicht auf Schäden, Fehler, Fehlfunktionen 
oder Servicemängel, die auf der Nichtbefolgung von Anweisungen von National Instruments für die Installation, den Betrieb oder die Wartung, 
auf Veränderungen des Produktes, Missbrauch oder Fehlgebrauch des Produktes, auf einer Unterbrechung der Energieversorgung, Feuer, 
Wasserschäden, Unfälle, Handlungen Dritter oder anderen Geschehnissen, die nicht im Verantwortungsbereich von National Instruments 
liegen, beruhen.

Urheberrechte
Gemäß den Bestimmungen des Urheberrechts darf diese Publikation ohne vorherige schriftliche Zustimmung der Firma National Instruments 
Corporation weder vollständig noch teilweise vervielfältigt oder verbreitet werden, gleich in welcher Form, ob elektronisch oder mechanisch. 
Das Verbot erfasst u.a. das Fotokopieren, das Aufzeichnen, das Speichern von Informationen in Retrieval Systemen sowie das Anfertigen von 
Übersetzungen gleich welcher Art.

National Instruments achtet das geistige Eigentum anderer und fordert seine Nutzer auf, dies ebenso zu tun. Die Software von National 
Instruments ist urheberrechtlich und durch andere Rechtsvorschriften zum Schutz geistigen Eigentums geschützt. Wenn Sie NI Software 
nutzen, um Software oder andere Materialien, die im Eigentum Dritter stehen, zu vervielfältigen, dürfen Sie NI Software nur insoweit nutzen, 
als Sie die betreffenden Materialien nach den jeweils anwendbaren Lizenzbestimmungen oder Rechtsvorschriften vervielfältigen dürfen.

Marken
National Instruments, NI, ni.com und LabVIEW sind Marken der Firma National Instruments Corporation. Nähere Informationen zu den 
Marken von National Instruments finden Sie im Abschnitt Terms of Use unter ni.com/legal.

Sonstige hierin erwähnte Produkt- und Firmenbezeichnungen sind Marken oder Handelsnamen der jeweiligen Unternehmen.

Mitglieder des National Instruments Alliance Partner Programms sind eigenständige und von National Instruments unabhängige Unternehmen; 
zwischen ihnen und National Instruments besteht keine gesellschaftsrechtliche Verbindung und auch kein Auftragsverhältnis.

Patente
Nähere Informationen über Patente auf Produkte von National Instruments finden Sie unter Hilfe»Patente in Ihrer Software, in der Datei 
patents.txt auf Ihrer CD oder unter ni.com/patents.

WARNUNG ZUR NUTZUNG VON NATIONAL INSTRUMENTS PRODUKTEN
(1) DIE SOFTWAREPRODUKTE VON NATIONAL INSTRUMENTS WURDEN NICHT MIT KOMPONENTEN UND TESTS FÜR EIN 
SICHERHEITSNIVEAU ENTWICKELT, DAS FÜR EINE VERWENDUNG BEI ODER IN ZUSAMMENHANG MIT CHIRURGISCHEN 
IMPLANTATEN ODER ALS KRITISCHE KOMPONENTEN VON LEBENSERHALTENDEN SYSTEMEN GEEIGNET IST, DEREN 
FEHLFUNKTION BEI VERNÜNFTIGER BETRACHTUNGSWEISE ZU ERHEBLICHEN VERLETZUNGEN VON MENSCHEN 
FÜHREN KANN. 
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UNVORHERGESEHENEN EINSATZES ODER MISSBRAUCHS ODER FEHLERN DES ANWENDERS ODER DES 



ANWENDUNGSENTWICKLERS (ENTGEGENWIRKENDE FAKTOREN WIE DIESE WERDEN NACHSTEHEND 
ZUSAMMENFASSEND “SYSTEMFEHLER” GENANNT) BEEINTRÄCHTIGT WERDEN. JEDE ANWENDUNG, BEI DER EIN 
SYSTEMFEHLER EIN RISIKO FÜR SACHWERTE ODER PERSONEN DARSTELLT (EINSCHLIESSLICH DER GEFAHR 
KÖRPERLICHER SCHÄDEN UND TOD), SOLLTE AUFGRUND DER GEFAHR VON SYSTEMFEHLERN NICHT LEDIGLICH AUF 
EINE FORM VON ELEKTRONISCHEM SYSTEM GESTÜTZT WERDEN. UM SCHÄDEN UND, U.U. TÖDLICHE, VERLETZUNGEN 
ZU VERMEIDEN, SOLLTE DER NUTZER ODER ANWENDUNGSENTWICKLER ANGEMESSENE SICHERHEITSMASSNAHMEN 
ERGREIFEN, UM SYSTEMFEHLERN VORZUBEUGEN. HIERZU GEHÖREN UNTER ANDEREM SICHERUNGS- ODER 
ABSCHALTMECHANISMEN. DA JEDES ENDNUTZERSYSTEM DEN KUNDENBEDÜRFNISSEN ANGEPASST IST UND SICH VON 
DEM TESTUMFELD UNTERSCHEIDET, UND DA EIN NUTZER ODER ANWENDUNGSENTWICKLER SOFTWAREPRODUKTE 
VON NATIONAL INSTRUMENTS IN VERBINDUNG MIT ANDEREN PRODUKTEN IN EINER VON NATIONAL INSTRUMENTS 
NICHT GETESTETEN ODER VORHERGESEHENEN FORM EINSETZEN KANN, TRÄGT DER NUTZER BZW. DER 
ANWENDUNGSENTWICKLER DIE LETZTENDLICHE VERANTWORTUNG FÜR DIE ÜBERPRÜFUNG UND AUSWERTUNG DER 
EIGNUNG VON NATIONAL INSTRUMENTS PRODUKTEN, WENN PRODUKTE VON NATIONAL INSTRUMENTS IN EIN SYSTEM 
ODER EINE ANWENDUNG INTEGRIERT WERDEN. DIES ERFORDERT U.A. DIE ENTSPRECHENDE ENTWICKLUNG UND 
VERWENDUNG SOWIE EINHALTUNG EINER ENTSPRECHENDEN SICHERHEITSSTUFE BEI EINEM SOLCHEN SYSTEM ODER 
EINER SOLCHEN ANWENDUNG.
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Zu diesem Handbuch

In diesem Handbuch erhalten Sie eine Einführung in die interaktive Mes-
sung mit LabVIEW SignalExpress und in die Grundfunktionen des 
Programms zum Erfassen und Analysieren von Signalen.

Die im Buch enthaltenen Übungen sollen Ihnen den Einstieg in LabVIEW 
SignalExpress erleichtern. Sie lernen damit die Konfiguration von Schrit-
ten, das Ausführen von Projekten, die Arbeit mit Signalen, das wiederholte 
Messen mit variablen Parametern, das Protokollieren von Daten sowie die 
Verwendung von LabVIEW SignalExpress durch die grafische Program-
mierumgebung LabVIEW.

Symbole und Darstellungen
In diesem Handbuch werden die folgenden Symbole und Darstellungen 
verwendet:

» Das Symbol » kennzeichnet die Reihenfolge, in der Sie Menüpunkte und 
Dialogfeldoptionen anzuklicken sind. So wird zum Beispiel mit der 
Abfolge Datei»Seite einrichten»Optionen angezeigt, dass zunächst das 
Menü Datei zu öffnen ist, daraus der Menüpunkt Seite einrichten auszu-
wählen und anschließend die Seite Optionen anzuklicken ist.

Dieses Zeichen steht für einen Hinweis auf wichtige Informationen.

fett In fettgedruckter Schrift sind Elemente dargestellt, die ausgewählt oder 
angeklickt werden müssen, wie Menüpunkte oder Optionen in Dialogfel-
dern. Bei fettgedrucktem Text kann es sich auch um die Namen von Ein- 
und Ausgängen, Parameternamen, Dialogfelder, Bereiche in Dialogfeldern 
und Menünamen handeln.

kursiv Variablen, Hervorhebungen, Querverweise und erstmals genannte Fachaus-
drücke sind durch Kursivschrift gekennzeichnet. Ebenfalls kursiv sind 
Textstellen gedruckt, an denen Wörter bzw. Werte einzusetzen sind.

monospace In Monospace-Schrift (nicht proportionaler Schrift) ist Text dargestellt, der 
über die Tastatur einzugeben ist. Diese Darstellungsweise wird ebenfalls 
für Laufwerke, Pfade, Verzeichnisse, Programme, Unterprogramme, Sub-
routinen, Gerätenamen, Funktionen, Operationen, Variablen sowie 
Dateinamen und -erweiterungen verwendet.
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Literaturhinweise
Wenn Sie beim Lesen dieses Handbuchs weitere Fragen haben, werden 
diese möglicherweise in der Hilfe zu LabVIEW SignalExpress unter 
Hilfe»LabVIEW-SignalExpress-Hilfe beantwortet.



© National Instruments Corporation 1-1 Erste Schritte mit LabVIEW SignalExpress

1
Einführung in LabVIEW 
SignalExpress

National Instruments bietet innovative Anwendungen für Wissenschaftler 
und Ingenieure, mit denen automatisierte Messanlagen auf dem Industrie-
standard entsprechenden Computern und Plattformen erstellt werden 
können. Die Firma National Instruments entwickelt technologisch füh-
rende Programmierumgebungen zur Automatisierung von Messanlagen, 
wie die grafische Entwicklungsumgebung LabVIEW, die ANSI-C-Pro-
grammierumgebung LabWindows™/CVI™ oder Measurement Studio zur 
Programmierung in Microsoft Visual Studio. Diese Programmierumgebun-
gen arbeiten sowohl mit Messkarten von National Instruments für den 
Computer als auch mit normalen Messgeräten, so dass Sie aus echten und 
virtuellen Messgeräten technisch anspruchsvolle Messanlagen zusammen-
stellen können.

LabVIEW SignalExpress optimiert die Messung mit virtuellen 
Messanlagen insofern, dass Sie aufgrund der interaktiven Bedienweise der 
Software ohne jegliche Programmierung sofort messen können. Mit 
LabVIEW SignalExpress können Sie Signale erfassen, erzeugen, analysie-
ren, vergleichen, importieren und speichern. So können Sie zum Beispiel 
vorgegebene Werte in einem Schritt mit Messwerten vergleichen. 
LabVIEW SignalExpress macht damit die Einfachheit und Flexibilität vir-
tueller Messanlagen auch solchen Nutzern zugänglich, die Signale ohne 
Programmierung messen und analysieren möchten. Sie können die Funk-
tionen von LabVIEW SignalExpress auch ausbauen, indem Sie ein eigenes 
VI (virtuelles Instrument) aus dem LabVIEW Development System impor-
tieren oder indem Sie ein LabVIEW-SignalExpress-Projekt in ein 
LabVIEW-Blockdiagramm umwandeln und in LabVIEW weiter am Pro-
jekt arbeiten. Weitere Informationen dazu finden Sie in Kapitel 7, 
Erweitern von LabVIEW-SignalExpress- Projekten durch LabVIEW.
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2
Installieren von LabVIEW 
SignalExpress

Für die Übungen in diesem Handbuch muss LabVIEW SignalExpress von 
der dazugehörigen CD installiert werden.

LabVIEW SignalExpress LE
LabVIEW SignalExpress LE ist eine 30-Tage-Testversion von 
LabVIEW SignalExpress mit vollem Funktionsumfang. Nach Ablauf 
dieses Zeitraums müssen Sie das Programm aktivieren oder die Vollver-
sion kaufen. Wenn Sie LabVIEW SignalExpress LE vor Ablauf der 
30 Tage aktivieren, steht Ihnen für die restliche Zeit der volle Funktions-
umfang des Programms zur Verfügung. LabVIEW SignalExpress LE bietet 
einfache Datenerfassungs- und Protokollierungsfunktionen.

Wenn Sie Ihre Version von LabVIEW SignalExpress LE nach dem Ablauf 
von 30 Tagen nicht registrieren, läuft das Programm mit folgenden 
Einschränkungen:

• Sie können keine Projekte mehr speichern, also auch keine Projekte in 
LabVIEW-Blockdiagramme umwandeln.

• Projekte laufen nur noch jeweils 10 Minuten.

Um die Vollversion von LabVIEW SignalExpress zu kaufen, besuchen Sie 
die Website ni.com/signalexpress.

Mindestvoraussetzungen zur Installation
Für LabVIEW SignalExpress werden mindestens 256 MB RAM sowie ein
Pentium III, ein Celeron-Prozessor mit 866 MHz oder ein gleichwertiger 
Prozessor benötigt. Empfohlen werden jedoch 512 MB RAM und ein 
Pentium 4/M oder ein gleichwertiger Prozessor.

http://ni.com/signalexpress
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Installieren von LabVIEW SignalExpress
Gehen Sie zur Installation von LabVIEW SignalExpress unter 
Windows Vista/XP/2000/NT wie folgt vor:

Hinweis Zur Umwandlung von LabVIEW-SignalExpress-Projekten in LabVIEW-Block-
diagramme müssen Sie zunächst eine LabVIEW-Version ab 7.1 installieren.

1. Deaktivieren Sie die automatische Virenerkennung. Virensuchpro-
gramme können die Installation behindern.

2. Melden Sie sich als Administrator oder Anwender mit Administrator-
rechten an.

3. Legen Sie die Development- oder die Evaluierungs-CD von LabVIEW 
SignalExpress ein und folgen Sie den Anweisungen.

Per Voreinstellung wird SignalExpress unter Programme\National 
Instruments\SignalExpress installiert.

4. Aktivieren Sie die automatische Virenerkennung wieder und untersu-
chen Sie die Festplatte nach Abschluss der Installation auf Viren.

Die Beispielprojekte für die Übungen in diesem Buch befinden sich unter 
SignalExpress\Examples\Tutorial. Die Lösungen finden Sie unter 
SignalExpress\Examples\Tutorial\Solutions.

Um Module oder Datenerfassungskarten von National Instruments in 
LabVIEW SignalExpress einzubinden, müssen Sie NI-DAQmx ab 8.5, 
NI-SCOPE ab 2.7, NI-FGEN ab 2.2 oder NI-DMM 2.4.2 installieren.



© National Instruments Corporation 3-1 Erste Schritte mit LabVIEW SignalExpress

3
Arbeit mit Projekten

Mit LabVIEW SignalExpress werden Messungen in Form einer Reihe von 
Schritten ausgeführt, die Sie interaktiv in SignalExpress auswählen und 
konfigurieren. Ein Schritt ist eine konfigurierbare Funktion, mit der Daten 
entweder erfasst, analysiert, geladen oder gespeichert werden. Die meisten 
Schritte verarbeiten Signale und geben Signale aus. Die Funktionsweise 
eines Schritts wird in der dazugehörigen Konfigurationsansicht festgelegt. 
Eine gespeicherte Schrittfolge ergibt ein LabVIEW-SignalExpress-Projekt.

In diesem Kapitel lernen Sie, wie Projekte geladen und ausgeführt und 
Schritte in den Projekten konfiguriert werden.

Öffnen von Projekten
Zum Laden eines Beispielprojekts in LabVIEW SignalExpress gehen Sie 
wie folgt vor:

1. Starten Sie LabVIEW SignalExpress.

Beachten Sie, dass das Programm in drei Bereiche aufgeteilt ist: den 
Projektbereich (links), den Datenbereich (Mitte) und die Hilfe (rechts). 
Im Datenbereich sollten Sie die Registerkarten Datenansicht, Auf-
nahmeoptionen und Projektdokumentation sehen.

2. Wenn SignalExpress sich nicht in der Werkseinstellung öffnet, wählen 
Sie Ansicht»Datenansicht.

3. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf 
First Project.seproj. 
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4. Sehen Sie sich in Ruhe den Aufbau des Programms an (siehe 
Abbildung 3-1; die Hilfe ist hier ausgeblendet). 

Abbildung 3-1.  First Project.seproj

Die linke Bildschirmhälfte ist die Projektansicht, in der die Reihen-
folge der Vorgänge (Schritte) aufgelistet ist, die im Rahmen des 
Projekts ausgeführt werden sollen. Die rechte Seite ist die Datenan-
sicht, in der das Signal zu sehen ist, das mit dem Projekt erzeugt oder 
analysiert wird.

1 Schaltflächen zur Ablaufsteuerung
2 Pulldown-Menü zur Auswahl des 

Arbeitsbereichs
3 Schritt

4 Eingangsgröße
5 Ausgangsgröße
6 Projektansicht

7 Fenster “Protokolldaten”
8 Datenansicht
9 Aufnahme-Schaltfläche
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Ausführen eines Projekts und Anzeigen von Signalen
LabVIEW SignalExpress hat zwei Ausführungsmodi: “Ausführen” und 
“Einmal ausführen”. Wenn Sie die Schaltfläche Ausführen anklicken, 
werden alle Schritte im Projekt so lange ausgeführt, bis Sie die 
Stopp-Schaltfläche anklicken. Die Stopp-Schaltfläche erscheint anstelle 
der Ausführen-Schaltfläche, wenn das Projekt läuft. Die Ausführung der 
Schritte wird in der Datenansicht veranschaulicht. Beim Ändern der Ein-
stellungen, während ein Projekt läuft, passt sich die Datenansicht sofort an. 
Wenn Sie während der Ausführung der Schritte eine Einstellung ändern, 
sehen Sie also sofort, welche Auswirkungen Ihre Änderungen haben. Beim 
Anklicken der Schaltfläche Einmal ausführen werden alle Schritte im 
Projekt einmal durchlaufen.

Zum Starten des Beispielprojekts in SignalExpress und zum Anzeigen von 
Signalen gehen Sie wie folgt vor:

1. Klicken Sie auf die Schaltfläche Ausführen (vgl. Abbildung links), so 
dass alle Schritte wiederholt durchlaufen.

Daraufhin wird ein Signal aus einer Textdatei geladen und es wird eine 
Amplituden- und Pegelmessung sowie eine Verzerrungsmessung 
durchgeführt. Diese Messungen werden jeweils von den Schritten 
“Amplitude und Pegel” und “Verzerrung” vorgenommen. Bei der Aus-
führung eines Projekts analysieren die Schritte die Eingangssignale 
und erzeugen als Ergebnis der Analyse neue Ausgangssignale. In 
diesem Projekt wird mit dem Schritt “Aus ASCII-Datei laden” eine 
verzerrte Sinuskurve geladen, die dann mit den Schritten “Amplitude 
und Pegel” und “Verzerrung” ausgewertet wird, und die beide eine 
neue Kurve erzeugen. Die Eingangsgrößen werden in der Projektan-
sicht durch rote Pfeile und die Ausgangsgrößen durch blaue Pfeile 
gekennzeichnet.

Im Graphen in der Datenansicht wird immer noch das geladene Zeit-
bereichssignal angezeigt. Graphen können Zeitbereichs-, 
Frequenzbereichs- und xy-Signale darstellen. 

2. Klicken Sie das Signal Exportiertes Spektrum an, das vom Schritt 
“Verzerrung” ausgegeben wird, und ziehen Sie es zur Anzeige in die 
Datenansicht. 

LabVIEW SignalExpress erzeugt daraufhin in der Datenansicht einen 
neuen Graphen. Exportiertes Spektrum wird nicht im selben Gra-
phen wie das Zeitbereichssignal angezeigt, da es sich bei dem 
Spektrum um ein Frequenzbereichssignal handelt. Das Programm 
erkennt Signaltypen automatisch und zeigt sie entsprechend an.
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3. Wählen Sie Hilfe»LabVIEW-SignalExpress-Hilfe, klicken Sie auf 
die Registerkarte Suchen und geben Sie Signaltypen ein, um sich in 
der Hilfe zu LabVIEW SignalExpress weiter über die Signaltypen zu 
informieren. In der Hilfe erfahren Sie mehr zu den einzelnen Kompo-
nenten von LabVIEW SignalExpress, z. B. Projekten oder Schritten.

4. Klicken Sie auf den Ausgang DC des Schritts “Amplitude und Pegel” 
und ziehen Sie ihn in die Datenansicht. 

Da DC diskrete Zahlenwerte als Messergebnisse ausgibt, wird auto-
matisch eine Tabelle erzeugt.

5. Ziehen Sie den Ausgang RMS in die Tabelle, um die Effektivwerte 
darin anzuzeigen.

Die Tabelle wird daraufhin um eine Zeile für das zweite Messergebnis 
erweitert. Das Projekt sollte wie in Abbildung 3-2 aussehen.

Abbildung 3-2.  Ausgangsgrößen von First Project.seproj
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Konfigurieren von Schritten
Ein Schritt ist eine konfigurierbare Funktion, mit der Daten entweder 
erfasst, analysiert, geladen oder gespeichert werden. Jeder Schritt verarbei-
tet Signale und gibt Signale aus. Sie können die Ausführung eines Schritts 
in den Schritteinstellungen (also der Konfigurationsansicht) festlegen. Sie 
können auch bei laufenden Projekten Änderungen an den Einstellungen 
vornehmen, um Ihre Messungen so anzupassen, dass die gewünschten 
Ergebnisse dargestellt werden.

Zur Konfiguration der Schritte “Verzerrung” und “Amplitude und Pegel” 
gehen Sie wie folgt vor:

1. Klicken Sie den Schritt “Verzerrung” in der Projektansicht doppelt an. 
Es öffnen sich die Schritteinstellungen (vgl. Abbildung 3-3).

Abbildung 3-3.  Einstellungen zum Schritt “Verzerrung”
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Die Einstellungen auf der Registerkarte Konfiguration zeigen an, 
dass der Schritt “Verzerrung” mit einem Zeitbereichssignal arbeitet, 
ein Leistungsspektrum des Signals erstellt, um es in ein Frequenzspek-
trum umzuwandeln, und den Klirrfaktor sowie die Grundfrequenz des 
Signals ermittelt. Der Schritt gibt drei Messergebnisse aus: das Spek-
trum, den Klirrfaktor und die Grundfrequenz des Signals.

2. Wenn die Kontexthilfe nicht auf der rechten Bildschirmhälfte ange-
zeigt wird, klicken Sie auf die Schaltfläche Hilfe einblenden (vgl. 
Abbildung links). Daraufhin sollten alle in der Hilfe enthaltenen Infor-
mationen zu einem Schritt angezeigt werden. In der oberen Hälfte der 
Kontexthilfe werden Informationen zum Schritt selbst angezeigt und 
in der unteren Hälfte sehen Sie Angaben zu einem Objekt, wenn Sie 
den Cursor auf das Objekt führen.

3. Wählen Sie auf der Registerkarte Konfiguration aus dem Pull-
down-Menü Signale ausgeben (Klirrfaktor) die Option 
Grundschwingung aus.

Der Schritt zeigt nun nicht mehr das Frequenzbereichsspektrum des 
gesamten Signals, sondern nur noch die Grundschwingung an. Die in 
der oberen Hälfte der Schritteinstellungen dargestellten Signale 
passen sich Ihrer Einstellung entsprechend an.

4. Wählen Sie aus dem Pulldown-Menü Signale ausgeben (Klirrfaktor) 
die Option Nur Harmonische aus.

Der Schritt gibt jetzt nur noch das Oberwellenspektrum des Signals 
aus. Das vom Schritt “Verzerrung” ausgegebene Signal und der Graph 
in der Datenansicht werden entsprechend angepasst.

5. Klicken Sie in der Projektansicht den Schritt “Amplitude und Pegel” 
an. 

Das Dialogfeld Schritteinstellungen zeigt nun die Einstellungen zum 
Schritt “Amplituden und Pegel” an.
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6. Klicken Sie auf die Registerkarte Eingang/Ausgang, so dass eine 
Liste der möglichen Ein- und Ausgabesignale für diesen Schritt ange-
zeigt wird (vgl. Abbildung 3-4).

Abbildung 3-4.  Einstellungen zum Schritt “Amplitude und Pegel”

7. Aktivieren Sie die Optionen Positiven Spitzenwert ausgeben, Nega-
tiven Spitzenwert ausgeben und Spitze-Spitze-Wert ausgeben, so 
dass diese drei Größen gemessen werden.

In der Projektansicht erscheinen nun drei zusätzliche Ausgänge.

8. Klicken Sie auf die Registerkarte Datenansicht.

9. Ziehen Sie die drei neuen Ausgänge von der Projektansicht in die 
Tabelle.

10. Klicken Sie auf die Schaltfläche Stopp (vgl. Abbildung links), um das 
Projekt anzuhalten.

Beim Anklicken der Stopp-Schaltfläche beendet das Projekt noch den 
letzten Durchlauf und hält dann an. Klicken Sie auf den Pfeil nach 
unten auf der Stopp-Schaltfläche und klicken Sie auf die Schaltfläche 
Abbrechen. Dadurch wird das Projekt mit sofortiger Wirkung 
gestoppt, ohne die noch ausstehenden Arbeitsschritte abzuwarten.

11. Klicken Sie auf Datei»Speichern unter und speichern Sie das Projekt 
unter dem Namen My First Project.seproj im Verzeichnis 
SignalExpress\Examples\Tutorial.

12. Schließen Sie das Projekt über Datei»Projekt schließen.
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Verschieben und Löschen von Schritten
Die Schritte in SignalExpress hängen von Daten an ihrem Eingang ab. Das 
heißt, ein Schritt arbeitet nur, wenn von einem vorhergehenden Schritt ein 
Signal in der Projektansicht ausgegeben wird. Wenn Sie das Pulldown-
Menü Eingangssignal auf der Registerkarte Eingang im Dialogfeld 
Schritteinstellungen zu einem Schritt anklicken, werden nur die passen-
den Signale vom vorherigen Schritt angezeigt. Sobald das Ausgabesignal 
eines Schritts am Eingang des nächsten anliegt, entsteht eine Abhängigkeit 
zwischen den Schritten und sie werden nacheinander mit der gleichen Rate 
ausgeführt. Der zweite Schritt kann erst beginnen, wenn durch den ersten 
Schritt ein Signal erzeugt wurde.

Sie können die Schritte in der Projektansicht nach oben oder unten ziehen. 
Zum Löschen eines Schritts klicken Sie ihn in der Projektansicht mit der 
rechten Maustaste an und wählen Sie aus dem Kontextmenü die Option 
Löschen aus. Allerdings ändert sich beim Löschen oder Verschieben eines 
Schritts der Status des Signals. Beim Löschen eines Schritts, der Signale 
erzeugt, auf die ein anderer Schritt angewiesen ist, funktioniert das Projekt 
beispielsweise nicht mehr und in der Projektansicht erscheint eine entspre-
chende Fehlermeldung. Sie können Schritte innerhalb eines Projekts auch 
ausschneiden, kopieren oder einfügen, indem Sie die Tastenkombinationen 
<Strg + X>, <Strg + C> und <Strg + V> drücken oder einen Schritt in der 
Projektansicht anklicken und die Option Ausschneiden, Kopieren, Vor 
ausgewähltem Schritt einfügen oder Nach ausgewähltem Schritt einfü-
gen auswählen. 

Umgang mit Fehlern und Warnungen
Bei einem Fehler während eines laufenden Projekts wird durch eine Feh-
leranzeige (vgl. Abbildung links) in der Projektansicht der Schritt 
angezeigt, bei dem der Fehler aufgetreten ist. Wenn Sie den fehlerhaften 
Schritt doppelt anklicken, erscheint am unteren Rand des Dialogfelds 
Schritteinstellungen eine Kurzbeschreibung des Fehlers. Die vollständige 
Beschreibung wird beim Anklicken der Schaltfläche Details neben der 
Fehlermeldung angezeigt.

Alle Fehler und Warnungen während der Ausführung eines Projekts 
werden protokolliert. Zur Anzeige des Ereignisprotokolls wählen Sie 
Ansicht»Ereignisprotokoll oder klicken Sie in der Datenansicht auf die 
Registerkarte Ereignisprotokoll. Weitere Informationen zu Fehlern und 
Warnungen finden Sie in der Hilfe zu LabVIEW SignalExpress, indem Sie 



Kapitel 3 Arbeit mit Projekten

© National Instruments Corporation 3-9 Erste Schritte mit LabVIEW SignalExpress

Hilfe»LabVIEW-SignalExpress-Hilfe auswählen, auf die Registerkarte 
Suchen klicken und das Stichwort Fehler eingeben.
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Arbeit mit Signalen

In LabVIEW SignalExpress können Signale generiert und analysiert wer-
den, um Entwürfe ohne Programmierung zu prüfen. In diesem Kapitel 
erfahren Sie, wie in LabVIEW SignalExpress mit Signalen gearbeitet wird. 
Sie lernen, wie Signale grafisch dargestellt, aus Dateien importiert, interak-
tiv ausgerichtet, verglichen und in Dateien gespeichert werden.

Graphisches Darstellen von Signalen
Zum Darstellen der Signale in einem Beispielprojekt und zum visuellen 
Untersuchen der Signale anhand von Cursorn gehen Sie wie folgt vor:

1. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf 
Signals.seproj. In diesem Projekt wird der Schritt “Analoges 
Signal erstellen” so konfiguriert, dass er ein Rechtecksignal ausgibt 
und der Schritt “Filter” wird auf einen Butterworth-Tiefpass 
eingestellt.

2. Ziehen Sie den Ausgang step signal des Schritts “Signal erstellen” in 
die Datenansicht.

3. Ziehen Sie den Ausgang filtered step des Schritts “Filter” in die 
Datenansicht.

Signale gleichen Datentyps können zusammen in einem Graphen dar-
gestellt werden. Da step signal und filtered step Zeitbereichssignale 
sind, erscheinen sie im selben Graphen. Zur Darstellung zweier 
Signale unterschiedlichen Typs können Sie beide Signale in denselben 
Graphen ziehen. Das Programm erstellt dann automatisch einen neuen 
Graphen.

4. Klicken Sie auf die Schaltfläche Neue Anzeige (vgl. Abbildung links), 
damit ein neuer Graph erzeugt wird.

5. Ziehen Sie den Ausgang filtered step des Filterschritts in den neuen 
Graphen.
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6. Klicken Sie den neuen Graphen mit der rechten Maustaste an und 
wählen Sie aus dem Kontextmenü die Option Sichtbare Objekte»
Cursor aus, so dass zwei interaktive Cursor eingeblendet werden 
(vgl. Abbildung 4-1).

Abbildung 4-1.  Signals.seproj

Wenn Sie an den Cursorn ziehen, erscheinen in der Cursor-Tabelle 
unten in der Datenansicht die x- und y-Werte der Cursor. 

7. Klicken Sie auf Datei»Projekt speichern unter und speichern Sie das 
Projekt unter dem Namen My Signals.seproj im Verzeichnis 
SignalExpress\Examples\Tutorial.
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Importieren von Signalen aus Dateien
Signale können aus Standarddateiformaten wie ASCII (durch Kommata 
oder Tabulatoren gegliedert) oder LabVIEW-Dateien für Messwerte 
(.lvm-Dateien) importiert werden. Ebenso können simulierte Signale von 
Programmen zur Entwurfsautomatisierung (wie SPICE) einbezogen 
werden.

Zum Importieren eines Signals aus einer Datei gehen Sie wie folgt vor:

1. Klicken Sie mit der rechten Maustaste auf die Projektansicht und 
wählen Sie Signale laden/speichern»Analoge Signale»Aus 
ASCII-Datei laden aus dem Kontextmenü aus.

2. Klicken Sie auf der Registerkarte Schritteinstellungen auf die Schalt-
fläche “Durchsuchen” (vgl. Abbildung links), wechseln Sie zum 
Verzeichnis SignalExpress\Examples\Tutorial und klicken Sie 
die Datei Step Response.txt doppelt an. Der Schritt liest daraufhin 
die Signale in der ASCII-Datei und stellt sie grafisch dar.

In der Spalte 1 der Dateivorschau werden die Zeitwerte und in Spalte 
2 die tatsächlichen Spannungswerte des Signals angezeigt.

3. Klicken Sie auf die Registerkarte Signale importieren, so dass die 
Signale aus der Datei angezeigt werden.

4. Aktivieren Sie die Option Spalte 2, um das entsprechende Signal zu 
importieren, und deaktivieren Sie Spalte 1.

Auf der Registerkarte Schritteinstellungen wird nun unter Impor-
tiertes Signal eine Vorschau des Signals angezeigt.

5. Wählen Sie aus dem Pulldown-Menü x-Eingangswerte die Option 
Spalte 1 aus, um die Werte auf der x-Achse entsprechend einzustellen.

6. Öffnen Sie die Datenansicht.

7. Klicken Sie in der Projektansicht auf den Ausgang Spalte 2 und 
wählen Sie aus dem Kontextmenü die Option Umbenennen aus.

8. Geben Sie step response ein und drücken Sie <Enter>, um den 
neuen Namen zu übernehmen.

9. Ziehen Sie den Ausgang step response des Schritts “Aus ASCII-Datei 
laden” in den unteren Graphen in der Datenansicht.
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Das Signal filtered step ähnelt der steigenden Flanke des Ausgangs 
step response (vgl. Abbildung 4-2).

Abbildung 4-2.  Signals of Signals.seproj

10. Speichern Sie das Projekt über Datei»Projekt speichern.

Ausrichten und Vergleichen von Signalen
Obwohl sowohl am Signal filtered step als auch am Signal step response 
ein Überschwingen an der steigenden Flanke zu verzeichnen ist, lässt sich 
die Ähnlichkeit zwischen beiden nur schwer abschätzen, da die Signale aus 
unterschiedlichen Quellen stammen und in Amplitude und dt nicht iden-
tisch sind. Sie können die Signale jedoch mit dem Schritt “Interaktive 
Ausrichtung” aneinander ausrichten und auswählen, welche Angaben für 
das Projekt eine Rolle spielen sollen.
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Zum Ausrichten zweier Signale im Projekt My Signals.seproj gehen 
Sie wie folgt vor:

1. Klicken Sie mit der rechten Maustaste auf den Ausgang step response 
und wählen Sie Senden an»Verarbeitung»Analoge Signale»
Interaktive Ausrichtung aus dem Kontextmenü aus, um das Signal 
step response vom Schritt “Aus ASCII-Datei laden” in den Schritt 
“Interaktive Ausrichtung” zu übertragen.

Daraufhin werden die zwei neuesten Signale des Projekts als Ein-
gangssignale ausgewählt und im Graphen auf der Registerkarte 
Schritteinstellungen dargestellt (vgl. Abbildung 4-3).

Abbildung 4-3.  Einstellungen zum Schritt “Interaktive Ausrichtung”

Beim Hinzufügen von Schritten zu einem Projekt werden die Ein-
gangssignale je nach den Signaltypen ausgewählt, mit denen der 
Schritt arbeitet. Der Schritt “Interaktive Ausrichtung” funktioniert bei-
spielsweise nur mit Signalverläufen im Zeitbereich. Daher werden für 
den Schritt die zwei letzten Zeitbereichssignale ausgewählt, die im 
Projekt erstellt wurden. Um die Eingangssignale eines Schritts zu 
ändern, wählen Sie aus dem Pulldown-Menü auf der Registerkarte 
Eingang/Ausgang der Registerkarte Schritteinstellungen ein ande-
res Signal aus.
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2. Klicken Sie im Graphen Eingangssignale das rote Signal an und 
ziehen Sie es an eine andere Stelle im Graphen.

Sie können das Signal hin und her verschieben, aufziehen und 
stauchen.

3. Versuchen Sie, die steigenden Flanken der zwei Signale in eine Linie 
zu bringen, indem Sie das Signal im Graphen verschieben. Klicken Sie 
ein Signal an, um einen Ankerpunkt zu setzen, und ziehen Sie bei 
gedrückter <Alt>-Taste am Signal, um es auf der x- oder y-Achse um 
den Ankerpunkt zu dehnen. 

Auf der Registerkarte Ausrichtung der Registerkarte Schritteinstel-
lungen werden automatisch die Verstärkung (der Faktor) und der 
Offset (Summand) für den x- und y-Wert angezeigt.

4. Wählen Sie aus dem Pulldown-Menü Modus die Option Autom. 
Schritt aus, um die Signale in eine Linie zu bringen. Bei dieser Option 
wird die Ausrichtung automatisch berechnet. 

Die Unterschiede zwischen den beiden Signalen werden im unteren 
Graphen der Registerkarte Schritteinstellungen angezeigt.

5. Aktivieren Sie auf der Registerkarte Eingang/Ausgang die Option 
Ausgerichtete Signale ausgeben, um die Signale als Ausgangsgrößen 
des Schritts hinzuzufügen.

6. Klicken Sie auf die Registerkarte Datenansicht.

7. Klicken Sie auf die Schaltfläche Neue Anzeige (vgl. Abbildung links), 
damit ein dritter Graph erzeugt wird.

8. Ziehen Sie Bezugssignal ausgerichtet und Testsignal ausgerichtet 
in den neuen Graphen, um sich die ausgerichteten Signale anzusehen.

9. Speichern Sie das Projekt über Datei»Projekt speichern.

Signaltypen in LabVIEW SignalExpress
Einige Schritte, zum Beispiel der Schritt “Arithmetik”, arbeiten mit ver-
schiedenen Signaltypen. Beispielsweise können Sie damit Berechnungen 
an Zeit- und Frequenzbereichssignalen vornehmen. Je nach Eingangssignal 
des Schritts passt sich der Schritt dann entsprechend an. Wenn Sie zum 
Beispiel zwei Zeitbereichssignale addieren, werden nur die Amplituden 
addiert. Bei zwei Frequenzbereichssignalen wird dagegen die entspre-
chende Phasenverschiebung addiert.

Weitere Informationen finden Sie in der Hilfe zu LabVIEW SignalExpress, 
indem Sie Hilfe»LabVIEW-SignalExpress-Hilfe, auf die Registerkarte 
Suchen klicken und das Stichwort Signaltypen eingeben.
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Exportieren und Drucken von Signalen
In LabVIEW SignalExpress können Sie Signale beschreiben und in ande-
ren Programmen weiter analysieren. In diesem Abschnitt lernen Sie, wie 
Signale exportiert (z. B. in eine ASCII-Datei), an Microsoft Excel übertra-
gen, gedruckt oder mit der Dokumentationsfunktion von LabVIEW 
SignalExpress beschrieben werden.

Speichern von Signalen in Dateien
Zum Speichern eines Signals in einer Datei gehen Sie wie folgt vor:

1. Klicken Sie auf die Schaltfläche Schritt hinzufügen und wählen Sie 
Signale laden/speichern»Als ASCII/LVM speichern.

2. Klicken Sie auf der Registerkarte Schritteinstellungen auf die Regi-
sterkarte Signale und wählen Sie aus dem Pulldown-Menü 
Eingangsdaten die Option filtered step aus.

3. Speichern Sie die Datei anschließend auf der Registerkarte Datei-Ein-
stellungen im Feld “Pfad zur Exportdatei” unter SignalExpress\
Examples\Tutorial.

4. Wählen Sie aus dem Pulldown-Menü Bei vorhandener Datei die 
Option Überschreiben aus.

5. Wählen Sie aus dem Pulldown-Menü Typ der Exportdatei die Option 
Allgemeine ASCII-Datei aus.

Mit dem Schritt “Signale laden/speichern” können Sie bei jeder Aus-
führung des Projekts Daten in Dateien speichern.

6. Klicken Sie auf die Schaltfläche Schließen, um die Registerkarte 
Schritteinstellungen zu schließen.

7. Speichern Sie das Projekt über Datei»Projekt speichern.

8. Schließen Sie das Projekt über Datei»Projekt schließen.

Exportieren von Signalen in Microsoft Excel
Um Signaldaten in Microsoft Excel zu exportieren, starten Sie Excel und 
ziehen Sie das Ausgabesignal eines Schritts in die Excel-Tabelle.

Drucken von Signalen
Zum Ausdrucken eines Graphen öffnen Sie die Datenansicht und wählen 
Sie Datei»Drucken»Datenansicht drucken.
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Erstellen von Reports in LabVIEW SignalExpress
Über Ansicht»Projektdokumentation wird die Ansicht “Projektdoku-
mentation” geöffnet. Hier können Sie Ihr Projekt beschreiben und die 
Ausgangsgrößen von Schritten per Drag-and-Drop in den Text hineinzie-
hen. Die Abbildung in der Projektdokumentation passt sich dabei 
automatisch dem aktuellen Ausgabewert des Schrittes an. 

Zum Drucken Ihrer Dokumentation öffnen Sie die Ansicht “Projektdoku-
mentation” und wählen Sie Datei»Drucken»Dokumentation drucken. 
Zum Umwandeln der Dokumentation ins HTML-Format öffnen Sie die 
Ansicht “Projektdokumentation” und wählen Sie Datei»Exportieren»
Dokument als HTML-Datei speichern.
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5
Protokollieren von Daten

Mit LabVIEW SignalExpress können Sie Messergebnisse aufzeichnen und 
auswerten. Sie können alle Arten von Zeitbereichssignalen bzw. Werten 
mit doppelter Genauigkeit sowie im U32- und im booleschen Format pro-
tokollieren. Außerdem können Sie protokollierte Werte analysieren und 
verarbeiten, indem Sie sie Analyseschritte durchlaufen lassen. 

In diesem Kapitel lernen Sie, wie Werte mit den entsprechenden Funktio-
nen in LabVIEW SignalExpress protokolliert werden. Sie erfahren, wie ein 
angegebenes Signal aufgenommen, wiedergegeben und mit den 
Analyseschritten ausgewertet wird. Außerdem wird die Ansicht “Aufnah-
meoptionen” beschrieben, wo Sie Signale nach bestimmten Start- oder 
Endbedingungen protokollieren können. 

Aufnehmen eines Signals
Mit der Schaltfläche Aufnahme wird die Protokollierung konfiguriert. 

Zum Auswählen und Aufnehmen eines Signals gehen Sie wie folgt vor:

1. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf 
Logging.seproj.

In diesem Projekt wird mit dem Schritt “Analoges Signal erstellen” ein 
Signal anhand einer Formel erstellt.

2. Klicken Sie auf die Schaltfläche Aufnahme (vgl. Abbildung links), 
um zum Dialogfeld Signalauswahl für Protokollierung zu gelangen.

Das Dialogfeld Signalauswahl für Protokollierung zeigt alle Signale 
im Projekt an, die aufgenommen werden können. Sie können ein 
Signal oder mehrere Signale auswählen. Außerdem kann das Protokoll 
hier benannt und beschrieben werden.

3. Aktivieren Sie die Option signal, um das berechnete Signal des 
Schritts Analoges Signal erstellen aufzunehmen.

4. Klicken Sie auf die Schaltfläche OK, um das Dialogfeld Signalaus-
wahl für Protokollierung zu schließen und die Aufnahme zu 
beginnen. Die Aufnahme läuft bis zum Anklicken der Schaltfläche 
Stopp.
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5. Klicken Sie auf die Schaltfläche Stopp (vgl. Abbildung links), um die 
Aufnahme anzuhalten. 

Die aufgezeichneten Werte werden im Fenster Protokollierte Werte 
(siehe Abbildung 5-1) angezeigt.

Abbildung 5-1.  Fenster “Protokollierte Werte”

Per Voreinstellung werden die Werte mit dem Datum und der Zeit 
gekennzeichnet, zu der sie aufgezeichnet wurden. Die Werte werden in 
einer Datei im *.tdms-Format in dem unter Optionen angegebenen 
Verzeichnis gespeichert. 

6. Zur Auswahl des Speicherorts für das Protokoll wählen Sie Werk-
zeuge»Optionen und klicken Sie auf Protokollierung. Hier finden 
Sie auch alle anderen Einstellungen zur Protokollierung.

7. Klicken Sie auf die Schaltfläche OK, um das Dialogfeld Optionen zu 
schließen.

8. Speichern Sie das Projekt über Datei»Projekt speichern.

Anzeigen aufgezeichneter Signale
Zum Anzeigen der aufgezeichneten Werte gehen Sie wie folgt vor:

1. Wenn die Datenansicht ausgeblendet ist, wählen Sie Ansicht»
Datenansicht. 

2. Unter Protokolle wird eine Liste aller aufgezeichneten Werte des Pro-
jekts angezeigt. Markieren Sie das Protokoll, das Sie gerade erstellt 
haben, und ziehen Sie es in die Datenansicht. In der Datenansicht 
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sehen Sie nun eine Vorschau der Werte (vgl. Abbildung 5-2). Das in 
der Datenansicht angezeigte Signal kann je nach Länge der Aufzeich-
nung allerdings von der Vorschau abweichen.

Abbildung 5-2.  Logging.seproj

In der Vorschau können Sie die Ansicht verkleinern, vergrößern und 
verschieben. Die Vorschau wird bei der Anzeige aufgezeichneter 
Werte immer als erstes geöffnet. Für aktuelle oder andere, nicht aufge-
zeichnete Werte können Sie die Vorschau jedoch auch öffnen, indem 
Sie die Datenansicht mit der rechten Maustaste anklicken und Sicht-
bare Objekte»Vorschau auswählen.

3. Zum Vergrößern der aufgezeichneten Werte klicken Sie auf die Schalt-
fläche Heranzoomen neben der Vorschau. Die Cursor in der Vorschau 
deuten auf die Werte, die gerade in der Vorschau angezeigt werden. 
Mit der Bildlaufleiste unter der Vorschau können Sie durch die Werte 
scrollen. Durch Anklicken und Ziehen der Cursor können Sie mehr 
oder weniger Werte ansehen.
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Protokollieren von Signalen mit festgelegten Start- und 
Endbedingungen

Mit Hilfe von Start- und Endbedingungen können Sie auch einen Zeitraum 
festlegen, während dessen Signale aufgezeichnet werden sollen. Gehen Sie 
dazu wie folgt vor:

1. Wenn die Registerkarte Aufnahmeoptionen nicht angezeigt wird, 
wählen Sie Ansicht»Aufnahmeoptionen.

2. Wählen Sie aus der Liste Kategorie die Option Signalauswahl aus.

3. Setzen Sie dann neben dem Signal in der Spalte Aufnahme ein Häk-
chen (vgl. Abbildung 5-3).

Abbildung 5-3.  Signalauswahl

Die Schaltfläche Aufnahme wandelt sich daraufhin in Aufnahme 
während Ausführung um (vgl. Abbildung links). Die Schaltfläche 
Aufnahme während Ausführung muss angeklickt sein. Wenn diese 
Schaltfläche gedrückt ist, wird das ausgewählte Signal nach Anklicken 
von Ausführen oder Einmal ausführen aufgezeichnet.

4. Wählen Sie aus der Liste Kategorie die Option Startbedingungen 
aus. 
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5. Legen Sie eine Startbedingung für die Protokollierung fest, indem Sie 
unter Bedingungen für Protokollbeginn die Schaltfläche Hinzufü-
gen anklicken.

a. Wählen Sie unter Auslöser die Option Signal aus und geben Sie 
eine Bedingung für die Protokollierung an.

b. Wählen Sie aus dem Feld Signal die Option signal aus.

c. Wählen Sie unter Bedingung die Option Pos. Steigung aus, so 
dass das Signal an einem bestimmten Signalwert bei einer positi-
ven Steigung aufgezeichnet wird.

d. Geben Sie 1 unter Wert ein. Die Protokollierung beginnt dann 
beim Wert 1 einer steigenden Flanke.

6. Wählen Sie aus der Liste Kategorie die Option Stoppbedingungen 
aus.

7. Legen Sie eine Stoppbedingung für die Protokollierung fest, indem Sie 
unter Bedingungen für Protokollende die Schaltfläche Hinzufügen 
anklicken.

a. Wählen Sie unter Auslöser die Option Dauer aus.

b. Geben Sie als Dauer den Wert 5 ein. Das Signal wird dann nach 
Erfüllen der Startbedingung 5 Sekunden aufgezeichnet.

c. Klicken Sie auf die Schaltfläche Ausführen (vgl. Abbildung 
links). LabVIEW SignalExpress beginnt dann beim Übersteigen 
von Pegel 1 an einer steigenden Flanke mit der Protokollierung 
und zeichnet die fünf darauf folgenden Sekunden auf. 

Die Anzeige Aufnahme am unteren Rand der Aufnahmeoptionen 
schaltet auf ein, wenn die Protokollierung läuft. Unter Festplat-
tenangaben sehen Sie, wie viel Festplattenspeicher für die 
Protokollierung noch frei ist.

Analysieren aufgezeichneter Signale
Nach dem Aufzeichnen eines Signals können Sie dieses genau wie ein 
nicht aufgezeichnetes Signal wieder abspielen und mit Analyseschritten 
auswerten. Zum Analysieren eines aufgezeichneten Signals gehen Sie wie 
folgt vor:

1. Klicken Sie im Pulldown-Menü Arbeitsbereich in der linken oberen 
Ecke des LabVIEW-SignalExpress-Fensters (vgl. Abbildung 5-4) auf 
den Pfeil nach unten und wählen Sie Wiedergabemodus, um den 
Arbeitsbereich auf Wiedergabe umzustellen.
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Abbildung 5-4.  Pulldown-Menü zur Auswahl des Arbeitsbereichs

In den Arbeitsbereichen können Sie im selben Projekt mehrere unter-
schiedliche Arbeitsschritte ausführen. So können Sie z. B. Daten 
erfassen, Signale verarbeiten, Daten aufzeichnen und Messungen an 
den aufgezeichneten Daten vornehmen, ohne dazu ein neues Projekt 
öffnen zu müssen. Beim Speichern eines Projekts werden alle Arbeits-
bereiche zum Projekt in derselben Datei gespeichert. 

Im voreingestellten Arbeitsbereich, “Monitor-/Aufnahmemodus”, 
können Sie Messungen an Signalen durchführen, die Signale auswer-
ten und aufzeichnen. Im Wiedergabebereich können Sie 
aufgezeichnete Signale mit Analyseschritten auswerten. So können 
Sie z. B. eine Messung vornehmen und das betreffende Signal im 
Arbeitsbereich “Monitor-/Aufnahmemodus” protokollieren und das 
aufgezeichnete Signal dann im Arbeitsbereich “Wiedergabemodus” 
einem Analyseschritt zuführen. 

2. Klicken Sie auf die Schaltfläche Schritt hinzufügen (vgl. Abbildung 
links) und wählen Sie Verarbeitung»Analoge Signale»Filter. An den 
Eingang des Schritts “Filter” wird automatisch das erste aufgezeich-
nete Signal angelegt.

3. Wechseln Sie zur Datenansicht. Ziehen Sie zur Anzeige des resultie-
renden Signals den Ausgang gefilterte Daten des Schritts “Filter” in 
die Datenansicht.

4. Klicken Sie auf die Schaltfläche Ausführen (vgl. Abbildung links). 
In der Datenansicht wird nun das gefilterte Signal angezeigt und 
LabVIEW SignalExpress spielt die gesamte Aufzeichnung ab.

Erweiterte Wiedergabe
In der Ansicht “Wiedergabeoptionen” finden Sie jedoch auch erweiterte 
Einstellungen zur Signalwiedergabe. In den Wiedergabeoptionen wird eine 
Vorschau der aufgezeichneten Daten angezeigt und Sie können daraus 
einen Abschnitt auswählen, der mit den Analyseschritten ausgewertet 
werden soll.

1. Wählen Sie Ansicht»Wiedergabeoptionen, um die Ansicht “Wieder-
gabeoptionen” (vgl. Abbildung 5-5) zu öffnen. Hier finden Sie eine 
Vorschau der aufgezeichneten Daten, in der Sie die Daten abschnitts-
weise auswerten können. 
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Abbildung 5-5.  Ansicht “Wiedergabeoptionen”

2. Wählen Sie aus dem zweiten Protokoll, das Sie unter Protokolliertes 
Signal erstellt haben, die Option signal aus.

3. Geben Sie als Startzeit den Wert 1 ein. So werden alle Daten abge-
spielt oder ausgewertet, die eine Sekunde nach Beginn der 
Aufzeichnung aufgenommen wurden. 

4. Geben Sie als Stoppzeit den Wert 4 ein. Damit werden alle Daten bis 
zum Ablauf von vier Sekunden nach Aufzeichnungsbeginn abgespielt 
oder ausgewertet.

5. Wechseln Sie zur “Datenansicht” und ziehen Sie das gefilterte Signal 
des Schritts “Filter” dort hinein.

6. Klicken Sie auf die Schaltfläche Ausführen (vgl. Abbildung links). 
Dadurch wird nur der Bereich des Signals gefiltert, den Sie in den Wie-
dergabeoptionen angegeben haben. Das gefilterte Signal wird in der 
Datenansicht angezeigt.

7. Klicken Sie auf die Schaltfläche Stopp, um das Projekt anzuhalten.

In der Hilfe zu LabVIEW SignalExpress sind weitere Optionen zur 
Aufzeichnung und Wiedergabe von Daten, z. B. anhand von Alarmbedin-
gungen, beschrieben.
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6
Messungen mit variierenden 
Größen

Mit LabVIEW SignalExpress können Sie Messungen mit dem so genann-
ten Sweep-Modus automatisieren, um Produktentwürfe zu testen und zu 
überprüfen, ob sie realen Bedingungen standhalten. Anhand von 
Sweep-Messungen können Sie Daten zu Produktentwürfen über einen 
Bereich von Bedingungen hinweg gewinnen, um die Funktionsweise der 
Entwürfe zu dokumentieren. So können Sie zum Beispiel die Frequenz 
eines angelegten Signals wobbeln oder eine Versorgungsspannung 
variieren.

In diesem Kapitel lernen Sie, wie mit dem Sweep-Schritt in LabVIEW 
SignalExpress Messungen mit variierenden Parametern vorgenommen 
werden. Sie erfahren u. a., wie die Reaktion eines Filters auf eine Reihe ver-
schiedener Frequenzen gemessen wird. Es wird beschrieben, wie die 
Ergebnisse der Sweep-Messung angezeigt und parallele Sweeps für kom-
plexe Messungen vorgenommen werden.

Festlegen des Messbereichs und der Ausgangsgrößen
In LabVIEW SignalExpress können Sie Messungen durch komplexe, sich 
wiederholende Messungen mit variierenden Parametern automatisieren.

Zum Festlegen eines Frequenzbereichs, mit dem ein Filter in einem Bei-
spielprojekt gewobbelt werden soll, gehen Sie wie folgt vor:

1. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf 
Sweep.seproj.

2. Klicken Sie auf die Schaltfläche Ausführen (vgl. Abbildung links), 
um das Projekt zu starten.

Das Projekt generiert mit Hilfe des Schritts “Analoges Signal erstel-
len” ein Sinussignal, das den Schritt “Filter” (als elliptischer 
Bandpassfilter konfiguiert) durchläuft. Anschließend wird mit dem 
Schritt “Amplitude und Pegel” der Effektivpegel des Filters gemessen 
und mit dem Schritt “Formel” in Dezibel umgerechnet. Der 
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Filterschritt soll das Testobjekt simulieren, so dass das Projekt ohne 
reale Geräte auskommt. Sie können jedoch auch ein tatsächliches 
Signal von einem Arbiträrgenerator, Funktionsgenerator, einer Multi-
funktionskarte von National Instruments oder das Ergebnis einer 
Analyse dynamischer Signale verwenden.

3. Klicken Sie auf die Schaltfläche Schritt hinzufügen (vgl. Abbildung 
links) und wählen Sie Ausführungssteuerung»Sweep.

4. Klicken Sie auf der Registerkarte Schritteinstellungen auf die Schalt-
fläche Hinzufügen. Daraufhin wird zu jedem Schritt im Projekt eine 
Liste variierbarer Parameter angezeigt (vgl. Abbildung 6-1).

Abbildung 6-1.  Auswahlfeld der variierbaren Messparameter

5. Wählen Sie unter Analoges Signal erstellen die Option Frequenz aus 
und klicken Sie auf OK.

Der Schritt “Analoges Signal erstellen” ist in den Schritt “Sweep” ein-
gebettet und stellt das Signal für die Messung bereit.

6. Wählen Sie auf der Registerkarte Sweep-Konfiguration aus dem 
Pulldown-Menü Typ die Option Exponentiell aus.

7. Stellen Sie Start: Frequenz (Hz) auf 1k und die Stopp: Frequenz 
(Hz) auf 40k ein.

8. Geben Sie unter Werteanzahl den Wert 150 ein.
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Die Registerkarte Sweep-Konfiguration sollte Abbildung 6-2 
entsprechen.

Abbildung 6-2.  Dialogfeld “Schritteinstellungen” zum Schritt “Sweep”

Mit dem Schritt “Sweep” können Sie für den Parameter Frequenz des 
Schritts “Analoges Signal erstellen” einen Bereich von Werten festle-
gen, die nacheinander durchlaufen werden sollen. Der Schritt 
“Analoges Signal erstellen” erzeugt dann anhand dieses Bereichs bei 
jeder der Frequenzen eine Sinusschwingung. Der Sweep-Schritt ist 
aber nicht auf das Wobbeln von Frequenzen beschränkt, sondern funk-
tioniert auch mit anderen Schritten, sofern deren Parameter variierbar 
sind.

9. Klicken Sie auf die Registerkarte Sweep-Ausgang.

10. Klicken Sie auf die Schaltfläche Hinzufügen, um zu jedem Schritt 
eine Liste variierbarer Parameter anzuzeigen.

11. Wählen Sie den Ausgang response amplitude in dB unter Formel aus 
und klicken Sie auf OK, um die Messung den gewobbelten 
Frequenz-Parameter visuell gegenüberzustellen.
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Mit dem Sweep-Schritt wird um alle anderen Schritte in der Projektan-
sicht eine Schleife gelegt, in der diese wiederholt werden.

Darstellen der Sweep-Ergebnisse
Beginnen Sie die Messung mit variierenden Parametern wie folgt:

1. Klicken Sie zum Durchführen der Messung auf die Schaltfläche 
Einmal ausführen (vgl. Abbildung links).

Der Ausgang stimulus signal des Graphen geht nun die Frequenzen 
im angegebenen Bereich nacheinander durch.

2. Ziehen Sie das Signal response amplitude in dB vs. Frequenz (Hz) 
am unteren Rand der Sweep-Schleife in die Datenansicht, damit das 
Ergebnis der Messung angezeigt wird.

Daraufhin wird ein neuer Graph erzeugt. Die Messung mit variieren-
den Parametern ergibt ein x-y-Array, für das ein gesonderter Graph 
benötigt wird (vgl. Abbildung 6-3).

Abbildung 6-3.  Sweep.seproj

3. Klicken Sie zum Durchführen der Messung auf die Schaltfläche 
Einmal ausführen.
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Der Frequenzgang des Filters wird im neuen Graphen dargestellt. Der 
Graph zeigt die Übertragungsfunktion des Filters an, also die Ampli-
tude in dB im Vergleich zur Frequenz.

4. Klicken Sie den Schritt “Filter” doppelt an, so dass auf der Register-
karte Schritteinstellungen die Filterspezifikationen angezeigt 
werden.

Der unter Amplitudengang des Filters dargestellte Frequenzgang 
entspricht genau dem Graphen in der Datenansicht.

5. Klicken Sie auf Datei»Projekt speichern unter und speichern Sie das 
Projekt unter dem Namen My Sweep.seproj im Verzeichnis 
SignalExpress\Examples\Tutorial.

Sie können auch mehrere Parameter gleichzeitig variieren, indem Sie auf 
der Registerkarte Sweep-Konfiguration in den Schritteinstellungen zum 
Schritt “Sweep” weitere Parameter auswählen. Ein Sweep mit mehreren 
variierenden Parametern wird paralleler Sweep genannt. Das ist zum Bei-
spiel der Fall, wenn sich die Amplitude des angelegten Signals auch ändern 
soll. Durch gleichzeitiges Variieren mehrerer Parameter lässt sich die 
höchstmögliche Messgenauigkeit erzielen, zum Beispiel, indem der Ein-
gangsbereich eines A/D-Wandlers oder einer MIO-Karte bei variierenden 
Signalpegeln durchlaufen wird. Durch stetiges Anpassen des Eingangsbe-
reichs des Messgeräts an den Signalpegel können Sie die ganze Auflösung 
des Geräts für die Messung ausnutzen.

Geschachtelte Messungen mit variierenden Parametern
Ebenso kann ein Sweep in Abhängigkeit von einer Größe durchgeführt wer-
den, wobei die Größe für die Dauer des Sweeps konstant bleibt, aber 
während der Messung ebenfalls kontinuierlich variiert (Schachtelung). So 
können Sie zum Beispiel bei verschiedenen Amplituden durch die Frequen-
zen eines Signals wobbeln. Sie würden die Amplitude beispielsweise auf 
den Pegel 1 setzen und durch die Frequenzen wobbeln, dann die Amplitude 
auf 2 setzen und durch die Frequenzen wobbeln usw. Um eine geschachtelte 
Messung mit variierenden Parametern durchzuführen, klicken Sie einen 
Sweep-Schritt in einem Projekt mit der rechten Maustaste an und wählen 
Sie Multi-Sweep hinzufügen, um eine weitere Sweep-Schleife einzufügen. 

Es gibt ein Beispielprojekt, in dem geschachtelte Messungen mit variieren-
den Parametern demonstriert werden. Dieses wird wie folgt gestartet:

1. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf 
Nested Sweep.seproj.
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2. Klicken Sie auf die Schaltfläche Ausführen (vgl. Abbildung links), 
um das Projekt zu starten.

Jedes Mal, wenn die innere Sweep-Schleife durchläuft, wird die 
Frequenz des anliegenden Signals gewobbelt. Mit der äußeren 
Sweep-Schleife werden die obere und untere Grenzfrequenz des 
Schritts “Filter” verändert. Jede Iteration wird verzögerungsfrei im 
oberen Graphen dargestellt. Im unteren Graphen erscheinen dazu 
die Messergebnisse bei jeder Änderung der Grenzfrequenz 
(vgl. Abbildung 6-4).

Abbildung 6-4.  Nested Sweep.seproj

3. Klicken Sie auf die Schaltfläche Stopp (vgl. Abbildung links), um das 
Projekt anzuhalten.
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7
Erweitern von 
LabVIEW-SignalExpress-
Projekten durch LabVIEW

Durch die Schritte zur Erfassung, Erzeugung, Analyse oder Aufzeichnung 
von Daten können Sie mit LabVIEW SignalExpress automatisierte Mes-
sungen vornehmen. Das Programm kann jedoch auch folgendermaßen 
durch LabVIEW erweitert werden:

• Erstellen eines VIs in LabVIEW und Importieren des VIs in LabVIEW 
SignalExpress als neuer Schritt. So können Sie die Funktionen des 
Programms beliebig erweitern. 

• Umwandeln eines LabVIEW-SignalExpress-Projekts in ein 
LabVIEW-Blockdiagramm, um den Schritt in LabVIEW weiter 
auszubauen.

Beachten Sie: Für die Übungen in diesem Kapitel benötigen Sie eine 
LabVIEW-Version ab 7.1.

Importieren von LabVIEW-VIs in LabVIEW 
SignalExpress als neue Schritte

Mit dem Schritt “LabVIEW-VI ausführen” können Sie beliebige 
LabVIEW-VIs von LabVIEW SignalExpress aus aufrufen. Dadurch sind 
folgende Funktionen mit dem Programm möglich:

• Steuern von GPIB-Instrumenten

• Arbeit mit Hardware von National Instruments, die LabVIEW Signal-
Express nicht unterstützt

• Arbeit mit zusätzlichen Dateiformaten

• Einblenden von Bedienungsanleitungen in Popup-Dialogfeldern

• Festlegen von Messalgorithmen
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Gehen Sie zum Importieren eines LabVIEW-VIs in den Schritt 
“LabVIEW-VI ausführen” wie folgt vor: 

1. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial und klicken Sie doppelt auf 
User Step.seproj.

In diesem Projekt wird mit dem Schritt “Analoges Signal erstellen” ein 
Signal erstellt.

2. Klicken Sie auf die Schaltfläche Schritt hinzufügen und wählen Sie 
LabVIEW-VI ausführen»VI ausführen - LabVIEW 8.2. 

Das in dieser Übung verwendete VI wurde in LabVIEW 8.2 gespei-
chert. Sie müssen immer die Version des Schritts “LabVIEW-VI 
ausführen” aufrufen, in der das VI gespeichert wurde.

3. Klicken Sie im Dialogfeld Schritteinstellungen auf die Schaltfläche 
“Durchsuchen” und suchen Sie unter SignalExpress
\Examples\Tutorial nach Limiter-LV82.vi. Dieses VI schnei-
det ein Zeitbereichssignal an den in den Schritteinstellungen 
festgelegten Werten ab. 

Beim Importieren eines LabVIEW-VIs werden die Eingänge des VIs 
als Schrittparameter und die Ausgänge des VIs als Ausgänge des 
Schritts interpretiert.

Bei den VI-Eingängen können Sie unterscheiden, ob diese Eingangs-
signale oder Parameter darstellen sollen. Ein Eingangssignal erscheint 
in der Projektansicht als Eingang eines Schritts, so dass Sie dem VI 
von außen Signale zuführen können. Parameter sind alle Schrittein-
stellungen im Dialogfeld zu einem Schritt. Mit dem Sweep-Schritt 
können Sie auch bestimmte Parameter dynamisch ändern. Im vorlie-
genden Projekt liegt am VI ein Zeitbereichssignal an (time waveform 
in) und es hat die Parameter Upper limit (Obergrenze) und Lower 
limit (Untergrenze). Beides sind Skalarwerte. 
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Das Dialogfeld Schritteinstellungen sollte wie in Abbildung 7-1 
aussehen.

Abbildung 7-1.  Einstellungen zum Schritt “Limiter.vi”

4. Klicken Sie auf die Schaltfläche Ausführen (vgl. Abbildung links), 
um das Projekt zu starten. 

5. Ziehen Sie den Ausgang Clipped waveform out des VI-Schritts in die 
Datenansicht.

6. Klicken Sie den Schritt doppelt an, so dass die Schritteinstellungen 
angezeigt werden.

7. Klicken Sie auf die Registerkarte VI konfigurieren. 

8. Ändern Sie die Werte für Upper limit und Lower limit. Geben Sie 
z. B. für Upper limit den Wert 100 ein und drücken Sie <Enter>.

Das Signal Clipped waveform out wird nun in der Datenansicht den 
Änderungen entsprechend angezeigt. 

Informationen zum Verwenden von VIs in LabVIEW SignalExpress sowie 
zum Entwickeln von VIs, die für LabVIEW SignalExpress geeignet sind, 
finden Sie in der Hilfe zu LabVIEW SignalExpress.
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Umwandeln von LabVIEW-SignalExpress-Projekten in 
LabVIEW-Blockdiagramme

LabVIEW-SignalExpress-Projekte können in LabVIEW-Blockdiagramme 
umgewandelt werden.

Hinweis Zur Umwandlung eines LabVIEW-SignalExpress-Projekts in ein LabVIEW-VI 
wird das LabVIEW Full Development System ab 7.1 benötigt.

Gehen Sie zum Umwandeln eines LabVIEW-SignalExpress-Projekts in ein 
LabVIEW-Blockdiagramm wie folgt vor:

1. Klicken Sie auf Datei»Projekt öffnen, wechseln Sie zum Verzeichnis 
SignalExpress\Examples\Tutorial\Solutions und klicken 
Sie doppelt auf My First Project.seproj.

2. Wählen Sie Werkzeuge»Programmcode erzeugen»LabVIEW-
Blockdiagramm.

3. Geben Sie einen Namen und Speicherort für das neue VI an und klik-
ken Sie auf OK.

Das erzeugte LabVIEW-Blockdiagramm spiegelt den Projektablauf 
in LabVIEW SignalExpress wider. Es besteht aus mehreren 
LabVIEW-Express-VIs, die miteinander verbunden sind. Jedes 
Express-VI entspricht einem Schritt im LabVIEW-SignalExpress-Pro-
jekt. Bei einem Doppelklick auf ein Express-VI werden die gleichen 
Schritteinstellungen wie in LabVIEW SignalExpress angezeigt. Sie 
können die Express-VIs auch mit der rechten Maustaste anklicken und 
Frontpanel öffnen auswählen, um sie in LabVIEW-SubVIs umzu-
wandeln. Im Blockdiagramm können Sie sehen, wie das VI ausgeführt 
wird und das VI ändern. Die Umwandlung eines Express-VIs in ein 
SubVI ist nicht umkehrbar.

Hinweis Beim Umwandeln eines LabVIEW-SignalExpress-Projekts, mit dem Signale 
aufgezeichnet werden können, enthält das entstandene Blockdiagramm nur ein 
Express-VI. Das Express-VI lässt sich nicht in ein SubVI umwandeln.
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8
Weitere Informationen

Weitere Informationen zu LabVIEW SignalExpress erhalten Sie durch:

LabVIEW-SignalExpress-Beispielprojekte
Zu LabVIEW SignalExpress gibt es eine Vielzahl von Beispielprojekten, 
in denen die Funktionen des Programms veranschaulicht werden. Die Pro-
jekte befinden sich im Verzeichnis SignalExpress\Examples. Die 
Beispiele sollen Ihnen helfen, sich mit den Funktionen von LabVIEW 
SignalExpress vertraut zu machen. Sie können ein Beispiel auch als Grund-
lage für ein eigenes Projekt verwenden. 

Verwenden von Hardware mit LabVIEW SignalExpress
In der vorliegenden Anleitung wurden keine Hinweise auf das Ansteuern 
von Hardware mit LabVIEW SignalExpress gegeben, da das Programm die 
verschiedensten Karten von National Instruments zur Erfassung und Aus-
gabe von Signalen unterstützt. LabVIEW SignalExpress arbeitet mit 
MIO-Karten, Karten zur Analyse dynamischer Signale, Hochgeschwindig-
keits-A/D-Wandlern sowie Arbiträr- und Funktionsgeneratoren von 
National Instruments. Sie können auch mehrere Geräte in einem System 
synchronisieren, indem Sie für alle Geräte denselben Takt oder Trigger 
verwenden. Weitere Einzelheiten zur Verwendung von Hardware in Lab-
VIEW SignalExpress finden Sie in der Hilfe zu LabVIEW SignalExpress, 
die sich unter Hilfe»LabVIEW-SignalExpress-Hilfe befindet.

Informationen im WWW
Auf der Website von National Instruments zu LabVIEW SignalExpress, 
ni.com/signalexpress, finden Sie Beispielprojekte, technische 
Beschreibungen und LabVIEW-VIs für das Programm.

http://ni.com/signalexpress
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A
Technische Unterstützung und 
professioneller Service

Für professionelle Serviceleistungen und technische Unterstützung lesen 
Sie bitte auf unserer Website ni.com unter folgenden Kategorien nach:

• Support: Auf ni.com/support gibt es folgende Informationsquel-
len zur technischen Unterstützung:

– Hilfe zur Selbsthilfe: Die preisgekrönte Website von National 
Instruments bietet unter anderem Treiber und Updates, eine 
umfassende Informationsdatenbank (KnowledgeBase), Bedie-
nungsanleitungen, Anleitungen zur Fehlersuche, Tausende 
Beispielprogramme, Lernhilfen, Application Notes und 
Gerätetreiber.

– Kostenlose technische Unterstützung: Alle registrierten Benut-
zer können den kostenlosen Basis-Support in Anspruch nehmen, 
der unter anderem auch den Zugriff auf Diskussionsforen von 
National Instruments auf ni.com/forums einschließt, in denen 
Sie sich bei Problemen mit Hunderten Applikationsingenieuren 
weltweit austauschen können. Die Applikationsingenieure von 
National Instruments sorgen dafür, dass alle Ihre Fragen beant-
wortet werden.

Welche Art der technischen Unterstützung es in Ihrer Nähe gibt, 
erfahren Sie unter ni.com/services oder indem Sie sich mit 
einer Niederlassung von National Instruments in Ihrer Nähe in 
Verbindung setzen (ni.com/contact). 

• Schulung und Zertifizierung: Auf ni.com/training finden Sie 
Lernhandbücher, virtuelle Schulungsräume, Übungs-CDs und Infor-
mationen über Lernprogramme mit Abschlusszertifikat. Hier können 
Sie sich auch für eine der weltweit angebotenen Software-Schulungen 
anmelden.

• System-Integration: Wenn Sie aus Zeit-, Personalmangel oder ande-
ren Gründen bei der Fertigstellung eines Projekts in Verzug geraten, 
können Ihnen die Mitglieder des NI-Alliance-Programms weiterhel-
fen. Für Informationen zu diesem Programm setzen Sie sich entweder 
telefonisch mit einer National-Instruments-Niederlassung in Ihrer 

http://ni.com
http://ni.com/support
http://ni.com/forums
http://ni.com/services
http://ni.com/contact
http://ni.com/training
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Nähe in Verbindung oder besuchen Sie die Website 
ni.com/alliance.

Sollten Sie nach dem Besuch unserer Internetseite ni.com immer noch 
offene Fragen haben, wenden Sie sich bitte an eine Niederlassung von 
National Instruments in Ihrer Nähe. Die Telefonnummern aller Niederlas-
sungen finden Sie am Anfang dieses Handbuchs. Auf die Internetseiten der 
einzelnen Niederlassungen, auf denen Sie immer die aktuellen Kontaktin-
formationen, Telefonnummern des technischen Supports, E-Mail-Adressen 
sowie aktuelle Ereignisse und Veranstaltungen finden, gelangen Sie über 
ni.com/niglobal.

http://ni.com/alliance
http://ni.com/niglobal
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保証
NIのソフトウェア製品が記録されている媒体は、素材および製造技術上の欠陥によるプログラミング上の問題に対して、受領書
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あった場合、NIは、本書を所有するお客様への事前の通告なく、本書の次の版を改訂する権利を有します。誤りと思われる個所
がありましたら、NIへご連絡ください。NIは、本書およびその内容により、またはそれに関連して発生した損害に対して、一
切責任を負いません。

NIは、ここに記載された以外、明示または黙示の保証は致しません。特に、商品性または特定用途への適合性に関する保証は致
しません。NI側の過失または不注意により発生した損害に対するお客様の賠償請求権は、お客様が製品に支払われた金額を上限
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可能性を通知されていた場合でも、一切の責任を負いません。NIの限定保証は、訴訟方式、契約上の責任または不法行為に対す
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す。NIは、NIの合理的に管理可能な範囲を超えた原因により発生した履行遅延に関しては一切の責任を負いません。所有者が
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著作権
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設計者は、適正で慎重なシステム故障防止策を取る必要があります。これには、システムのバックアップまたは停止が含まれ
ますが、これに限定されません。各エンドユーザのシステムはカスタマイズされ、NIのテスト用プラットフォームとは異なる
ため、そしてユーザまたはアプリケーション設計者が、NIの評価したことのない、または予期していない方法で、NI製品を他
の製品と組み合わせて使用する可能性があるため、NI製品をシステムまたはアプリケーションに統合する場合は、ユーザまた
はアプリケーション設計者が、NI製品の適合性を検証、確認する責任を負うものとします。これには、このようなシステムま
たはアプリケーションの適切な設計、プロセス、安全レベルが含まれますが、これに限定されません。
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このマニュアルについて

LabVIEW SignalExpress の対話式計測、および信号の集録と解析に使用

する LabVIEW SignalExpress 基本機能の習得について説明します。

本書には、LabVIEW SignalExpress で作業を開始する際に役立つ演習問

題などが含まれています。 これらの演習では、プロジェクトの実行方法、

ステップの構成方法、信号の操作方法、スイープ計測の構成方法、データ

のログ方法、LabVIEW のグラフィカルプログラミングを使用した

LabVIEW SignalExpress の拡張方法について説明します。

表記規則

このマニュアルでは、以下の表記規則を使用しています：

→ 矢印 ( → ) は、ネストされたメニュー項目やダイアログボックスのオプ

ションをたどっていくと目的の操作項目を選択できることを示します。 た
とえば、ファイル→ページ設定→オプションという順になっている場合

は、まずファイルメニューをプルダウンし、次にページ設定項目を選択し

て、最後のダイアログボックスからオプションを選択します。

このアイコンは、注意すべき重要な情報を示します。

太字 太字のテキストは、メニュー項目やダイアログボックスなど、ソフトウェ

アでユーザが選択またはクリックする必要のある項目を示します。 また、

入出力名、パラメータ名、ダイアログボックスまたはその一部、メニュー

名も示します。

斜体 斜体のテキストは、変数、強調、相互参照、または重要な概念の説明を示

します。 また、ユーザが入力する必要がある語または値のプレースホルダ

も示します。

monospace このフォントのテキストは、キーボードから入力する必要があるテキスト

や文字を示します。 また、ディスクドライブ、パス、ディレクトリ、プロ

グラム、サブプログラム、サブルーチンなどの名称、デバイス名、関数、

操作、変数、ファイル名および拡張子の引用にも使用されます。

関連ドキュメント

詳細は、Help → LabVIEW SignalExpress ヘルプを選択し、『LabVIEW 
SignalExpress ヘルプ』を参照してください。
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1
LabVIEW SignalExpress
の概要

ナショナルインスツルメンツでは、業界標準のコンピュータとプラット

フォームを使用した自動計測システムを構築するための革新的なソリュー

ションを科学者やエンジニアのために提供しています。 当社では、グラ

フィカルプログラミングが可能な LabVIEW、ANSI C プログラミング対

応の LabWindowsTM/CVITM、Microsoft Visual Studio プログラミング対

応の Measurement Studio など、堅固で業界最先端の自動計測システム

用プログラミング環境を開発しています。 これらのプログラミングツール

を弊社の計測ハードウェアや従来の計測器へのインタフェースとともに使

用すれば、カスタム仕様の高機能な仮想計測システムを構築することが可

能です。

LabVIEW SignalExpress は、プログラミングが不要な対話式計測環境を

提供します。 LabVIEW SignalExpress では、信号の集録、生成、解析、

比較、インポート、ログを対話式に行うことができます。 また、設計デー

タと測定データの比較を 1 つのステップで行えます。 LabVIEW 
SignalExpress を使用すれば、信号の集録や解析が必要な際にプログラミ

ングアプリケーションなしで、仮想計測器の使いやすさと性能を活用でき

ます。 また、LabVIEW 開発システムで作成したカスタム仮想計測器（VI）
のインポートや、 LabVIEW SignalExpress プロジェクトを LabVIEW ブ

ロックダイアグラムに変換することにより、LabVIEW で開発を継続で

き、LabVIEW SignalExpress の機能拡張が可能です。 詳細は第 7 章

「LabVIEW で LabVIEW SignalExpress プロジェクトを拡張する」を参

照してください。
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2
LabVIEW SignalExpress
をインストールする

LabVIEW SignalExpress CD で、LabVIEW SignalExpress をインストー

ルして本書の演習を行うことができます。

LabVIEW SignalExpress LE
LabVIEW SignalExpress LE は、LabVIEW SignalExpress フルバージョ

ンを 30 日間お試しいただけるようになっています。 この期間後は、ご使

用いただいているバージョンの LabVIEW SignalExpress LE をアクティ

ブ化するか、フルバージョンを購入していただくことになります。 
フルバージョンの 30 日間お試し期間が満了する前に LabVIEW 
SignalExpress LE をアクティブ化する場合も、フル機能は 30 日間のお試

し期間の残りとして有効です。 LabVIEW SignalExpress LE は簡単なデー

タ集録とロギング関数を使用できます。

30 日間を経過しても LabVIEW SignalExpress LE バージョンを登録しな

いと、LabVIEW SignalExpress LE に以下の制限が付きます。

• プロジェクトを保存できなくなるため、プロジェクトを LabVIEW の

ブロックダイアグラムに変換できません。

• プロジェクトはセッション毎に 10 分のみ実行できます。

フルバージョンの LabVIEW SignalExpress を購入するには、ナショナル

インスツルメンツのウェブサイト ni.com/jp/signalexpressを参照

してください。

最小システム要件

LabVIEW SignalExpress は、最小で 256 MB の RAM、および

Pentium III 以上、Celeron 866 MHz、または同等のプロセッサを必要と

しますが、ナショナルインスツルメンツでは 512 MB の RAM、および

Pentium 4/M、または同等のプロセッサを推奨します。

http://www.ni.com/signalexpress
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LabVIEW SignalExpress をインストールする

LabVIEW SignalExpress を Windows Vista/XP/2000/NT にインストー

ルするには、以下の手順に従ってください。

メモ LabVIEW SignalExpress プロジェクトを LabVIEW のブロックダイアグラムに

変換する場合、LabVIEW SignalExpress をインストールする前に LabVIEW 7.1
以降をインストールする必要があります。

1. インストールを始める前に自動ウイルス検出プログラムを無効にして

ください。 一部のウィルス検出プログラムは、インストーラの実行を

妨げる場合があります。

2. 管理者または管理者権限のあるユーザとしてログオンします。

3. LabVIEW SignalExpress 開発版または評価版の CD を挿入し、画面

上の指示に従います。

デフォルトで、LabVIEW SignalExpress は Program Files¥

National Instruments¥SignalExpressディレクトリにインス

トールされます。

4. インストール後、一時的に無効にしたウィルス検出プログラムを有効

にし、ハードディスクにウィルスがないことを確認します。

本書で使用するサンプルプロジェクトは、SignalExpress¥Examples¥
Tutorialにあります。 各演習問題の回答は、SignalExpress¥
Examples¥Tutorial¥Solutionsにあります。

LabVIEW SignalExpress をナショナルインスツルメンツのデータ集録ま

たはモジュール式計測のハードウェアで使用する場合、NI-DAQmx 8.5
以降、NI-SCOPE 2.7 以降、NI-FGEN 2.2、または NI-DMM 2.4.2. 以降を

インストールする必要があります。LabVIEW SignalExpress には、これ

らのドライバを含む、ナショナルインスツルメンツのドライバ CD が用

意されています。



© National Instruments Corporation 3-1 LabVIEW SignalExpress スタートアップガイド

3
プロジェクトの操作

LabVIEW SignalExpress では、対話式計測環境でステップの追加や構成

を行い、測定処理を定義することができます。 ステップとは、信号の集録

や生成、解析、ロード、保存を行う機能のことで、それぞれ構成すること

が可能です。 多くの場合、ステップにより入力信号が処理され、出力信号

が生成されます。 構成ビューで値を指定すると、ステップの操作を構成で

きます。 構成されたステップのシーケンスを保存したものが LabVIEW 
SignalExpress プロジェクトです。

本章では、既存のプロジェクトのロードや実行を行う方法、プロジェクト

のステップを構成する方法について説明します。

プロジェクトを開く

LabVIEW SignalExpress でサンプルプロジェクトをロードするには、以

下の手順に従ってください。

1. LabVIEW SignalExpress を起動します。

LabVIEW SignalExpress は大きく 3 つの表示（左側のプロジェクト

ビュー、中央のデータビュー、右側のヘルプ）に分かれていることに

注目してください。 データビューには、データビュータブ、ロギング

オプションタブ、プロジェクトドキュメントタブがあります。

2. 出荷時のデフォルト設定で LabVIEW SignalExpress 開かない場合、

表示→データビューを選択してデータビューを表示します。

3. ファイル→プロジェクトを開くを選択し、SignalExpress¥
Examples¥Tutorialディレクトリを参照して、LabVIEW 
SignalExpress プロジェクトの First Project.seprojをダブルク

リックします。 



第 3 章 プロジェクトの操作

LabVIEW SignalExpress スタートアップガイド 3-2 ni.com/jp

4. ヘルプが非表示の状態で図 3-1 のようなウィンドウが表示されたら、

LabVIEW SignalExpress の様々なコンポーネントを確認してくださ

い。

図 3-1 First Project.seproj

左側のペーンがプロジェクトビューで、プロジェクトの操作手順やス

テップを表示します。 右のペーンがデータビューで、プロジェクトが

生成および解析した信号がここに表示されます。

プロジェクトの実行と信号の表示

LabVIEW SignalExpress には、2 つの実行モード（実行および 1 回実行）

があります。 実行ボタンをクリックすると、停止ボタンをクリックするま

で、プロジェクトのステップがすべて連続して実行されます。 プロジェク

トの実行中は、実行ボタンは押せなくなり、停止ボタンは押せるように表

1 実行制御ボタン

2 作業エリアプルダウンメニュー

3 ステップ

4 入力

5 出力

6 プロジェクトビュー

7 ログデータウィンドウ

8 データビュー

9 記録ボタン

5

8

1

3

4

2

9

56

7
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示されます。 プロジェクトのステップを実行している間にも、データ

ビューは更新され続けます。 プロジェクトの実行中に測定の構成を変更し

たり、測定結果を即座に表示したりすることができます。 プロジェクトの

実行中にステップの構成を変更すると、この変更は LabVIEW 
SignalExpress に直ちに適用されます。 1 回実行ボタンをクリックすると、

プロジェクトのすべてのステップが１回実行されます。

サンプルプロジェクトを実行して信号を表示するには、以下の手順に従っ

てください。

1. 左に示す実行ボタンをクリックし、プロジェクトのすべてのステップ

を連続的に実行します。

プロジェクトはテキストファイルから信号をロードし、信号上で 2
つの操作（振幅とレベル計測およびひずみ計測）を実行します。 「振

幅とレベル」ステップおよび「ひずみ」ステップは、これらの測定を

個別に実行します。 プロジェクトを実行する場合、ステップは入力信

号を解析し、解析結果として新規の出力信号を生成します。 このプロ

ジェクトでは、「ASCII からロード」ステップが歪み正弦波をロード

し、「振幅とレベル」ステップと「ひずみ」ステップはこの正弦波を

解析した後、両方のステップ共、新規出力を返します。 プロジェクト

ビューでは、入力は赤い矢印が付いた状態、出力は青い矢印が付いた

状態で示されます。

データビューのグラフには、時間領域信号であるロードされた信号が

引き続き含まれています。 グラフには、時間領域、周波数領域、また

は x-y 信号が表示されます。 

2. プロジェクトビューで「ひずみ」ステップのエクスポートスペクトル

出力信号をクリックしてデータビューにドラッグし、その信号を表示

します。 
データビューに新規のグラフが作成されます。 エクスポートスペクト

ル信号が周波数領域信号のため、時間領域信号のように同じグラフに

エクスポートスペクトル信号は表示されません。 LabVIEW 
SignalExpress では自動的に異なる信号タイプを認識し、適切な表示

でその信号をレンダリングします。

3. 信号タイプの詳細については、ヘルプ→ LabVIEW SignalExpress ヘ

ルプを選択して検索タブをクリックし、「信号タイプ」と入力して

『LabVIEW SignalExpress ヘルプ』を参照してください。 このヘルプ

は、プロジェクト、ステップ、信号など、LabVIEW SignalExpress
の機能の詳細を記載しています。

4. 「振幅とレベル」ステップの DC 出力をクリックしてデータビューに

ドラッグし、その測定を表示します。 

DC 出力からスカラ計測を表示する表が作成されます。
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5. rms 出力を表へドラッグし、スカラ RMS 計測を表示します。

表で新規行が作成され、2 番目の測定が表示されます。 図 3-2 のよう

なプロジェクトが表示されます。

図 3-2 First Project.seproj の出力

ステップを構成する

ステップとは、信号の集録や生成、解析、ロード、保存を行う機能のこと

で、それぞれ構成することが可能です。 ステップにより、入力信号が処理

され、出力信号が生成されます。 ステップの操作は、そのステップのス

テップ設定ダイアログボックスまたは構成ビューで値を指定することで構

成できます。 プロジェクトの実行中でも、ステップの構成を変更して変更

が適用された結果を表示したり、必要な測定結果が得られるまで測定を調

整することができます。
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「ひずみ」ステップおよび「振幅とレベル」ステップを構成するには、以

下の手順に従ってください。

1. プロジェクトビューの「ひずみ」ステップをダブルクリックします。 
図 3-3 のような「ひずみ」ステップのステップ設定ダイアログボック

スが表示されます。

図 3-3 「ひずみ」ステップのステップ設定ダイアログボックス

構成 タブ上のこの設定では、「ひずみ」ステップは時間軸の信号を入

力として受け取り、信号に対してパワースペクトルを計算して周波数

領域に変換し、この信号の全高調波ひずみ (THD) と基本周波数を計

算します。 このステップは出力として 3 つの計測（スペクトル、

THD、元の時間領域の波形入力の基本周波数）を生成します。

2. 詳細ヘルプが画面右側に表示されない場合は、左に示すヘルプの表示

ボタンをクリックし、ステップに関する参照情報を表示します。 詳細

ヘルプの上方にはステップについての情報、そして下方には項目につ

いて（項目の上にカーソルを移動させることで表示）の情報が表示さ

れます。
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3. 構成タブ上で、エクスポート信号 (THD) プルダウンメニューから基

本トーンを選択します。

入力信号の全周波数領域スペクトルが表示されていたステップに、入

力信号の基本トーンの周波数スペクトルのみが表示されます。 ステッ

プ設定ダイアログボックスの上半分に表示されている信号は、変更に

基づいて更新されます。

4. エクスポート信号 (THD) プルダウンメニューから高調波のみを選択

します。

このステップは、入力信号から高調波信号のスペクトルのみがエクス

ポートされるよう変更されます。 「ひずみ」ステップの出力信号と

データビューのグラフは両方とも、変更に基づいて更新されます。

5. プロジェクトビューの「振幅とレベル」ステップをクリックします。 
「ひずみ」ステップの構成が表示されていたステップ設定ダイアログ

ボックスに、「振幅とレベル」ステップの構成が表示されます。

6. 入力 / 出力タブをクリックし、図 3-4 で表すようにこのステップで選

択できる入出力リストを表示します。

図 3-4 「振幅とレベル」ステップのステップ設定ダイアログボックス

7. +peak 値をエクスポート、–peak 値をエクスポート、peak-peak
値をエクスポートの各チェックボックスを有効にして「振幅とレベ

ル」ステップを構成し、追加した 3 つの計測を返します。

追加された 3 つの出力は、プロジェクトビューに表示されます。

8. データビュータブをクリックし、データビューを表示します。
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9. プロジェクトビューから 3 つの新規出力を表へドラッグし、スカラ

計測を表示します。

10. 左に示す停止ボタンをクリックし、プロジェクトを停止します。

停止ボタンをクリックすると、現在の一連のステップ操作または反復

が完了した後でプロジェクトの実行は停止されます。 停止ボタンの下

矢印をクリックし、中断ボタンをクリックすると、プロジェクトは完

全に緊急停止し、残りのステップは実行されません。

11. ファイル→プロジェクトを別名で保存を選択し、プロジェクトを My 
First Project.seprojという名前で SignalExpress¥Examples¥

Tutorialディレクトリに保存します。

12. ファイル→プロジェクトを閉じるを選択し、プロジェクトを閉じます。

ステップを移動、削除する

LabVIEW SignalExpress のプロジェクトのステップは、入力データに

よって異なります。つまり、各ステップで操作できるのは、プロジェクト

ビューにある以前のステップからエクスポートされた信号上のデータのみ

です。 ステップのステップ設定ダイアログボックスの入力タブで、入力信

号プルダウンメニューをクリックすると、以前のステップからエクスポー

トされた互換性のある信号のみがメニューに表示されます。 ステップの出

力が別のステップの入力になると、その 2 つのステップは互いに依存する

ようになり、順次実行されます。 最初のステップによって生成された出力

信号は、2 つ目のステップの入力として受信され、実行が開始されます。

プロジェクトビューでステップを上下にドラッグすることで、プロジェク

ト内でステップを移動できます。 また、プロジェクトビューでステップを

右クリックし、ショートカットメニューから削除を選択すると、ステップ

を削除できます。 ただし、ステップの移動や削除を行った場合には、プロ

ジェクトの信号のステータスが変更されます。 たとえば、出力信号を生成

するステップを削除した場合に、削除された出力信号のいずれかが他のス

テップの入力になっているとプロジェクトの動作は中断され、プロジェク

トビューにエラーインディケータが表示されます。 また、プロジェクト内

でステップの切り取り、コピー、貼り付けを行うには、<Ctrl-X>、
<Ctrl-C>、<Ctrl-V> のそれぞれのキーを押すか、プロジェクトビューのス

テップを右クリックしてショートカットメニューから切り取り、コピー、

選択したステップの前に貼り付け、または選択したステップの後に貼り付

けを選択します。
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エラーと警告を処理する

プロジェクトの実行中にエラーが発生した場合には、左に示すエラーイン

ディケータが、エラーが発生したステップのプロジェクトビューに表示さ

れます。 エラーが発生したステップをダブルクリックし、エラーの説明を

ステップ設定ダイアログボックスの下全体に表示します。 エラーの説明の

右にある詳細ボタンをクリックすると、エラーの全説明が表示されます。

エラーおよび警告はすべて、プロジェクトの実行中にイベントログに記録

されます。 イベントログを表示するには、表示→イベントログを選択し、

データビューのイベントログタブをクリックします。 エラーと警告の詳細

は、『LabVIEW SignalExpress ヘルプ』を参照してください。このヘル

プは、ヘルプ→ LabVIEW SignalExpress ヘルプを選択して検索タブをク

リックし、「エラー」と入力すると表示されます。
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4
信号を操作する

LabVIEW SignalExpress では、信号の生成および解析を行い、プログラ

ミングを行わずに設計を評価することができます。 本章では、信号をグラ

フにプロットする方法、信号をファイルからインポートする方法、2 つの

信号を対話式に整列して比較する方法、信号をファイルに保存する方法と

いった LabVIEW SignalExpress における信号の操作方法について説明し

ます。

信号をグラフ化する

サンプルプロジェクトの信号をプロットし、カーソルを使用して視覚的に

検証するには、以下の手順に従ってください。

1. ファイル→プロジェクトを開くを選択し、SignalExpress¥

Examples¥Tutorialディレクトリを参照して、Signals.seproj

をダブルクリックします。 このプロジェクトでは、方形波を生成する

「アナログ信号を作成」ステップと、ローパスバタワースフィルタを

実行する「フィルタ」ステップを構成します。

2. 「アナログ信号を作成」ステップのステップ信号出力をデータビュー

にドラッグします。

3. 「フィルタ」ステップのフィルタ処理済みのステップ出力をデータ

ビューにドラッグします。

信号タイプが同じ信号は、同一のグラフにプロットすることができま

す。 ステップ信号とフィルタ処理済みのステップ信号は、両方とも時

間領域信号であるため、同じグラフに表示されます。 異なるタイプの

信号をプロットする場合には、信号を同じグラフにドラッグすると、

新しいグラフが作成されます。

4. 左に示すツールバーのビューを追加ボタンをクリックし、新しいグラ

フを作成します。

5. 「フィルタ」ステップのフィルタ処理済みのステップ出力を新しいグ

ラフにドラッグします。
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6. 新しいグラフを右クリックし、ショートカットメニューから

表示項目→カーソルを選択して、図 4-1 に示す 2 つの対話式カーソル

を表示します。

図 4-1 Signals.seproj

カーソルをドラッグするたびに、カーソルの x 値と y 値が更新され、

データビューの下方にあるカーソルの表に表示されます。

7. ファイル→プロジェクトを別名で保存を選択し、プロジェクトを

My Signals.seprojという名前で SignalExpress¥Examples¥
Tutorialディレクトリに保存します。
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信号をファイルからインポートする

信号は、ASCII、コンマ区切りもしくはタブ区切りのファイル、

LabVIEW 計測データファイル（.lvm）などの標準的なファイル形式から

インポートできます。 また、SPICE シミュレータなどの EDA ツールのシ

ミュレーション結果からも信号をインポートすることができます。

信号をファイルからインポートするには、以下の手順に従ってください。

1. プロジェクトビューを右クリックし、ショートカットメニューから信

号をロード / 保存→アナログ信号→ ASCII からロードを選択します。

2. 左に示すステップ設定ダイアログボックスの参照ボタンをクリック

し、SignalExpress¥Examples¥Tutorialディレクトリを参照し

て、Step Response.txtをダブルクリックします。 このステップに

より、ASCII 形式のファイルが読み込まれ、データが表示されます。

ファイルプレビューセクションの列 1 はタイムスタンプデータ、

列 2 は信号の実際の電圧値を示します。

3. 信号のインポートタブをクリックし、ファイルにある使用可能な信号

を表示します。

4. 列 2 チェックボックスを有効にして信号をインポートし、列 1
チェックボックスを無効にします。

ステップ設定ダイアログボックスのインポートされた信号セクション

に信号のプレビューが表示されます。

5. X 入力値プルダウンメニューから列 1 を選択し、波形の x 軸データ

を適切な値に設定します。

6. データビューを開きます。

7. プロジェクトビューの列 2 出力を右クリックし、ショートカットメ

ニューから名前を変更を選択します。

8. step responseと入力し、<Enter> キーを押して出力名を変更しま

す。
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9. 「ASCII からロード」ステップのステップ応答出力をデータビューの

下のグラフにドラッグします。

図 4-2 のように、フィルタ処理済みのステップ信号は、ステップ応答

出力の立ち上がりエッジと類似しています。

図 4-2 Signals.seproj の信号

10. ファイル→プロジェクトを保存を選択してプロジェクトを保存します。

信号を整列および比較する

フィルタ処理済みのステップ信号とステップ応答出力の両方に、立ち上が

りエッジでオーバーシュートが見られますが、信号ソースが異なることや

振幅やタイミングに違いがあるため、この 2 つの信号は類似点を判定し

にくいという状況にあります。 ただし、「対話式アライメント」ステップ

を使用すれば 2 つの信号を整列して比較できるため、プロジェクト内で

使用する操作からエクスポートする情報を選択できます。
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My Signals.seprojプロジェクトの 2 つの信号を整列するには、以下の

手順に従ってください。

1. 「ASCII からロード」ステップからステップ応答信号を「対話式アラ

イメント」ステップに渡すには、ステップ応答出力を右クリックし、

ショートカットメニューから送信先→処理→アナログ信号→対話式ア

ライメントを選択します。

図 4-3 のように、プロジェクトで最後に使用された 2 つの信号が入

力として選択され、ステップ設定ダイアログボックスのグラフにそれ

らの信号が表示されます。

図 4-3 「対話式アライメント」ステップのステップ設定ダイアログボックス

ステップをプロジェクトに追加すると、ステップが受け入れることの

可能な信号タイプに基いて入力信号が選択されます。 例えば、「対話

式アライメント」ステップでは、時間領域の波形信号のみを処理でき

ます。 したがって、プロジェクトで作成された信号のうち最後の 2 つ

の時間領域信号が入力として選択されます。 ステップの入力信号を変

更するには、ステップ設定 ダイアログボックスの入力 / 出力タブに

ある対応信号のプルダウンメニューから、別の信号を選択します。

2. 入力信号グラフで赤い信号をクリックし、そのグラフ内の他のポイン

トへドラッグします。

グラフ上の信号は、ドラッグ、拡張、縮小を行うことができます。
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3. グラフ内で信号をドラッグすることで、2 つの信号の立ち上がりエッ

ジを整列してみます。 信号をクリックしてアンカーポイントを設定

し、<Alt> キーを押したまま信号をクリックして、x 軸と y 軸の方向

でアンカーポイントの周りにドラッグします。

ステップ設定ダイアログボックスの整列タブ上では、信号をドラッグ

するたびに、ステップによりアライメント仕様を満たすのに必要な

ｘ軸と ｙ軸のゲインとオフセットの値が計算され、表示されます。

4. モードプルダウンメニューから自動ステップを選択し、信号を整列し

ます。 このアライメントモードは、標準アルゴリズムに基づいていま

す。

ステップ設定ダイアログボックスの下のグラフには、2 つの信号にお

ける相違が表示されます。

5. 入力 / 出力タブの整列した信号をエクスポートチェックボックスを有

効にし、信号をステップの出力に追加します。

6. データビュータブを選択し、データビューを開きます。

7. 左に示すビューを追加ボタンをクリックし、3 つ目のグラフを追加し

ます。

8. 「対話式アライメント」ステップの整列された基準出力と整列された

テスト出力を新しいグラフにドラッグし、整列された信号を表示しま

す。

9. ファイル→プロジェクトを保存を選択してプロジェクトを保存しま

す。

LabVIEW SignalExpress の信号タイプ

ステップの中には、「演算」ステップなど、複数の信号タイプを処理でき

るステップがあります。 たとえば、「演算」ステップでは、時間領域また

は周波数領域の波形を処理することができます。 この「演算」ステップで

は、そのステップで選択した入力信号のタイプによって動作が異なりま

す。 たとえば、2 つの時間領域信号を追加すると、その振幅のみが追加さ

れます。 これに対し、2 つの周波数領域位相信号を追加すると、適切な位

相シフトが追加されます。

詳細は、『LabVIEW SignalExpress ヘルプ 』を参照してください。この

ヘルプは、ヘルプ→ LabVIEW SignalExpress ヘルプを選択して検索タブ

をクリックし、「信号タイプ」と入力すると表示されます。
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信号をエクスポートおよび印刷する

LabVIEW SignalExpress で信号をドキュメント化したり、別のソフト

ウェアアプリケーションで解析を継続したりできます。 このセクションで

は、信号の ASCII ファイルへの送信、データの Microsoft Excel への送

信、信号の印刷、標準のドキュメント機能を使用した LabVIEW 
SignalExpress プロジェクトのドキュメント化を含む、信号のエクスポー

ト方法について説明します。

信号をファイルに保存する
信号をファイルへ保存するには、以下の手順に従ってください。

1. ステップを追加ボタンをクリックし、信号をロード / 保存→アナログ

信号→ ASCII/LVM に保存を選択します。

2. ステップ設定ダイアログボックスの信号タブをクリックし、入力デー

タプルダウンメニューからフィルタ処理済みのステップを選択します。

3. ファイル設定タブで、ファイルパスをエクスポートでファイルを

SignalExpress¥Examples¥Tutorial¥filtered signal.txt に

保存します。

4. ファイルが既存の場合プルダウンメニューから上書きを選択します。

5. ファイルタイプをエクスポートプルダウンメニューから汎用 ASCII
を選択します。

プロジェクトが実行されるたびに、「信号をロード / 保存」ステップ

を使用し、データをファイルへ保存します。

6. 実行ボタンをクリックして、プロジェクトを実行し、その結果得られ

た信号を指定した ASCII ファイルへ保存します。

7. ファイル→プロジェクトを保存を選択してプロジェクトを保存しま

す。

8. ファイル→プロジェクトを閉じるを選択し、プロジェクトを閉じま

す。

Microsoft Excel へ信号をエクスポートする
Microsoft Excel へ信号データをエクスポートするには、Excel を起動し、

LabVIEW SignalExpress にあるステップの出力信号を Excel のスプレッ

ドシートへドラッグします。

信号を印刷する
グラフの画像を印刷するには、データビューを開き、ファイル→印刷→

データビューを印刷を選択します。
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LabVIEW SignalExpress でレポートを作成する
表示→プロジェクトドキュメントを選択し、プロジェクトドキュメント

ビューを表示します。 テキストを使用してプロジェクトを説明し、ステッ

プ出力をドキュメントにドラッグアンドドロップできます。 ステップ出力

をプロジェクトドキュメントビューにドラッグアンドドロップすると、ス

テップ出力の現在値に一致するようにプロジェクトドキュメントビューで

値が自動的に更新されます。 

ドキュメントを印刷するには、プロジェクトドキュメントビューを開き、

ファイル→印刷→ドキュメントを印刷を選択します。 ドキュメントを

HTML へエクスポートするには、プロジェクトドキュメントビューを開

き、ファイル→エクスポート→ドキュメントを HTML にエクスポートを

選択します。
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5
データをロギングする

LabVIEW SignalExpress は、測定の記録と解析を行います。 任意の時間

領域、倍精度、U32、ブールのステップ出力を記録できます。 また、解析

ステップを介してログデータを検証し、ログデータの解析と処理を行うこ

ともできます。 

本章では、LabVIEW SignalExpress で統合データロギング機能を使用し

たデータの記録方法について説明します。 指定した信号の記録方法、信号

の再生方法、解析のステップを使用した信号の解析方法について習得しま

す。 また、指定した開始条件または停止条件に基づいて信号をログする記

録オプションビューの使用方法についても習得します。 

信号を記録する

記録ボタンでデータロギング処理を構成できます。 

記録する信号を指定し、その信号を記録するには、以下の手順に従ってく

ださい。

1. ファイル→プロジェクトを開くを選択し、SignalExpress¥

Examples¥Tutorialディレクトリを参照して、Logging.seproj

をダブルクリックします。

このプロジェクトでは、「アナログ信号を作成」ステップを使用し、

フォーミュラに基づいて信号を生成します。

2. 左に示す記録ボタンをクリックし、信号選択をログダイアログボック

スを開きます。

信号選択をログダイアログボックスは、有効なプロジェクトで記録す

る信号を表示します。 記録には 1 つまたは複数の信号を選択できま

す。 また、ログの名前と説明を指定することもできます。

3. アナログ信号を作成ステップで生成されるフォーミュラの信号を記録

するには、信号チェックボックスにチェックマークを付けます。

4. OK ボタンをクリックし、信号選択をログダイアログボックスを閉じ

て、信号の記録を開始します。 これで、停止ボタンがクリックされる

まで、ログ操作が継続されます。
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5. 左に示す停止ボタンをクリックし、信号のログを停止します。 
図 5-1 のように、ログデータはログデータウィンドウに表示されま

す。

図 5-1 ログデータウィンドウ

デフォルトでは、データを記録した日付と時間に従ってログデータに

名前を付けます。 LabVIEW SignalExpress では、ログデータは

.tdmsファイル形式で、オプションダイアログボックスで指定した

ディレクトリに保存されます。 

6. LabVIEW SignalExpress のディレクトリを指定してログデータを保

存し、ログデータのさまざまな設定をカスタマイズするには、

ツール→オプションでロギングオプションを選択します。

7. OK ボタンをクリックし、オプションダイアログボックスを閉じま

す。

8. ファイル→プロジェクトを保存を選択してプロジェクトを保存しま

す。

ログされた信号を表示する

ログデータを表示するには、以下の手順に従ってください。

1. データビューが非表示の場合、表示→データビューを選択するとデー

タビューが表示されます。 

2. ログデータウィンドウは、現在のプロジェクトのすべてのログデータ

を一覧表示します。 ログデータウィンドウで記録したデータログを選

択し、それをデータビューへドラッグします。 図 5-2 のように、デー

タビューでログデータとグラフプレビューが表示されます。データ

ビューに表示される信号は、信号を記録する時間により異なるため、

図 5-2 に表示される信号と異なることがあります。
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図 5-2 Logging.seproj

グラフプレビューは、データビューでデータのズームおよびパニング

の方法を提供します。 デフォルトで、グラフプレビューはログデータ

を表示すると表示されます。 ライブデータまたはログされていない

データを表示する場合にグラフプレビューを表示するには、データ

ビューを右クリックして表示項目→プレビューを選択します。

3. グラフプレビューの隣にあるズームインボタンをクリックし、ログさ

れた信号でズームイン操作を行います。 グラフプレビューのカーソル

は、グラフプレビューに現在表示されているデータのサブセットを示

します。 グラフプレビューの下にあるスクロールバーで、データをス

クロールします。 表示しているデータのサブセットの増減を行うに

は、グラフプレビューでカーソルをクリックしてドラッグします。
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事前に定義した開始および停止条件で信号をログする

LabVIEW SignalExpress で信号の記録や記録停止を行う前に、開始およ

び停止条件に一致するように信号を構成できます。 開始および停止条件に

基づいてデータをログするには、以下の手順に従ってください。

1. 記録オプションタブが非表示の場合、表示→記録オプションを選択す

ると、記録オプションビューが開きます。

2. 記録オプションビューのカテゴリリストで信号選択を選択します。

3. 図 Figure 5-3 のように、記録列で正弦波の隣りにチェックマークを

付けます。

図 5-3 信号選択

記録ボタンは、左に示す実行中に記録ボタンに変わります。 実行中に

記録ボタンが押されたことを確認してください。 実行中に記録ボタン

が押されると、実行または 1 回実行ボタンを押した場合に、選択し

た信号が記録されます。

4. 記録オプションビューのカテゴリリストで開始条件を選択します。 

5. ロギングタスクの開始条件をカスタマイズするには、ロギング開始条

件ページで 追加ボタンをクリックします。

a. 入力信号が指定した条件に一致すると記録を開始するように

LabVIEW SignalExpress を指定するには、条件ソース制御器で

信号オプションを選択します。
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b. 信号制御器で信号を選択します。

c. 条件制御器で立ち上がりスロープを選択し、正のスロープで信号

のエッジの値に基づいて信号の記録を開始します。

d. 値制御器で 1を入力すると、立ち上がりスロープで信号が 1 を

クロスすると記録が開始されます。

6. 記録オプションビューのカテゴリリストで停止条件を選択します。

7. ロギングタスクの停止条件をカスタマイズするには、ロギング停止条

件ページで 追加ボタンをクリックします。

a. 条件ソース制御器で持続時間オプションを選択します。

b. 信号が開始条件に一致してから 5 秒間信号を記録するには、持

続時間制御器で 5と入力します。

c. 左に示す実行ボタンをクリックします。 立ち上がりスロープで信

号がレベル 1 をクロスすると、信号の記録が開始され、この記

録が 5 秒間継続されます。 
記録オプションビューの下部にある記録表示器は、信号が開始条

件に一致してログが処理されている場合に、ON になります。 
ディスク情報表示器はログを行うコンピュータの有効なハード

ディスクスペースを表示します。

ログされた信号を解析する

信号をログした後、ライブデータと同様に、ログデータの再生や、解析の

ステップでログされた信号を実行できます。 ログされた信号を解析するに

は、以下の手順に従って下さい。

1. 図 5-4 のように、LabVIEW SignalExpress ウィンドウの左上にある

作業エリアプルダウンメニューを参照します。再生作業エリアに切り

替えるには、下矢印をクリックして再生を選択します。

図 5-4 作業エリアプルダウンメニュー

同じプロジェクトで複数の LabVIEW SignalExpress 操作を実行する

場合に作業エリアを使用します。 新規プロジェクトを開かずに、デー

タ集録、信号処理、データの記録、ログデータでの測定実行が可能で

す。 プロジェクトを保存する場合、同じプロジェクトファイルにある

該当プロジェクト内で各作業エリアが保存されます。

デフォルトの作業エリア（監視 / 記録）で、測定の実行、ライブデー

タの解析、データのログを行うことができます。 ログデータを解析ス

テップの入力として使用するには、再生作業エリア内でなければなり

ません。 たとえば、監視 / 記録作業エリアで測定を実施して信号をロ
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グし、再生作業エリアで解析ステップを介してログデータを実行でき

ます。

2. 左に示すステップを追加ボタンをクリックし、処理→アナログ信号→

フィルタから「フィルタ」ステップを選択します。 自動的に、ログさ

れた最初の信号が「フィルタ」ステップの入力として選択されます。

3. データビューを参照します。 結果として得られた信号を表示するに

は、「フィルタ」ステップのフィルタ処理済みのデータ出力をデータ

ビューにドラッグします。

4. 左に示す実行ボタンをクリックします。 データビューは結果として得

られたフィルタ処理済みの信号を表示し、ログ全体を再生します。

上級再生

再生オプションビューで、上級データ再生オプションを構成できます。 再
生オプションビューはログデータのプレビューを表示し、再生や解析ス

テップを介して実行するデータのサブセットを選択できます。

1. 図 5-5 のように、再生オプションビューを開くには、表示→再生オプ

ションを選択します。再生オプションビューで、ログデータのプレ

ビュー、および再生や解析ステップへ送信を行うログデータのサブ

セットを指定できます。 

図 5-5 再生オプションビュー
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2. ログされた信号リストボックスで作成した 2 番目のログから信号を

選択します。

3. 開始時間制御器で 1と入力すると、ログ開始後、1 秒の経過が始まる

ポイントでログされた信号のサブセットの再生や解析を行います。 

4. 停止時間制御器で 4と入力すると、ログ開始後、4 秒の経過が終わる

ポイントでログされた信号のサブセットの再生や解析を行います。

5. データビューに切り替え、「フィルタ」ステップのフィルタ処理済み

のデータ出力をデータビューにドラッグします。

6. 左に示す実行ボタンをクリックします。 再生オプションで指定した信

号のサブセットをフィルタ処理し、データビューに結果として得られ

たフィルタ処理済み信号を表示します。

7. 停止ボタンをクリックしてプロジェクトの実行を停止します。

アラーム条件や再生オプションの指定など、ロギングデータの詳細につい

ては、『LabVIEW SignalExpress ヘルプ』を参照してください。
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スイープ計測を行う

LabVIEW SignalExpress では、スイープ操作により測定を自動化し、特

性評価や設計検証を行うことができます。 広範な条件でスイープ計測を使

用して設計からデータを収集し、その設計性能をドキュメント化すること

ができます。 たとえば、特性評価のための測定を実行中に、スイープ操作

を使用して刺激信号の周波数や電源の電圧レベルを変化させることができ

ます。

本章では、LabVIEW SignalExpress で「スイープ」ステップを使用した

スイープ操作の設定方法について説明します。 周波数スイープを行い、

フィルタ出力の測定を行うことで、フィルタの性能を評価 する方法と、 ス
イープ結果の表示方法と、より複雑な測定のための多次元掃引（スイー

プ）の実行方法についても説明します。

スイープの範囲と出力を定義する

「スイープ」ステップでは、複雑で反復的なスイープ操作でも、これを定

義することにより測定を自動的に行うことができます。

サンプルプロジェクトで周波数範囲を定義し、フィルタを介してスイープ

操作を行うには、以下の手順に従ってください。

1. ファイル→プロジェクトを開くを選択し、SignalExpress¥
Examples¥Tutorialディレクトリを参照して、Sweep.seprojを

ダブルクリックします。

2. 左に示す実行ボタンをクリックし、プロジェクトを実行します。

このプロジェクトでは、「アナログ信号を作成」ステップにより正弦

波の刺激信号が生成されます。この信号は、「フィルタ」ステップに

より楕円バンドパスフィルタを介して渡され、「振幅とレベル」ス

テップによりフィルタ出力の RMS が測定され、「フォーミュラ」ス

テップによりデシベル (dB) に変換されます。 「フィルタ」ステップ

はシミュレートされた検査対象として動作するため、ハードウェアは

使用しません。 ただし、ナショナルインスツルメンツの任意波形発生

器、関数発生器、ダイナミック信号アナライザ、またはマルチファン

クション I/O (MIO) デバイスから生成される物理チャンネルをス

イープすることもできます。

3. 左に示すステップを追加ボタンをクリックし、実行制御→スイープを

選択します。
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4. 図 6-1 のように、ステップ設定ダイアログボックスの追加ボタンをク

リックし、プロジェクトの各ステップのスイープパラメータのリスト

を表示します。

図 6-1 スイープパラメータ選択ダイアログボックス

5. アナログ信号を作成から周波数パラメータを選択し、OK ボタンをク

リックします。

「スイープ」ステップは、スイープする信号を提供する「アナログ信

号を作成」ステップを囲みます。

6. スイープ構成タブのタイププルダウンメニューから指数を選択しま

す。

7. 開始周波数 (Hz) フィールドに 1k と入力し、停止周波数 (Hz) フィー

ルドに 40kと入力します。
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8. ポイント数フィールドに 150と入力します。

図 6-2 のようなスイープ構成タブが表示されます。

図 6-2 スイープステップ設定ダイアログボックス

「スイープ」ステップを使用し、「アナログ信号を作成」ステップの周

波数パラメータを介して反復する値の範囲を指定します。 「信号を作

成」ステップでは、定義された周波数範囲を元に、各周波数で正弦波

を生成します。周波数以外のパラメータをスイープさせることも可能

です。

9. スイープ出力タブをクリックします。

10. 追加ボタンをクリックし、プロジェクトの各ステップのスイープ出力

リストを表示します。

11. フォーミュラから応答振幅 (dB) 出力を選択し、OK ボタンをクリッ

クして、スイープされた周波数パラメータに対してこの測定をプロッ

トします。

スイープ操作で使用するステップをすべて含めるため、「スイープ」

ステップはループを作成してプロジェクトビューの全ステップを囲み

ます。
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スイープの結果をプロットする

スイープ計測を実行するには、以下の手順に従ってください。

1. 左に示す 1 回実行 ボタンをクリックし、スイープ計測を実行します。

グラフ上の刺激信号の出力は、指定された周波数範囲で繰り返し出力

されます。

2. スイープループの下の応答振幅 (dB) vs. 周波数信号をデータビューに

ドラッグし、スイープの出力を表示します。

新規でグラフが作成されます。 図 6-3 のように、スイープ操作のデー

タは、異なるグラフを必要とする x-y 配列です。

図 6-3 Sweep.seproj

3. 1 回実行ボタンをもう一度クリックし、スイープを実行します。

プロジェクトの実行中に、新規グラフで「フィルタ」ステップの周波

数応答（振幅 (dB) 対周波数）がプロットされます。 周波数に対する

デシベルで表される振幅の出力、またはフィルタの転送関数がグラフ

に表示されます。
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4. 「フィルタ」ステップをダブルクリックし、ステップ設定ダイアログ

ボックスでフィルタ仕様を表示します。

フィルタ振幅応答グラフにある周波数応答が、データビューのグラフ

と一致します。

5. ファイル→プロジェクトを別名で保存を選択し、プロジェクトを My 
Sweep.seprojという名前で SignalExpress¥Examples¥

Tutorialディレクトリに保存します。

 スイープステップ設定ダイアログボックスのスイープ構成タブに別のパ

ラメータを追加することで、「スイープ」ステップを使用し、複数のパラ

メータを同時にスイープすることができます。 複数のパラメータを同時に

スイープすることを、平行スイープと呼びます。 たとえば、刺激信号の振

幅と周波数を両方スイープさせることが可能です。 また、平行スイープ

は、信号レベルを変更するたびにデジタイザや MIO デバイスの入力範囲

を変更することで、集録の精度を最大限にできます。 信号レベルが上昇し

たら、測定デバイスの入力範囲を広げれば、その測定に計測器がもつ分解

能をフルに活かすことができます。

多次元掃引（スイープ）を実行する

多次元（またはネスト化した）スイープを使用し、2 つのパラメータを順

番にスイープさせることが可能です。 たとえば、刺激信号の周波数を様々

な振幅でスイープする場合には、ネストスイープを実行します。 振幅をレ

ベル 1 に設定して様々な周波数でスイープし、今度は振幅をレベル 2 に

設定して様々な周波数でスイープする、というようなことができます。 ネ
ストスイープは、プロジェクトで「スイープ」ステップを右クリックし、

ショートカットメニューから次元を追加を選択し、別のスイープループを

追加すると作成できます。 

ネストスイープのサンプルプロジェクトを実行するには、以下の手順に

従ってください。

1. ファイル→プロジェクトを開くを選択し、SignalExpress¥

Examples¥Tutorialディレクトリを参照して、Nested 
Sweep.seprojをダブルクリックします。
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2. 左に示す実行ボタンをクリックし、プロジェクトを実行します。

内側のスイープループの各反復は、刺激信号の周波数をスイープしま

す。 外側のスイープループは、「フィルタ」ステップのカットオフ周

波数の上限と下限を変化させます。 図 6-4 のように、まず上のグラフ

に各反復がリアルタイムに表示されます。下のグラフには、各カット

オフ周波数設定のスイープがすべて表示されます。

図 6-4 Nested Sweep.seproj

3. 左に示す停止ボタンをクリックし、プロジェクトを停止します。
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7
LabVIEW で LabVIEW 
SignalExpress プロジェクト
を拡張する

LabVIEW SignalExpress では、信号の集録、生成、解析、またはログの

標準ステップを使用し、自動計測を定義することができます。 以下の方法

で、LabVIEW を使用して LabVIEW SignalExpress プロジェクトの機能

を拡張できます。

• カスタムステップの機能を提供し、LabVIEW SignalExpress で使用

可能なステップ数を拡張するには、LabVIEW で VI を作成し、この

VI を LabVIEW SignalExpress にインポートします。

• LabVIEW SignalExpress プロジェクトを LabVIEW のブロックダイ

アグラムに変換すると、LabVIEW で開発を継続できます。

本章の演習問題には、LabVIEW 7.1 以降のバージョンが必要です。

LabVIEW の VI をステップとして LabVIEW 
SignalExpress にインポートする

LabVIEW SignalExpress の「LabVIEW の VI を実行」ステップを使用す

れば、カスタム仕様の LabVIEW の VI を呼び出すことができます。

LabVIEW SignalExpress から LabVIEW の VI を呼び出すことにより、

以下の操作が可能です。

• GPIB 計測器を制御する

• LabVIEW SignalExpress がサポートしないナショナルインスツルメ

ンツのハードウェアを制御する

• 多様なファイル形式のデータを読み書きする

• 操作説明をポップアップダイアログボックスに表示する

• 測定アルゴリズムを定義する
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「LabVIEW の VI を実行」ステップで LabVIEW から VI をインポートす

るには、以下の手順に従ってください。

1. ファイル→プロジェクトを開くを選択し、SignalExpress¥
Examples¥Tutorialディレクトリを参照して、User Step.seproj
をダブルクリックします。

このプロジェクトでは、「アナログ信号を作成」ステップで信号を生

成します。

2. ステップを追加ボタンをクリックして、LabVIEW の VI を実行→

LabVIEW 8.2 の VI を実行を選択します。 
この演習で実行する VI は LabVIEW 8.2 で保存されました。 VI を保存

した LabVIEW のバージョンに一致する「LabVIEW の VI を実行」

ステップのバージョンを使用する必要があります。

3. ステップ設定ダイアログボックスの参照ボタンをクリックし、

LabVIEW SignalExpress¥Examples¥Tutorialディレクトリにあ

る Limiter-LV82.viを選択します。 Limiter-LV82 VI は時間領域波形

を入力として受け入れ、ステップ設定ダイアログボックスで指定した

信号範囲の上限を超えた値と下限を下回った値をクリップし、クリッ

プした波形を出力信号として返します。

LabVIEW の VI をインポートする際、LabVIEW SignalExpress で
は、VI の入力はパラメータとして、そして VI の出力は出力信号とし

てマップされます。

VI の入力は入力信号またはパラメータのどちらかに定義できます。 プ
ロジェクトビューでは、入力信号はステップに入力として表示される

ので、信号を入力として VI に渡すことができます。 パラメータは、

ステップのステップ設定ダイアログボックスで構成できる値です。 
「スイープ」ステップを使用すると、動的にパラメータをスイープす

ることもできます。 このプロジェクトでは、VI に入力信号の時間波形

入力、およびスカラパラメータの上限と下限があります。
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図 7-1のようなステップ設定ダイアログボックスが表示されることを

確認してください。

図 7-1 Limiter VI ステップ設定ダイアログボックス

4. 左に示す実行ボタンをクリックし、プロジェクトを実行します。 

5. 「Limiter.vi」ステップからクリップされた波形出力の出力信号をデー

タビューにドラッグします。

6. 「Limiter.vi」ステップをダブルクリックし、ステップ設定ダイアログ

ボックスを表示します。

7. 構成 VI タブを選択し、VI を表示します。 

8. 上限および下限フィールドに新しい値を入力します。 たとえば、上限

フィールドに 100と入力します。

9. 指定した変更の通りに、データビューのクリップされた波形出力信号

が変更されます。

LabVIEW SignalExpress における LabVIEW の VI の使用方法や、

LabVIEW SignalExpress と正しく動作する VI の作成方法についての詳細

は、『LabVIEW SignalExpress ヘルプ』を参照してください。
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LabVIEW SignalExpress プロジェクトを LabVIEW
のブロックダイアグラムに変換する

LabVIEW SignalExpress は、LabVIEW SignalExpress プロジェクトを

LabVIEW のブロックダイアグラムに変換できます。

メモ LabVIEW SignalExpress プロジェクトを LabVIEW の VI に変換するには、

LabVIEW 7.1 開発システム以上が必要です。

LabVIEW SignalExpress プロジェクトを LabVIEW のブロックダイアグ

ラムに変換するには、以下の手順に従ってください。

1. ファイル→プロジェクトを開くを選択し、SignalExpress¥

Examples¥Tutorial¥Solutionsディレクトリを参照して、

My First Project.seprojをダブルクリックします。

2. ツール→コード生成→ LabVIEW ダイアグラムを選択します。

3. 新しい LabVIEW の VI のファイル名と場所を指定し、OK ボタンを

クリックします。

LabVIEW のブロックダイアグラムの結果は、LabVIEW 
SignalExpress でプロジェクトの実行に反映されます。 LabVIEW の

ブロックダイアグラムは、配線された LabVIEW Express VI から構成

されます。 各 Express VI は、LabVIEW SignalExpress プロジェクト

のステップに相関します。 Express VI をダブルクリックすると、

LabVIEW SignalExpress と同じステップ設定ダイアログボックスを

表示できます。 また、Express VI を右クリックし、ショートカットメ

ニューからフロントパネルを開くを選択すると、Express VI を
LabVIEW のサブ VI に変換できます。 ブロックダイアグラムを表示

し、LabVIEW のブロックダイアグラムでの実行状況の確認や VI の
機能変更を行うことができます。 Express VI をサブ VI に変換する場

合、そのサブ VI を Express VI に戻すことはできません。

メモ LabVIEW SignalExpress プロジェクトをロギングで変換する場合、LabVIEW 
SignalExpress は 1 つの Express VI を持つ LabVIEW のブロックダイアグラム

を生成します。 生成された Express VI はサブ VI に変換できません。
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詳細情報

LabVIEW SignalExpress の詳細については、以下のリソースを参照して

ください。

LabVIEW SignalExpress サンプルプロジェクト

LabVIEW SignalExpress には、多くの機能を搭載した様々なサンプルプ

ロジェクトが付属しています。 これらのプロジェクトは SignalExpress¥
Examplesディレクトリにあります。 これらのサンプルを参照すれば、さ

らに多くの LabVIEW SignalExpress の機能の習得、および必要条件に近

いプロジェクトでの作業開始が可能です。

LabVIEW SignalExpress でハードウェアを使用する

本書では、LabVIEW SignalExpress がナショナルインスツルメンツ製の

信号集録や信号生成の多様なハードウェアをサポートしているため、

LabVIEW SignalExpress からハードウェアを制御する方法を記載してい

ません。 ナショナルインスツルメンツの MIO デバイス、ダイナミック信

号集録デバイス、高速デジタイザ、任意波形発生器、関数発生器デバイス

を使用して、LabVIEW SignalExpress でアナログ信号の生成や集録を行

うことができます。 また、デバイス間でクロックを共有や信号をトリガす

ることで、システムで複数デバイスを同期化することもできます。 
LabVIEW SignalExpress でハードウェアを使用する詳細については、

ヘルプ→ LabVIEW SignalExpress ヘルプを選択し、『LabVIEW 
SignalExpress ヘルプ』を参照してください。

ウェブリソース

サンプルプロジェクト、技術関連ドキュメント、LabVIEW 
SignalExpress で使用する LabVIEW の VI などのリソースについては、

ナショナルインスツルメンツのウェブサイト ni.com/jp/

signalexpressを参照してください。

http://www.ni.com/signalexpress
http://www.ni.com/signalexpress
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技術サポートおよびその他のサービスについては、ナショナルインスツル

メンツのウェブサイト (ni.com/jp) の下記のセクションを参照してくだ

さい。

• サポート―オンライン技術サポート (ni.com/jp/support) には以下

のリソースがあります。

– セルフヘルプリソース―質問に対する回答やソリューションが必
要な場合は、ナショナルインスツルメンツのウェブサイトをご参
照ください。ソフトウェアドライバとアップデート、検索可能な
技術サポートデータベース、製品マニュアル、トラブルシュー
ティングウィザード、種類豊富なサンプルプログラム、チュート
リアル、アプリケーションノート、計測器ドライバなどをご利用
いただけます。

– 技術サポート―ユーザ登録をされますと、基本的なサービスを無
償でご利用いただくことができます。ni.com/jp/dforumから
アクセスできる NI ディスカッションフォーラムでは、アプリ
ケーションエンジニアに対するご質問を承ります。 お尋ねいただ
きましたご質問には、ナショナルインスツルメンツのアプリケー
ションエンジニアが必ず回答いたします。

ご利用の地域のその他の技術サポートオプションについては、
ni.com/jp/servicesをご覧いただくか、または ni.com/jp/
contactから最寄りの営業所までお問い合わせください。 

• トレーニングと認定―自習形式のコースキットやインストラクタによ

る実践コースなどのトレーニングおよび認定プログラムについては、

ni.com/jp/training 参照してください。

• システムインテグレーション―時間の制約がある場合や社内で技術リ

ソースが不足されている場合、または、プロジェクトで簡単には解消

しない問題がある場合などは、ナショナルインスツルメンツのアライ

アンスパートナーによるサービスをご利用いただけます。 詳しくは、

最寄りの NI 営業所にお電話いただくか、ni.com/jp/allianceを

ご覧ください。

NI のウェブサイト (ni.com/jp) を検索しても問題が解決しない場合は、

最寄りの営業所またはナショナルインスツルメンツ本社までお問い合わせ

ください。 世界各地の弊社営業所の連絡先は、このドキュメントの巻頭に

掲載されています。 ni.com/niglobal（英語）にある Worldwide 
Offices のセクションから、各支社のウェブサイトへアクセスすることも

http://ni.com/jp
http://ni.com/jp/support
http://ni.com/jp/dforum
http://ni.com/jp/services
http://ni.com/jp/contact
http://ni.com/jp/contact
http://ni.com/jp/training
http://ni.com/jp/alliance
http://ni.com/niglobal
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できます。このウェブサイトでは、お問い合わせ情報、サポートの電話番

号、電子メールアドレス、および現行のイベント等に関する最新情報をご

案内しています。
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